Closed Bug 258867 Opened 18 years ago Closed 14 years ago

non-animated favicons that are over 16k in file size won't save to bookmark cache

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 389273

People

(Reporter: mozbugs, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040910 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040910 Firefox/0.10

I have a slashdot, mozillazine, and zeldman bookmarks in my bookmarks toolbar.
Slashdot and Mozillazine pick up their icons fine, but zeldman's bookmark still
shows only the firefox's placeholder icon.  This happens despite after clicking
on the bookmark, both the page tab and the address bar pick up the icon.

Reproducible: Always
Steps to Reproduce:
0. Make a new tab in Firefox
1. Go to www.zeldman.com
1a. Observe both page tab and address bar display site icon
2. Bookmarks > Bookmark This Page
3. Place Bookmark on Bookmark Toolbar
4. Observe Bookmark on Bookmark Toolbar
5. Click on Bookmark
6. Observe zeldman's site reload
Actual Results:  
the zeldman Bookmark continues to show firefox's bookmark icon placeholder
rather than an icon that matches both the tab and the address bar.

Expected Results:  
the zeldman Bookmark shows zeldman's site icon on the bookmark in the Bookmark
Toolbar.

I closed down firebox and restarted, getting the same results.
Assignee: p_ch → vladimir
Product: Browser → Firefox
QA Contact: seamonkey.bookmarks → mconnor
I'm getting identical results on:
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Also with the following sites:
http://airbagindustries.com/
http://modulo26.net/daily/
http://www.alistapart.com/
confirmed.

the reason is that the file http://www.zeldman.com/favicon.ico is too large for
whatever stores the favicon in the bookmarks file.
i noticed this when i did the following.

i downloaded and installed the extention that allows me to select a favicon for
a bookmark that has none.
i downloaded http://www.zeldman.com/favicon.ico to my desktop
i used the extention mentioned above to make the bookmarks icon the one i
downloaded and saved to my desktop.
it gave me an error saying the file from http://www.zeldman.com/favicon.ico was
too large.

so..
i opened http://www.zeldman.com/favicon.ico with microangelo icon editor.
there was more than one icon in the file. multiple icons 16x16 and 32x32 all at
different color settings.. 256.. 16.. true color.. etc.
usually having a couple sizes or color settings isn't a problem but this icon
had just about every combination imaginable.. and it was very redundant on Mr.
Zeldmans part.

i've just checked http://airbagindustries.com/favicon.ico and same thing..
it COULD be that these icons have a windows XP color setting that uses alpha
transparency.
alpha transparency dosen't seem to have any effect on this either way.
it seems to just be the size of the favicon.ico file is just too large to be
stored in the cache.

is there a way to increase the maximum file size that gets stored in the cache?

how can i change the status of this bug from unconfirmed to confirmed?
the title on the bug should probably be changed to something more along the
lines of "Favicon that is too large in file size won't save to bookmark cache"
just correcting comment 4, and cross-posting from Brian's comment on bug 252401
comment 8.

Apparently, this bug is in direct opposition to bug 252401's current fix, which
is simply to not to cache favicons over 16k.

Brian, thanks for the detective work.

retitling bug per comment 3.

was:
zeldman's site icon appears in page tab and address bar but not in bookmark toolbar

is now:
non-animated favicons that are over 16k in file size won't save to bookmark cache

(as if I, myself, knew what's going on)


Summary: zeldman's site icon appears in page tab and address bar but not in bookmark toolbar → non-animated favicons that are over 16k in file size won't save to bookmark cache
Depends on: 252401
*** Bug 260178 has been marked as a duplicate of this bug. ***
Assignee: vladimir → vladimir+bm
*** Bug 278174 has been marked as a duplicate of this bug. ***
Assignee: vladimir+bm → nobody
Workaround:
I've made a workaround extension to pick up 16x16 icon from multiple icons in one ICO file and discard others. See bug 175787 comment #43.
This bug seems reproducibile on TechConnect Magazine (www.tcmagazine.info).

The favicon is about 30 kb.
*** Bug 326678 has been marked as a duplicate of this bug. ***
Attached image test image
Use this code:


<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">
  <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type">
  <title>Favicon test page</title>
</head>
<body>
<span style="font-weight: bold;">Favicon test page<span style="font-weight: bold;"></span></span>
</body>
</html>
Don't forget to refresh the page after saving the bookmark.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
*** Bug 351319 has been marked as a duplicate of this bug. ***
Dup of bug 389273?
Yeah. Looks like we bumped the max-size to 32K at some point, but 389273 as what will resolve the issue.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389273
You need to log in before you can comment on or make changes to this bug.