Last Comment Bug 260186 - No way to logout from a HTTP login in Firefox
: No way to logout from a HTTP login in Firefox
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Windows 2000
: -- enhancement with 8 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 289960 296200 298600 (view as bug list)
Depends on: 260839
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-18 02:31 PDT by David Balažic
Modified: 2008-05-26 12:55 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David Balažic 2004-09-18 02:31:18 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

After logging into a site with HTTP auth-basic ( or other HTTP auth ), there is
no way to logout ( make the browser forget the login ).
A logout button ( menu , keyboard shortcut ) is missing.
See same issoe on mozilla in bug 55181

Reproducible: Always
Steps to Reproduce:
Comment 1 Håvar I. Henriksen 2004-09-18 02:45:04 PDT
There is already an extension that does this:
http://mmcc.cx/mozilla/
http://mmcc.cx/mozilla/clearhttpauth.xpi
Comment 2 Peter van der Woude [:Peter6] 2004-09-18 04:03:17 PDT

*** This bug has been marked as a duplicate of 55181 ***
Comment 3 Daniel Veditz [:dveditz] 2005-04-11 18:02:20 PDT
the folks in bug 55181 are pretty adamant that it's fixed for the Suite,
reopening this as the Firefox UI bug since I couldn't find another. An extension
to do it is nice, but it's a legitimate request for inbuilt functionality.

A further refinement is bug 260839, the ability to log out of a single site.
Possibly that's all anyone would need, but one of the two would be good.
Comment 4 Daniel Veditz [:dveditz] 2005-04-11 18:06:25 PDT
*** Bug 289960 has been marked as a duplicate of this bug. ***
Comment 5 Jaime Mitchell (use bugmail@jaimem.org.uk for email) 2005-06-01 06:21:14 PDT
*** Bug 296200 has been marked as a duplicate of this bug. ***
Comment 6 David P James 2006-06-16 11:44:12 PDT
Mass edit: Changing QA to default QA Contact
Comment 7 Michael Wu [:mwu] 2006-07-21 14:48:35 PDT
*** Bug 298600 has been marked as a duplicate of this bug. ***
Comment 8 Mike Connor [:mconnor] 2008-05-26 12:36:43 PDT
This is long since fixed for the "log out of all authenticated sessions" case.
Comment 9 Gummi 2008-05-26 12:50:22 PDT
Description and comment 3 are clear that this is a UI bug.
There is no “logout” button in firefox that expires a particular http-auth session.

You need to reopen.
Comment 10 Gummi 2008-05-26 12:55:05 PDT
See bug 260839, my bad.

Note You need to log in before you can comment on or make changes to this bug.