Closed Bug 260424 Opened 17 years ago Closed 17 years ago

Can't apply message filters from one account to any other accounts

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 129883

People

(Reporter: evan, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040917 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040917 Firefox/0.9.3

It's not possible to apply a filter on one account to any other accounts. So if
I have a personal mail account and a work account, I have to have a filter on
each account just to put all my email from my Mom into the "Mom" folder.

A particularly sticky situation is if you've set up a lot of filters on a POP
account and then switch to using the Global Inbox. You have to recreate each
filter by hand, rather than just "reassigning" them to the Global Inbox.

Reproducible: Always
Steps to Reproduce:
1. Open the Message Filters dialog (Tools -> Message Filters...)
2. Try to figure out a way to copy a filter from one account to another.
3. Try to figure out a way to apply one filter to more than one account.

Actual Results:  
You cannot do it! Because there is no way!

Expected Results:  
Perhaps, instead of a combobox that selects filters for each account in the
Message Filters dialog, the accounts it applies to should be a multi-select list
box in the "Filter Rules" dialog for each filter. For example, with my "Mom"
filter, I'd pop open the filter rules and select both "Work" and "Personal" in
the "accounts to filter" list.

*** This bug has been marked as a duplicate of 129883 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.