Filters Should be Shareable Across Multiple E-mail Accounts

VERIFIED DUPLICATE of bug 34973

Status

enhancement
VERIFIED DUPLICATE of bug 34973
18 years ago
7 years ago

People

(Reporter: general, Unassigned)

Tracking

(Depends on 1 bug)

Dependency tree / graph
Bug Flags:
wanted-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [penelope_wants])

Attachments

(1 attachment, 4 obsolete attachments)

Reporter

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

It's a pain to set up a bunch of filters for one account
(secretaddressjustforfriends@host.com) and then have to go manually copy them to
the rules.dat file of another account (spamvictim@host.com). Why not change the
user interface or data structure for filters so that all filters are displayed
in one list, and the user can check a box for each account to which they should
apply?

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 34973 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
sorry.. - this is not an exact dup. Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

17 years ago
*** Bug 157507 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
*** Bug 160184 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
My suggestion in bug 160184 was that when you create a filter in one account, it
is copied to all accounts, but is left unchecked in the other accounts.

Doing it that way wouldn't require any UI changes.

Comment 6

17 years ago
OK I have been looking at the code, and now I see that the easiest way to do it
would probably be to change the 'new filter' dialog, and add a checkbox with the
title 'Copy to all accounts'.

I've had a go at creating a patch to do this. It's just the backend, the
checkbox itself still needs designing.

Maybe somebody could have a look at the patch and tell me if it looks OK.

Comment 7

17 years ago
Posted patch First attempt at patch (obsolete) — Splinter Review

Comment 8

17 years ago
Posted patch Second attempt at patch (obsolete) — Splinter Review
Attachment #93504 - Attachment is obsolete: true

Comment 9

17 years ago
Posted patch Third attempt (obsolete) — Splinter Review
Attachment #93507 - Attachment is obsolete: true

Comment 10

17 years ago
Posted patch Complete patch (obsolete) — Splinter Review
OK, I've tested this and it works.

It adds a checkbox next to the filter name 'copy to all email accounts'.
If you check the box, the filter is copied when you click OK to save the
filter.

If a filter of the same name already exists in another account, then a
duplicate won't be created.



Please can I get a review of this so I can check it in.
Attachment #93509 - Attachment is obsolete: true

Comment 11

17 years ago
Attachment #93654 - Attachment is obsolete: true

Updated

17 years ago
Keywords: patch, review

Comment 12

17 years ago
The tree/trunk is in lock down mode. I'll get to it when the tree opens. 

Comment 13

17 years ago
*** Bug 163475 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Tree should be open again now. Any chance of getting this patch reviewed ?

Two comments about the code:
1) Should we add copyToAll() to Edit as well ?
2) I don't understand why, but setting args.copyToAll causes args.refresh to be
ignored.

Comment 15

16 years ago
*** Bug 201044 has been marked as a duplicate of this bug. ***
mass re-assign.
Assignee: naving → sspitzer
*** Bug 197515 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
Isn't the best solution to have seperate global filters and account-specific
filters? I can only speak for myself, but having seperate list of filters for
each account is a bug, not a feature. 

Comment 19

15 years ago
*** Bug 236366 has been marked as a duplicate of this bug. ***

Comment 20

15 years ago
I partly agree with Jack Byer. Mail filters should be applied to all accounts by
default. The account should only be a possible but not mandatory condition of
every filter.

Adding myself to CC :)

Comment 21

15 years ago
Newbie here,

   I gather this has not been implimented for lack of interest.  True?
   It's two years old. 

Updated

15 years ago
Attachment #93655 - Flags: review?(neil.parkwaycc.co.uk)

Comment 22

15 years ago
Moz@L-Squared.biz: it looks to me like no one read the 
Life Cycle of a Patch (formerly "Hacking Mozilla")
<http://www.mozilla.org/hacking/life-cycle.html> document
Comment on attachment 93655 [details] [diff] [review]
Complete patch, minor change

I see you don't allow global edits, I assume this is because the existing
filter code isn't designed to overwrite arbitrary filters? Also there's no easy
way to tell if you copied the filter previously. The label is misleading
because your code will also copy to news and rss accounts. And I think any
copying code belongs in FilterEditor.js, although as other people mentioned a
global filter backend would be the most useful solution.
Attachment #93655 - Flags: review?(neil.parkwaycc.co.uk) → review-

Comment 24

15 years ago
(In reply to comment #22)
> Moz@L-Squared.biz: it looks to me like no one read the 
> Life Cycle of a Patch (formerly "Hacking Mozilla")
> <http://www.mozilla.org/hacking/life-cycle.html> document

Huh?  I read it, but I don't see the applicability to my question.  As I said,
I'm new here, I was curious why there was no update on the status, even though a
patch was submitted (I thought) two years ago.  I'm just trying to understand
how this system works.  I could not see any way to discover where things stood.

I'm not stupid, just ignorant.

Comment 25

15 years ago
by no one i actually meant gabriel@pixle.demon.co.uk

the relevant section is:
When you have a patch, submit it to Bugzilla as an attachment to that bug. 

<done>

We're big believers in code review, so before code is checked in to the CVS
Repository it must be reviewed by the appropriate module owner or one of his
peers. Modules do not quite directly correspond to Bugzilla Components, but
there is a strong correlation.

To get review:
<needs to be done>
    * Ask the bug owner (assignee) explicitly for a review by setting the review
flag for the patch to ? (indicating that review is requested) and entering the
email address of the person from whom you are requesting review.
<needed to be done>

Comment 26

15 years ago
Boy, I can see it will be a while before I "get" this system.

Quote:
   * Ask the bug owner (assignee) explicitly for a review by setting the review
flag for the patch to ? (indicating that review is requested) and entering the
email address of the person from whom you are requesting review.
<needed to be done>

How does one do that?  I don't see a "review flag".

Updated

15 years ago
Blocks: 66425

Comment 27

15 years ago
I would be very happy to see this feature realized. My opinion:

All filters should be set at one global place. You always see all defined
filters. I would not copy a filter for each account as suggested as this might
be necessary each time changing a filter and could be a problem when another
filter with the same name allready exists in another account.
The relevant accounts for each filter could be selected from a multiselect list
of all available accounts.
Two more buttons could make selection easier:
  "Set for default account"
  "Set for all accounts"

Comment 28

15 years ago
*** Bug 256495 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
*** Bug 247428 has been marked as a duplicate of this bug. ***
*** Bug 259513 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
>  "Set for default account"
>  "Set for all accounts"

No, this is the wrong way of doing it, because this takes out the possibility 
that a user wants to apply a filter ONLY for ONE account. Simply, do it as 
Outlook Express does it: the account should be one of the RULES.

That's the easiest way to go around all problems.

Comment 32

15 years ago
> No, this is the wrong way of doing it, because this takes out the possibility 
> that a user wants to apply a filter ONLY for ONE account.

No, the buttons should just make default selections easier. I also suggested:
"The relevant accounts for each filter could be selected from a multiselect list
of all available accounts." That should do exactly what you wrote.
However this doesn't need to be the best/easiest/most intuitiv way of course.
*** Bug 260424 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 34

15 years ago
I agree with an earlier comment - I think that the friendliest way to implement
this would be that in addition to all the "account specific" filters, there
should be a "Global Filters" section (which could perhaps be the one that comes
up by default).

Comment 35

14 years ago
This looks like a dup of bug 34793.

Comment 36

14 years ago
By the way, in bug 294632 (which I've now marked as a dup of 34973) I proposed
an alternate organization/UI for this feature, which I think is pretty reasonable.

Comment 37

14 years ago
(In reply to comment #36)
> By the way, in bug 294632 (which I've now marked as a dup of 34973) I proposed
> an alternate organization/UI for this feature, which I think is pretty 
> reasonable.

I agree. I think it's a more elegant solution to the problem.

One can simply add an option to folder-based filters so that the message was received on a certain account, and then one has the equivalent of account-based filters as needed.

Comment 38

13 years ago
*** Bug 330440 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Duplicate of this bug: 335644
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
QA Contact: laurel → filters
Duplicate of this bug: 332291

Updated

11 years ago
Flags: wanted-thunderbird3?
Product: Core → MailNews Core
Duplicate of this bug: 472415
wanted‑thunderbird3-; can't see us getting to this unless someone submits a working patch - which would be very welcome.
Flags: wanted-thunderbird3? → wanted-thunderbird3-

Updated

10 years ago
Duplicate of this bug: 401494

Updated

10 years ago
Whiteboard: [penelope_wants]

Updated

8 years ago
Duplicate of this bug: 570302

Comment 46

8 years ago
Actually, why is this not a dupe of bug 34973 ?
Depends on: GlobalFilters
(In reply to :aceman from comment #46)
> Actually, why is this not a dupe of bug 34973 ?

inclined to agree.
Status: NEW → RESOLVED
Closed: 18 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: GlobalFilters
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.