Last Comment Bug 261153 - if you click a link, move a link
: if you click a link, move a link
Status: VERIFIED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: x86 All
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://bugzilla.mozilla.gr.jp/attachm...
: 262556 267274 272368 (view as bug list)
Depends on: 209694
Blocks: 261196
  Show dependency treegraph
 
Reported: 2004-09-23 01:11 PDT by baffclan
Modified: 2004-11-30 19:23 PST (History)
16 users (show)
asa: blocking1.8a5-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (522 bytes, text/html)
2004-09-23 02:42 PDT, Martijn Wargers [:mwargers]
no flags Details
Smaller Testcase (150 bytes, text/html)
2004-09-23 19:35 PDT, Ronald Tilby
no flags Details

Description User image baffclan 2004-09-23 01:11:25 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040922
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040922

if you click a link, move a link

Reproducible: Always
Steps to Reproduce:
1. Open http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2386&action=view
2. Click a "click me!" link
Actual Results:  
move a "click me!"

Expected Results:  
Don't move a "click me!"

Original bug report in Bugzilla-jp is 
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=3980
Comment 1 User image Martijn Wargers [:mwargers] 2004-09-23 02:37:40 PDT
Confirmed, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; @AB_CD@; rv:1.8a4) Gecko/20040922
Firefox/0.9.1+
Comment 2 User image Martijn Wargers [:mwargers] 2004-09-23 02:42:53 PDT
Created attachment 159837 [details]
testcase

Basically the same as the url testcase, which is fine, but without the image.
Comment 3 User image baffclan 2004-09-23 07:09:01 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040905
Firefox/0.9.1+ and Netscape/7.2(Gecko/20040804)/WinXP have not this problem.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040919
Firefox/0.9.1+ have this problem.
Comment 4 User image Hideo Oshima 2004-09-23 08:12:09 PDT
2004092221-trunk/Linux+gtk2+xft has also this problem.
It's not dependent on OS.
Comment 5 User image Ronald Tilby 2004-09-23 19:35:39 PDT
Created attachment 159930 [details]
Smaller Testcase

Mozilla Nightly 2004092306 on Windows XP
Here's a smaller testcase.
Comment 6 User image Ronald Tilby 2004-09-23 21:33:09 PDT
I've narrowed the regression window.
Windows Mozilla Trunk Nightly 2004091105 is ok.
Windows Mozilla Trunk Nightly 2004091306 fails the testcases.

The mozilla-win32-installer.exe file at
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/2004-09-12-07-trunk/
fails to run for me after download, so I wasn't able to narrow window further.
Comment 8 User image Bernd 2004-09-23 22:50:48 PDT
I meant bug 258118
Comment 9 User image Bernd 2004-09-24 10:04:21 PDT
backing out the patch for bug 258118 fixes the smaller testcase.
Comment 10 User image Hermann Schwab 2004-09-26 14:19:11 PDT
same time of regression, similar testcase and fix, waiting for review:
Bug 260938  	mozdev's pages' middle-column drops below left column
same time of regression
Bug 260963  	bad rendering of the web page
Comment 11 User image Stephen Donner [:stephend] 2004-10-02 00:35:04 PDT
*** Bug 262556 has been marked as a duplicate of this bug. ***
Comment 12 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2004-11-02 17:25:36 PST
*** Bug 267274 has been marked as a duplicate of this bug. ***
Comment 13 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2004-11-11 14:17:06 PST
This is probably fixed by my big margin-collapse/clear patch in bug 209694.
Comment 14 User image Asa Dotzler [:asa] 2004-11-17 09:36:30 PST
ROC, we really do need to fix this for a5. Any chance of a fix independent of
your big patch at bug 261153. Or is it planned to land bug 261153?
Comment 15 User image Hermann Schwab 2004-11-17 10:53:19 PST
there is a fix waiting in 
Bug 260938 	[fix] mozdev's pages' middle-column drops below left column
In Bug 260938 comment 6 RoC told the fix is working, in Bug 260938 comment 12 he
did his own rewiew ;-)
> minusing because this work is completely subsumed by the work in bug 209694.

Comment 16 User image Robert O'Callahan (:roc) (email my personal email if necessary) 2004-11-17 11:23:08 PST
The fix in bug 260938 is a complete band-aid. I discovered the problems were
much deeper and took another tack. I don't know what that fix will do. We can
check it in if you want to find out :-)

Why is this bug critical for 1.8a5, by the way?
Comment 17 User image Asa Dotzler [:asa] 2004-11-18 11:33:09 PST
This is a regression that will cause a lot of people to avoid using and testing
this release. We're already skirting the low end of download numbers necessary
for good talkback and regression finding. 
Comment 18 User image Asa Dotzler [:asa] 2004-11-18 12:57:21 PST
sucking it up for 1.8a5. 
Comment 19 User image Per Ångström 2004-11-24 12:35:25 PST
For the record: this bug is still present in 1.8a5.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041121
Comment 20 User image Martijn Wargers [:mwargers] 2004-11-26 00:56:17 PST
Fixed by bug 209694
Comment 21 User image Hideo Oshima 2004-11-26 06:54:34 PST
I confired to fix this problem on Trunk/Linux.
Thanks.
Comment 22 User image Stephen Donner [:stephend] 2004-11-28 10:18:43 PST
Verified FIXED with all three testcases for me using build 2004-11-28-06 on
Windows XP Seamonkey trunk.
Comment 23 User image Stefan Borggraefe 2004-11-30 02:26:59 PST
*** Bug 272368 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.