"Sender" field in filter doesn't match "Sender" field in mail-header pane.

RESOLVED DUPLICATE of bug 221724

Status

--
enhancement
RESOLVED DUPLICATE of bug 221724
15 years ago
14 years ago

People

(Reporter: CarlPonder, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla Thunderbird version 0.8 (20040913)

The mail-header pane lists a "Sender" field, which can derive from various
fields in the mail message. For example, 

            From: "eBay" <eBay@reply3.ebay.com>
            From: eBay <eBay@reply3.ebay.com>

would both come out with "eBay" as the Sender, but setting

             Sender     is    eBay

would catch the second message but not the first. I can work around this
by adding a rule

             From        starts with         "eBay"

but this doubles the number of rules, and there may be other fields the
Sender can derive from and I would have to add even more rules.

I understand that the word "Sender" is being used to mean different things
in different places here, since a mail-message can actually *say*

               Sender: ...

though many mailers don't have this. What I'd really like is a

               Sender         is-apparently          eBay

where "is-apparently" matches what is printed in the mail-header pane.

Reproducible: Always
Steps to Reproduce:
1. Sign up for eBay.
2. Write filter "Sender is eBay"
3. Run the filter.

Actual Results:  
Message stayed in InBox.

Expected Results:  
Message should have been recognized and moved to eBay mail box.

Comment 1

15 years ago
What is wrong with using this?:
   Sender CONTAINS eBay
or even
   Sender CONTAINS ebay.com


> I understand that the word "Sender" is being used to mean different things
> in different places here, since a mail-message can actually *say*
> 
>                Sender: ...
> 
> though many mailers don't have this.

The Sender: header may have some special meaning; I've only noticed it in 
certain mailing-lists.  It is possible, but confusing, to add Sender to the 
custom header list, but then "Sender" appears twice in the header dropdown; see 
bug 40934.
(Reporter)

Comment 2

15 years ago
The problem with "contains" is that it's too broad. For example,

     Sender contains Adam Clayton

will match

     "Adam Clayton Powell"

so I'd have to add a bunch of AND-qualifiers to prevent this, and my set of
rules will get even larger than it is.

The whole point of (re?) raising this issue is that the Sender field, as listed
in the Thunderbird mail-header window, uses a good heuristic to identify the
source of the mail-message, and I would like to use this in building my rules
instead of having to multiply-out my rules in order to capture all the
possibilities.

Probably the biggest problem is that the "Sender" identification is smart enough
to drop the ""'s from the name that comes before the <address> part at the send,
but the filters don't have a way to do this beyond doubling all the rules to
include the ""'d and non-""'d forms, or by relaxing the rules so they match
other things as well.

On a side-note, I could remove a lot of rules if there were options

         Sender/To       ....     ....
         Sender/To/CC    ....     ....

which would cover *all* correspondences with a particular person; as it is, I
have to add a bunch of explicit rules for this and it's a pain to keep track of,
given that I keep having to add special-cases for all the addressing forms that
map to the same thing in the "Sender" column.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 221724 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.