Last Comment Bug 263446 - Make the EULA accessible in a sane manner to people who don't understand English
: Make the EULA accessible in a sane manner to people who don't understand English
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://wiki.mozilla.org/User:Beltzner...
Depends on:
Blocks: 326580
  Show dependency treegraph
 
Reported: 2004-10-08 01:16 PDT by Pavel Franc - Mozilla.cz
Modified: 2013-04-19 13:20 PDT (History)
24 users (show)
mconnor: blocking‑firefox2-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Pavel Franc - Mozilla.cz 2004-10-08 01:16:35 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

The LICENSE file contains english preamble about no rights to trademarked stuff.
More over we used to a short paragraph in Czech with summary of the licence
which must remain in english. So the Czech users aren't comfused with the
english text in the installer and needn't to agree with something they have no
clue about.

Reproducible: Always
Steps to Reproduce:
Comment 1 Pavel Franc - Mozilla.cz 2004-10-08 01:19:38 PDT
Related bug 246011
Comment 2 Pavel Franc - Mozilla.cz 2004-10-08 01:26:11 PDT
Related bug 260806
Comment 3 Gervase Markham [:gerv] 2005-09-27 01:46:44 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 4 Vidar Haarr (not reading bugmail) 2005-09-27 08:27:10 PDT
This bug is not "in state UNCONFIRMED", as required by
<http://www.mozilla.org/quality/auto-resolve.html>.
Comment 5 Kadir Topal [:atopal] 2005-09-27 08:34:15 PDT
Still a big problem.
Comment 6 Kadir Topal [:atopal] 2005-09-27 08:35:23 PDT
The Status was just changed.
Comment 7 Reed Loden [:reed] (use needinfo?) 2005-12-17 02:19:42 PST
Actually, the EULA explains everything about this. From a look at Fx's installer files, it uses browser/EULA as a license file, which mentions that people can go to www.mozilla.org/licensing/ to see translations of the EULA.
Comment 8 Andras Timar 2005-12-17 02:26:55 PST
This is of no use for people who do not understand English.
Comment 9 Reed Loden [:reed] (use needinfo?) 2005-12-17 02:28:40 PST
CC'ing the right people.
Is this still something that should be done or just leave it as the EULA only or what?
Comment 10 Pavel Franc - Mozilla.cz 2005-12-21 01:56:35 PST
Updating the summary and the URL.

IMHO the optimal solution would be to move the first EULA sentence
"FOR TRANSLATIONS OF THIS LICENSE INTO SELECTED LANGUAGES, PLEASE VISIT WWW.MOZILLA.ORG/LICENSING." out of the EULA into setup UI and localize it.



Comment 11 Gervase Markham [:gerv] 2005-12-23 05:09:15 PST
The key question here is whether we can get legally-binding official translations of the EULA which lawyers have vetted, or whether we can do unofficial translations which state that the English version is authoritative. The latter is, of course, much easier.

How about this: the EULA file for localised builds contains first the translated EULA and then a divider and the English one. The first line of the translation could read (in the translated language):

[This is an unofficial translation of the Firefox EULA into &lt;language&gt;. It does not legally state the license terms for this copy of Firefox--only the original English text of the EULA, which is included below, does that. However, we hope that this translation will help &lt;language&gt; speakers understand the Firefox EULA better.]

(This text is adapted from similar text used on translations of the GPL: http://www.gnu.org/licenses/translations.html)

Whatever we do, we'd need Chris Beard's signoff.

Gerv
Comment 12 Vidar Haarr (not reading bugmail) 2005-12-23 05:26:34 PST
This bug is not about translating the EULA itself - or, in fact, the first sentence of the EULA; it's about translating the first sentence in the textbox containing the EULA, as noted in comment 10:

"FOR TRANSLATIONS OF THIS LICENSE INTO SELECTED LANGUAGES, PLEASE VISIT
WWW.MOZILLA.ORG/LICENSING."

The point being that if you do not understand english, you don't understand that either.

As it's not part of the EULA itself, but really only a label, and could be moved out of the EULA text and into a XUL <label> making it easily translatable, as also noted in comment 10, we should just do that here - and it would not require signoff from cbeard, AFAIK.
Comment 13 Vidar Haarr (not reading bugmail) 2005-12-23 05:29:57 PST
So there could potentially be 3 different kinds of EULAs in the installer:
1. Lawyer-vetted localized EULAs.
2. Unofficial translations, clearly marked as such.
3. en-US EULA with "FOR TRANSLATIONS OF THIS LICENSE INTO SELECTED LANGUAGES, PLEASE VISIT WWW.MOZILLA.ORG/LICENSING." in a label.

This bug is about #3, I think. Gervs comment is about #1 and #2.
Comment 14 Gervase Markham [:gerv] 2005-12-23 06:41:58 PST
Regarding comment #10: if you are installing a browser, it's not much use saying "browse to this website to read the terms under which you can use this software"! 

There is not much point translating that sentence unless a copy of the EULA in the target language exists on www.mozilla.org. And, if it exists, why shouldn't it be shipped in the Firefox package anyway? So option 3 is not a sensible option.

Currently, the EULA is only available in English and Japanese (http://www.mozilla.org/foundation/EULA/), so this bug isn't actually all that relevant. Even if you translate the sentence in question into Slovak or Portuguese, if the person doesn't understand English, visiting that URL isn't going to help them much anyway.

If we want to make the EULA accessible in a sane manner to people who don't understand English, we should a) translate it and b) ship it rather than make them browse to it.

Gerv
Comment 15 Pavel Franc - Mozilla.cz 2005-12-23 10:25:06 PST
> it be shipped in the Firefox package anyway? So option 3 is not a sensible
> option.

I agree that #3 is not very sensible but it is a little bit better then the present situation, and it is easy to fix it. So my intention was to try this small fix first. If we can do even better i.e. #2 or #3, I would definitely vote for it.

Adjusting the summary again.
Comment 16 Gervase Markham [:gerv] 2005-12-29 02:21:17 PST
OK, here's what I'll do. I'll email cbeard and mitchell to try and get them to sign off on the idea of unofficial EULA translations. If they say yes in a sensible amount of time, let's implement plan #2. Otherwise, we'll do plan #3.

Gerv
Comment 17 Kadir Topal [:atopal] 2005-12-29 02:35:22 PST
Okay, but who is going to do the translations? It's one thing to translate software menu items, but it's another to translate legal texts. That's not to say that the localization teams wouldn't do it, but I for one definitly wouldn't feel comfortable translating something that sensitive.
Comment 18 Gervase Markham [:gerv] 2005-12-29 02:51:22 PST
Abdulkadir: that's why we are making them unofficial and labelling them as such. 

We don't want localisers to feel that they are taking on legal risk or having to meet a very high standard of accuracy in that way. I hope that l10n teams would be happy to translate the EULAs unofficially, in the spirit of helping their fellow language-speakers understand it better.

Gerv
Comment 19 Pavel Franc - Mozilla.cz 2005-12-29 03:26:28 PST
> software menu items, but it's another to translate legal texts. That's not to
> say that the localization teams wouldn't do it, but I for one definitly
> wouldn't feel comfortable translating something that sensitive.

The unofficial Czech translation was made by one Czech law office (eadvokacie.cz) who did it as a gift to the community + some propagation from our community web page. 
Comment 20 Gervase Markham [:gerv] 2005-12-29 04:04:46 PST
Pavel: cool - that sort of thing certainly doesn't hurt :-)

Gerv
Comment 21 Gervase Markham [:gerv] 2005-12-29 06:00:05 PST
Chris is out of the office until January 5th; but I might get a reply from Mitchell before then.

Gerv
Comment 22 Gervase Markham [:gerv] 2006-01-05 03:27:45 PST
OK, we have a legal green light for unofficial localised EULAs. I anticipate that this will work as follows:

* Any localisation team may, if they wish, localise the Firefox and/or Thunderbird EULA.

(Note that the two documents are identical in all the numbered sections (1-8) and the sole difference in the first three unnumbered paragraphs is the name of the product. So the two documents are almost identical.)

* The localised EULA must state the following at the top, in the target language:

"[This is an unofficial translation of the <product> EULA into <language>.
It does not legally state the license terms for this copy of <product> - only the original English text of the EULA, which is included below, does that. However, we hope that this translation will help <language> speakers understand
the <product> EULA better.]"

This should mean that the localisers incur no legal risk by doing the localisation. If localisers are able to obtain legal help to do or to review their translation, so much the better. (However, they should not claim to be officially representing the Foundation when asking.)

* The localised EULA can then be shipped in the EULA file of the localised build, with the English EULA appended below, separated by a divider of some sort.

(I don't know if having multiple copies of the EULA requires technical changes to the build system.)

* The localised EULA file can also be posted on the website. The introductory paragraph is changed to make "original English text of the EULA" a hyperlink to the English EULA, and the phrase "which is included below" is removed.

I hope this plan is satisfactory. Localise away! :-)

Gerv
Comment 23 Ahmet Serkan Tıratacı 2006-01-05 10:32:28 PST
> * The localised EULA must state the following at the top, in the target
> language:
> 
> "[This is an unofficial translation of the <product> EULA into <language>.
> It does not legally state the license terms for this copy of <product> - only
> the original English text of the EULA, which is included below, does that.
> However, we hope that this translation will help <language> speakers understand
> the <product> EULA better.]"
> 
> This should mean that the localisers incur no legal risk by doing the
> localisation.

Can we add that [a] "the localisers incur no legal risk by doing the localisation of EULA" and that [b] "Mozilla Corporation (or Mozilla Foundation) is the one who users should speak to when there's a case", as [a] is not mentioned anywhere.
Comment 24 Gervase Markham [:gerv] 2006-01-12 03:30:06 PST
> Can we add that [a] "the localisers incur no legal risk by doing the
> localisation of EULA"

We cannot make that statement, because we cannot be completely certain it is true. Being certain that it is true would require an exhaustive legal analysis in every country, which would be far more effort than doing an official translation.

In any sane legal system, labelling a translation of a document is unofficial and saying "the official version is over here, and takes precedence" would be fine. Lots of people do it, all over the web. But we can't make a blanket statement indemnifying translators, in the same way that we don't indemify you if you translate Firefox in such a way that someone loses money (for a far-fetched example, mixing round the Submit and Cancel translations, and someone accidentally sends some money to someone when they didn't mean to). 

If translators feel that they are at legal risk from doing a clearly-labelled unofficial translation, then they shouldn't do it. I believe the risk is negligible in any sane jurisdiction, but I'm not being paid to give you official legal advice :-)

> and that [b] "Mozilla Corporation (or Mozilla Foundation)
> is the one who users should speak to when there's a case"

I believe [b] is covered by the original EULA language.

Gerv
Comment 25 Pavel Franc - Mozilla.cz 2006-01-13 07:47:04 PST
> (I don't know if having multiple copies of the EULA requires technical changes
> to the build system.)

I investigated this, and I guess that it would be enough to hack the perl script responsible for the installer.

http://lxr.mozilla.org/mozilla1.8/source/toolkit/mozapps/installer/makeall.pl#194 

where 

$licenseLocation is set to "browser/EULA" or "mail/LICENSE.txt"
$versionLanguage is set to ab-CD (i.e. the locale name)

Instead of simple copy(,) || die() we have to check the existence of $topsrcdir/../l10n/$versionLanguage/$licenseLocation, and if this file exists we need to join it with the separation line and the original en-US license.

After that, it would be enough to put the translated license into l10n
browser/mail directory.

Comment 26 Benjamin Smedberg [:bsmedberg] 2006-01-13 07:53:18 PST
> I investigated this, and I guess that it would be enough to hack the perl
> script responsible for the installer.

Unfortunately not: makeall.pl is only used when we make the original en-US builds: the localized builds are created by repackaging this en-US build, and so we need to build this code into the repackaging step.

However, unless we're planning on doing this work for firefox 1.5.0.x (which I don't think we should be considering), please don't worry about it. We're planning a new installer for Firefox 2 that will have a significantly different build setup. (See bug 322206).
Comment 27 Axel Hecht [pto-Aug-30][:Pike] 2006-01-13 07:59:00 PST
http://wiki.mozilla.org/User:CBeard:Fx2_EULA_Requirements has requirements for
this.
Comment 28 Pavel Franc - Mozilla.cz 2006-06-24 02:20:03 PDT
The new NSIS installer could take care of this. For the localised EULA scenario see comment 22.
Comment 29 Mike Connor [:mconnor] 2006-06-24 22:53:05 PDT
Nice to have, but not a blocker.  We're still planning on doing the same repackaging magic for locales, so its pretty hard to claim that the NSIS installer can/will fix this.
Comment 30 Robert Strong [:rstrong] (use needinfo to contact me) 2006-06-25 16:02:34 PDT
For the standard installer this is just having the build process move the EULA for the locale into the directory where we build the installer, using iconv to convert it to the correct code page, and naming the file license.txt. For multi-language installers (see bug 342240) this will take more of an effort but should be do-able.
Comment 31 Gervase Markham [:gerv] 2008-06-09 09:41:19 PDT
We now ship the EULA in various languages:
http://www.mozilla.com/en-US/legal/eula/

I don't know what the plan is for Firefox 3, where the EULA is presented on first run. Does everyone get the English EULA? Are we doing translations? Axel? Chris?

Gerv
Comment 32 Pascal Chevrel:pascalc(PTO until Sept 2) 2008-06-09 09:52:50 PDT
AFAIK, there is no translation of the EULA since it is a legal document and this translation work should be validated by a lawyer speaking the language in which it is translated. Most (all?) of the translations we have today are inherited from netscape.
Comment 33 Gervase Markham [:gerv] 2008-06-10 01:26:48 PDT
Pascal: there are several translations of the Firefox EULA at:
http://www.mozilla.com/en-US/legal/eula/
These clearly can't have been inherited from Netscape. 

The Dutch one, at least, is marked as unofficial. But that's fine. Better an unofficial document people can read than an official one they can't.

Harvey: do plans exist for EULA translations (official or unofficial) for Firefox 3?

Gerv
Comment 34 Francesco Lodolo [:flod] 2008-06-10 01:42:44 PDT
> Pascal: there are several translations of the Firefox EULA at:
> http://www.mozilla.com/en-US/legal/eula/
> These clearly can't have been inherited from Netscape. 

The quality of the Italian localization of the EULA, as we already pointed out in the past, is really far from good.(In reply to comment #33)

https://bugzilla.mozilla.org/show_bug.cgi?id=358758
Comment 35 Axel Hecht [pto-Aug-30][:Pike] 2008-06-10 01:44:13 PDT
bug 432169 is the closest I found to actually put the v3 eula on mozilla.com in the first place.

      
Comment 36 Reed Loden [:reed] (use needinfo?) 2008-06-10 01:47:44 PDT
(In reply to comment #35)
> bug 432169 is the closest I found to actually put the v3 eula on mozilla.com in
> the first place.

You actually want bug 432167. :)
Comment 37 Giuliano Masseroni [:jooliaan] 2008-06-10 01:47:52 PDT
The Italian EULA http://www.mozilla.com/en-US/legal/eula/firefox2-it.html for Fx 2 has a wrong encoding. All the à è é ì ò ù (even in capital letters) are shown as a weird symbols. If you're planning to use it also for Fx 3 please fix this issue.
Comment 38 :Paolo Amadini 2013-04-19 13:20:04 PDT
I think the issues discussed in this old "Build Configuration" bug may be no
longer relevant to the latest version of Firefox, or may need more context.
The page at http://www.mozilla.org/legal/eula/ currently says:

Mozilla software is made available to you under the terms of the Mozilla Public License 2, a free software license, which gives you the right to run the program for any purpose, to study how it works, to give copies to your friends and to modify it to meet your needs better. There is no separate End User License Agreement (EULA).

If you think that some issues still applies, I recommend filing a new bug for
the specific issues encountered.

Note You need to log in before you can comment on or make changes to this bug.