Closed Bug 26365 Opened 20 years ago Closed 20 years ago

Mozilla should throw a dialog box on "non-existent" FTP directories

Categories

(Core :: Networking: FTP, defect, P3)

x86
Windows 98
defect

Tracking

()

CLOSED DUPLICATE of bug 25014

People

(Reporter: vimages, Assigned: jud)

References

()

Details

To reproduce:

1) In Nav 4.x, Open: ftp://ftp.netscape.com/pub/communicator/english/
2) Click on the 4.72 directory

results: a modal dialog box saying the directory doesn't exist is thrown

1) In M13, Open: ftp://ftp.netscape.com/pub/communicator/english/
2) Click on the 4.72 directory

results: The wheel just keeps on spinning, forever and ever.
NOTE: Once this directory is populated/existent, a decent test case will need to 
be built. I'm guessing this is because of the lame-o round-robinness of the NSP 
FTP servers. Oh. and Hi Eli.                                         - Jim Race
And BTW (cranky Jim again) can I comment on the UI of the FTP display somewhere?
Boy do I hate HTML dialogs. Reassign to Judson
Assignee: davidm → valeski
Component: HTML Dialogs → Networking

*** This bug has been marked as a duplicate of 18007 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Rubber-stamping as verified.
Status: RESOLVED → VERIFIED
Eli, how does this relate to 18007? That bug has to do with DNS failure. This 
one is quite different. 
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
yup. my fault. sorry about that. this is directory failure.
Status: REOPENED → ASSIGNED
Target Milestone: M15
No worries. I'm an ex-Netscape QA geek. I hate dupes. :)
Hi, Jim ---

Umm...Networking isn't my area, I go through several dozen bugs a day, and I just 
rubber-stamped it assuming there was a common root source resulting in both 
issues that Judson had to fix?

See ya.
QA Assigning to Tom.
QA Contact: elig → tever
Also, if you type an invalid filename/directory, it doesn't give an error message.
for example
ftp://ftp.mozilla.org/pub/thissucks

will try for a minute, and repond with a "Done" in the status bar. should
produce some kind of error. (though this is very a minor bug)
Target Milestone: M15 → M16
Moving to M17 (also beta2).
Target Milestone: M16 → M17

*** This bug has been marked as a duplicate of 25014 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
verified DUP
Status: RESOLVED → VERIFIED
Component: Networking → Networking: FTP
Marking closed. -jim
Status: VERIFIED → CLOSED
You need to log in before you can comment on or make changes to this bug.