Cannot use two instances of firefox with two user ids in a web app.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: bristols, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When programming web applications, I often log on to the app with two different
user accounts at the same time. Firefox will not accomodate this. After loging
on with the second account, the first window now also uses the second account.
This seems to be some problem handling session ids/cookies. This is true if both
logons are in the same window (two tabs) or different windows.

This means I cannot use firefox for development.

Reproducible: Always
Steps to Reproduce:
1. Open Firefox and log into a web applicaiton.
2. Open a second window or tab and log into the same application with a
different user account.
3. The first window is now also using the second user account.

Actual Results:  
Lost the first session.

Expected Results:  
It sould maintain both sessions.
manyfox.bat:

cd "c:\Program Files\Mozilla Firefox\"
set MOZ_NO_REMOTE=1
firefox -p

Create a new profile for your second identity, and it WORKSFORME (and also lets
you have multiple versions installed, to boot).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

14 years ago
Can you please provide more detatiled instructions so I can verify?

Thanks,
steve
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(In reply to comment #2)
> Can you please provide more detatiled instructions so I can verify?

Create a batch file, named whatever.bat, that consists of three lines:

cd "the path to where you installed Firefox" (to get into the right directory)
set MOZ_NO_REMOTE=1 (the magic environment variable that tells Firefox not to
insist on just one instance)
firefox.exe -p (which starts Firefox with the Profile Manager so you can select
a profile or create a new one)

Since you can't have two instances using the same profile at once, you want a
new one. Double click your batch file, a commandline window opens, opens the
profile manager. Click Create Profile and... do so. Probably uncheck "Don't ask
at startup, select the new profile and fire it up. Profit!!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
*** Bug 297470 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
On Linux, it's possible to have two instances running at the same time -
"firefox -ProfileManager" does start the profile manager.

Is this supposed to be this way?

Comment 6

14 years ago
Please see bug #297618.
Blocks: 297618

Comment 7

13 years ago
*** Bug 309618 has been marked as a duplicate of this bug. ***
*** Bug 310756 has been marked as a duplicate of this bug. ***
*** Bug 312605 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
must apologize since i was clear enough in my description.

I meant, that i could not have two windows of firefox running.  you know that if
your set your settings to open a new window when clicking on a link, instead of
bringin it up inside the current window...

I could not do that, i could not open a second window for my 1 user id. I wasnt
trying to have multiple profiles. I was not able to open two windows so that i
could check my mail and surf the web at the same time through my one user id. 

Which i can do now, that i have upgraded to beta 1.5b2. 

Ignore my bug if you like. I was only trying to help.
*** Bug 318284 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.