Last Comment Bug 264205 - customizable statusbar (allow reordering of icons there)
: customizable statusbar (allow reordering of icons there)
Status: VERIFIED FIXED
[testday-20110422][fixed by bug 574688]
:
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: unspecified
: x86 All
: -- enhancement with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 575168 (view as bug list)
Depends on: 574688
Blocks: 427282 439413
  Show dependency treegraph
 
Reported: 2004-10-13 10:08 PDT by James Norris
Modified: 2011-04-22 14:12 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description James Norris 2004-10-13 10:08:49 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041006 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041006 Firefox/0.10.1

Firefox should allow users to customise the locations of extension icons in the
status bar. Adblock can be moved, but otheres are static. It would be nice to be
able to move firefox features (ie. progress bar and certificate information) to
the left side of the extension icons (personally) Where other's might want them
somwhere else.  Currently, they're all mixed together.

Reproducible: Always
Steps to Reproduce:
Comment 1 Peter van der Woude [:Peter6] 2004-10-13 10:11:45 PDT
isn't that up to the writers of extensions ?
Comment 2 James Norris 2004-10-14 01:12:33 PDT
(In reply to comment #1)
> isn't that up to the writers of extensions ?

Dunno, that's why I posted. Seems like something that should be written in to ff
to me.
Comment 3 Nickolay_Ponomarev 2005-05-08 17:30:00 PDT
see bug 213672 and bug 150379 comment 16.
see this for implementation that can be used in extensions (based on Adblock's)
http://kb.mozillazine.org/Dev_:_Extensions_:_Example_Code_:_Adding_Drag_and_Drop_to_Statusbarpanel

Confirming the bug, the wontfix comments are quite old and don't contain much
explanations.
Comment 4 Alex Sirota (iosart) 2005-06-18 02:27:05 PDT
It would be great if the status bar would become fully customizable. By that I
mean that when the customization palette is open, the statusbar would become a
valid target just as any of the toolbars, and this will also allow it's widgets
to be reordered, removed or positioned on the toolbars (not only on the status bar).

I implemented something similar back in September for FoxyTunes
(http://www.iosart.com/firefox/foxytunes_articles/dragAndDropReposition.html)
but this is really a hack which sometimes conflicts with the Firefox
customization mechanism (flexible spaces, etc.) resulting in incorrect position
of my widget. It would be great to see this implemented in Firefox so all the
extensions get the functionality 'for free'. I believe that the users will
greatly appreciate this feature, as this was one of the most requested things
for FoxyTunes at the time.

Comment 5 Nicolas Mailhot 2006-10-25 14:10:36 PDT
The extension icons position in the status bar currently depends on the extension installation order (effectively random)
Comment 6 Jesse Ruderman 2008-04-06 13:10:33 PDT
See also bug 427282, which goes beyond reordering and asks to be able to move items between the status bar and the toolbars at the top of the window.
Comment 7 Simon Bünzli 2008-08-30 19:08:16 PDT
(In reply to comment #6)
See also bug 213672 which WONTFIXES that and some of what's requested in this bug.
Comment 8 Jakub 'Livio' Rusinek 2008-08-31 03:29:46 PDT
Don't know why such useful feature requests are rejected and a "hyperfeatures", like improved search in location bar, which is fact is slow on linux as elephant, aren't.

Probably I will never understand some developers. Maybe they're supposed to be geeks/nerds separated from the rest of people?
Comment 9 Bjartur Thorlacius 2009-07-13 10:07:33 PDT
I think we should close this bug and open a new one requesting the  statusbar to be made just another toolbar and allowing toolbars to be dragged at any side of the screen and items dragdropped between any of them allowing the tab-bar to be dragged to the side, the awesomebar to the bottom and the statusbar to the top.
This will of course never be implemented before Gecko 2.
Comment 10 Sebastian H. [:aryx][:archaeopteryx] 2010-06-29 21:47:39 PDT
*** Bug 575168 has been marked as a duplicate of this bug. ***
Comment 11 Chris Wood 2011-04-15 20:22:17 PDT
This is now fixed by new new addon bar (apart from old addons, which is bug 598929).
Comment 12 Simona B [:simonab] 2011-04-22 03:00:42 PDT
Status bar was replaced by the add-on bar and still some of the extensions are static and can not be moved from their initial position.
Comment 13 Kevin Brosnan [:kbrosnan] 2011-04-22 14:12:40 PDT
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110421 Firefox/6.0a1

Note You need to log in before you can comment on or make changes to this bug.