Today's linux build crashes on startup

VERIFIED DUPLICATE of bug 254967

Status

()

Firefox
General
--
blocker
VERIFIED DUPLICATE of bug 254967
14 years ago
7 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Chase Phillips)

Tracking

({crash, fixed-aviary1.0, smoketest})

1.0 Branch
x86
Linux
crash, fixed-aviary1.0, smoketest
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
used the installer for 2004101909-0.9+ on linux fc2. after going through the
installer (custom), firefox seg faulted when attempting to startup (no talkback).

./run-mozilla.sh: line 451:  2537 Segmentation fault      "$prog" ${1+"$@"}

I'll see if this occurs with the non-installer blob.

Tracy, Marcia, how are the Windows and Mac builds for you?
(Reporter)

Comment 1

14 years ago
also crash when using non-installer blob.
(Assignee)

Comment 2

14 years ago
This could be related to caillon's landing of the GTK2 file chooser.

http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?module=AviaryBranchTinderbox&branch=AVIARY_1_0_20040515_BRANCH&cvsroot=/cvsroot&date=explicit&mindate=1098145500&maxdate=1098146880&who=caillon%25redhat.com

Also, the crash-on-startup bug leads to a test-failed status for our Aviary
Linux Tinderboxen.  It's the cause of our missing Linux branch builds this morning.

Updated

14 years ago
Keywords: crash
Summary: today's linux build crashes on startup → Today's linux build crashes on startup

Comment 3

14 years ago
*** Bug 265118 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

14 years ago
Graham, in the bug you filed you mentioned seeing talkback. could you file the
talkback report here and add the incident ID number? thanks!

(for some reason I didn't get tb when using either the installer or non-inst
builds.)
(Reporter)

Updated

14 years ago
Component: Installer → General
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?

Updated

14 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
(Reporter)

Comment 6

14 years ago
over irc Chase mentions that this bug might also be why the linux branch tbirds
failed today.
Flags: blocking-aviary1.0+ → blocking-aviary1.0?
(Reporter)

Comment 7

14 years ago
accidentally clobbered chofmann's flag setting; resetting back to plus.
Flags: blocking-aviary1.0? → blocking-aviary1.0+
So the basic problem here, according to bryner, is that bug 254967 didn't land
on the branch, but it is a prerequisite for the filepicker to land.
Or at least a prerequisite for it to land in the state it's currently in on the
trunk.  The use of REGISTER_AGAIN is, according to caillon, now unnecessary, and
he posted a patch on IRC to allow that to be removed.  I think it would be
reasonable to reland the GTK2 filepicker with the patch caillon posted on IRC,
assuming it's been tested.
Caillon's patch on IRC is
http://people.redhat.com/caillon/patches/register-again.patch

My only concern with that patch is the removal of the call to
nsFilePicker::Shutdown, but that seems like something that should be in the
module destructor anyway (perhaps move it there?).
(Reporter)

Comment 11

14 years ago
looks fixed using 2004101918-0.9+ bits.
Keywords: fixed-aviary1.0

*** This bug has been marked as a duplicate of 254967 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

14 years ago
Status: RESOLVED → VERIFIED

Comment 13

14 years ago
Aviary builds for the last 3-4 days have all crashed on first run. Still
happening today with with this hot off of ftp.mozilla.org build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041021 Firefox/1.0
(Reporter)

Comment 14

14 years ago
this morning's build (and y'day's) work fine for me: no crash on initial launch.
Jeremy, is talkback appearing for you when you crash?

Comment 15

14 years ago
sairuh: no, no talkback shows up on this first-run crash. (Normal crashes during
surfing, rare as they are nowadays, do pop up talkback.) Perhaps it's something
in the talkback code itself causing the crash before it can load? Maybe making
~/.talkback/<build-id>?  I will ./mozilla-installer -ira, then strace my first
run with tomorrow's build to see if that provides any leads.

Comment 16

14 years ago
Still happening. This time talkback DID pop up, for once. ID is TB1486393E,
though it may not be available in the DB for twelve hours or so, there's quite a
backlog.
Should a seperate bug be filed? Again, this is only on first run for each new build.

Updated

12 years ago
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.