Thunderbird and Firefox Silent Install fails to install

VERIFIED DUPLICATE of bug 229706

Status

Thunderbird
Installer
VERIFIED DUPLICATE of bug 229706
13 years ago
13 years ago

People

(Reporter: cmtalbert, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 7.53  [en]
Build Identifier: Thunderbird 0.8

When attempting a silent install of Thunderbird, the "select destination folder" 
screen from the install wizard pops up.  Next, setup.exe will exit without 
installing anything. Even clicking the "Next" button on the screen that pops up 
does nothing.  The only visible item that was accomplished was creating the 
Mozilla Thunderbird directory.  Nothing else appears to have been performed on 
the system.



Reproducible: Always
Steps to Reproduce:
Reproduction method 1:
1. Download release version of Thunderbird 0.8
2. Run Thunderbird-setup0.8.exe -ms
3. You get the "select destination folder" screen from the install wizard. 
(which you shouldn't get in a silent install).
4. Clicking next on this screen does nothing. After a few moments, setup.exe 
exits without installing the product.

Reproduction method 2:
1. Unpack thunderbird-setup-0.8.exe
2. Edit config.ini to change Run Mode from "Normal" to "Silent"
3. Re-pack components into t8silent.exe using nszip.exe
4. Attempt to install using t8silent.exe and you get the same behavior as in 
method 1.

Actual Results:  
Nothing was installed on the system

Expected Results:  
Software should have been installed using all the default settings.  There 
should have been no pop-up screens from the installation wizard either since it 
was a silent install.

Comment 1

13 years ago
The exact same thing happens with Firefox 1.0 PR. Getting the silent and auto
installs to actually work would go a long way toward allowing me to easily
deploy Firefox to my users.

I have also tried running the setup so it extracts the files, grabbing the
extracted files from the temp folder, canceling the setup, changing the
config.ini, then running the setup I pulled from the temp folder, with the same
result. 

Can we change the summary to reflect that this is just not for Thunderbird?
(Reporter)

Comment 2

13 years ago
Because of comments I've received, I've changed the summary. Apparently, the 
same thing happens in Firefox 1.0 PR.

Received Comments:
The exact same thing happens with Firefox 1.0 PR. Getting the silent and auto
installs to actually work would go a long way toward allowing me to easily
deploy Firefox to my users.

I have also tried running the setup so it extracts the files, grabbing the
extracted files from the temp folder, canceling the setup, changing the
config.ini, then running the setup I pulled from the temp folder, with the same
result. 

Can we change the summary to reflect that this is just not for Thunderbird?
Summary: Thunderbird Silent Install fails to install → Thunderbird and Firefox Silent Install fails to install

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 229706 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 4

13 years ago
*** Bug 273586 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
*** Bug 272529 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.