If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

standards in-compliance with CSS and html on extensions page

VERIFIED DUPLICATE of bug 247572

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED DUPLICATE of bug 247572
13 years ago
2 years ago

People

(Reporter: Aaron Slunt, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041108 Firefox/1.0

The extensions site is clutterred with html errors, most of which can be resolved.

The CSS is not valid, and does not render the same in IE and Firefox. I have
fixed the CSS to make it completely valid, and it renders the link I gave you
perfectly in both browsers.

About links on your page with & in them: please use htmlentities in the php loop
that outputs the links, and it will change & to &, and get rid of many
errors that the w3c validator spits out involving those.

If I get around to it, I'll be glad to help out more with the validation.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
Created attachment 165231 [details]
css fix

This is the CSS fix; validated, and works properly in IE and Firefox.
Component: Web Site → Update
Product: Firefox → mozilla.org
Version: unspecified → other

Comment 2

13 years ago
The attachment breaks the desired layout, and this bug is a dupe.

*** This bug has been marked as a duplicate of 247572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

13 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.