Crash when attempting to install an incompatible extension or theme

VERIFIED DUPLICATE of bug 269585

Status

Thunderbird
General
--
critical
VERIFIED DUPLICATE of bug 269585
14 years ago
14 years ago

People

(Reporter: trix supremo, Assigned: Scott MacGregor)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Tbird crashes when trying to install an incompatible extension in latest linux
build.

TALKBACK INCIDENT ID#: TB1871600G

Steps:
1. Install latest linux build 20041110.
2. Bring up Extensions dialog and install an incompatible extension (ie:
FoxyTunes_0.61.xpi)

Results:
Crash

Note:
Win32 and Mac builds correctly prompt users that the extension is incompatible.
Trix, what version and flavor of Linux are you running?

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB1871600G

0x007a006f
libglib-2.0.so.0 + 0x4979f (0x004ca79f)
libglib-2.0.so.0 + 0x241e2 (0x004a51e2)
libglib-2.0.so.0 + 0x252d8 (0x004a62d8)
libglib-2.0.so.0 + 0x25610 (0x004a6610)
libglib-2.0.so.0 + 0x2587d (0x004a687d)
nsAppShell::DispatchNativeEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 279]
nsXULWindow::ShowModal() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/xpfe/appshell/src/nsXULWindow.cpp,
line 710]
nsContentTreeOwner::ShowAsModal() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/xpfe/appshell/src/nsContentTreeOwner.cpp,
line 443]
nsWindowWatcher::OpenWindowJS() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 566]
GlobalWindowImpl::OpenInternal() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 4937]
GlobalWindowImpl::OpenDialog() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 65]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2939]
XPC_WN_CallMethod() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 2977]
js_Invoke() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 958]
nsXPCWrappedJSClass::CallMethod() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1343]
nsXPCWrappedJS::CallMethod() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 450]
PrepareAndDispatch() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp,
line 100]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2939]
XPC_WN_CallMethod() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1287]
js_Invoke() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 941]
js_Interpret() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 2977]
js_Invoke() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 958]
js_InternalInvoke() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsinterp.c,
line 1035]
JS_CallFunctionValue() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/js/src/jsapi.c,
line 3705]
nsJSContext::CallEventHandler() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1296]
nsJSEventListener::HandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/dom/src/events/nsJSEventListener.cpp,
line 177]
nsEventListenerManager::HandleEventSubType() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 710]
nsEventListenerManager::HandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1529]
nsXULElement::HandleDOMEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2841]
nsXULElement::HandleDOMEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 710]
nsXULElement::HandleDOMEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 88]
PresShell::HandleDOMEventWithTarget() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6135]
nsButtonBoxFrame::MouseClicked() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp,
line 65]
nsButtonBoxFrame::HandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp,
line 146]
PresShell::HandleEventInternal() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6102]
PresShell::HandleEventWithTarget() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5984]
nsEventStateManager::CheckForAndDispatchClick() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 2985]
nsEventStateManager::PostHandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 1973]
PresShell::HandleEventInternal() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 710]
PresShell::HandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5920]
nsViewManager::HandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/view/src/nsViewManager.cpp,
line 710]
nsViewManager::DispatchEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/view/src/nsViewManager.cpp,
line 96]
HandleEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/view/src/nsView.cpp,
line 77]
nsCommonWidget::DispatchEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsCommonWidget.cpp,
line 215]
nsWindow::OnButtonReleaseEvent() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsWindow.cpp,
line 1450]
button_release_event_cb() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsWindow.cpp,
line 3277]
libgtk-x11-2.0.so.0 + 0x112434 (0x0441a434)
libgobject-2.0.so.0 + 0x9160 (0x005ec160)
libgobject-2.0.so.0 + 0x1d165 (0x00600165)
libgobject-2.0.so.0 + 0x1befe (0x005feefe)
libgobject-2.0.so.0 + 0x1c424 (0x005ff424)
libgtk-x11-2.0.so.0 + 0x2119e5 (0x045199e5)
libgtk-x11-2.0.so.0 + 0x1109d2 (0x044189d2)
libgtk-x11-2.0.so.0 + 0x10f726 (0x04417726)
libgdk-x11-2.0.so.0 + 0x3e025 (0x006db025)
libglib-2.0.so.0 + 0x241e2 (0x004a51e2)
libglib-2.0.so.0 + 0x252d8 (0x004a62d8)
libglib-2.0.so.0 + 0x25610 (0x004a6610)
libglib-2.0.so.0 + 0x25c53 (0x004a6c53)
libgtk-x11-2.0.so.0 + 0x10eff3 (0x04416ff3)
nsAppShell::Run() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/thunderbird-aviarybranch/Linux_2.4.18-14_Clobber/mozilla/mail/app/nsMailApp.cpp,
line 59]
libc.so.6 + 0x14ad4 (0x00137ad4)
Keywords: crash
(Assignee)

Comment 2

14 years ago
*** Bug 269074 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

14 years ago
what flavor of glib too?
(Reporter)

Comment 4

14 years ago
OS: FC2
Kernel: 2.6.7-1.494.2.2
glib2: 2.4.7
I wasn't able to reproduce this using Linux Fedora Core 2 with the latest
updates. here's my version info:

from uname -a:
  kernel 2.6.8-1.521

from rpm -qa|grep glib:
  glibc-devel-2.3.3-27
  glibc-debug-static-2.2.93-5
  glibc-common-2.3.3-27
  dbus-glib-0.20-4.1
  glibc-kernheaders-2.4-8.44
  glib2-2.4.7-1.1
  glibc-utils-2.3.3-27
  glibc-2.3.3-27
  glib-1.2.10-12.1.1
  glib2-devel-2.4.7-1.1
  glibc-headers-2.3.3-27
  glib-devel-1.2.10-12.1.1
  glibc-profile-2.3.3-27
Summary: Crash when attempting to install an incompatible extension. → Crash when attempting to install an incompatible extension or theme
Brian, could this crash be due to the earlier version of the kernel or glib that
Trix has? (seems odd, since he does have fc2.)

Comment 7

14 years ago
I'm seeing both Firefox and Thunderbird crash in event_processor_callback(),
although I'm not doing anything with themes (see bug 268402).

The last frames on the stack are:

#0  0xb69b5e76 in event_processor_callback (source=0x88ee6b0, condition=G_IO_IN,
data=0x88ee260) at nsAppShell.cpp:67
#1  0xb7a1d1df in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#2  0xb79f7b92 in g_main_depth () from /usr/lib/libglib-2.0.so.0
#3  0xb79f8c88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#4  0xb79f8fc0 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#5  0xb79f922d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#6  0xb69b66dc in nsAppShell::DispatchNativeEvent (this=0x5, aRealEvent=0,
aEvent=0x0) at nsAppShell.cpp:277

timeless seems to think that this is related to *this* bug - via bug 269074 - 
although I wasn't sure.

Should I open a new bug?

Comment 8

14 years ago
I see it seems to be a popular top-crash for Firefox, but I don't see a bug for
it, unless this is it?

If it's of any help...

I can reliably reproduce the event_processor_callback() crash - in Thunderbird
at least - by creating a sub-folder, and then clicking on it. I do
nightly checkouts/builds have have narrowed it down to:

   20041103  OK
   20041104  BAD

[and every build since then has the problem]

My checkouts run at 0500 GMT.

Comment 9

14 years ago

*** This bug has been marked as a duplicate of 269585 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.