Add Wikipedia to the set of default search engines (using relevant language)

RESOLVED WONTFIX

Status

()

Firefox
Search
--
enhancement
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: David A. Wheeler, Assigned: Pierre Chanial)

Tracking

unspecified
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

One of the most popular search engine additions for Firefox is the
"Wikipedia" addition.  Currently Firefox has several generic web searchers,
and a dictionary, but no encyclopedia by default.
Normal users are very familiar with using encyclopedias, and encyclopedias
are very broadly useful, so it's a capability that most users would find useful.
Also, Wikipedia's development approach is very consonant with the
Firefox development approach - the two projects have much in common, and
highlighting Wikipedia will probably help highlight Firefox as well.
It also creates a special ability in Firefox that its competitors don't have -
it then comes with a built-in capability to search an encyclopedia.

Yes, obviously people can add Wikipedia as a search option.  But by
including it by default, EVERYONE can do it, without having to install
anything.  Since it's a very popular addition, it'd be great to build it in.

Note this is a generalization of bug 268166.


Reproducible: Always
Steps to Reproduce:
After default install, click on search engines.
Actual Results:  
No wikipedia entry.

Expected Results:  
Show a Wikipedia entry :-).
(Reporter)

Comment 1

13 years ago
A few quick additions.  First, I'm suggesting that Wikipedia be the
INITIAL default for searches - keep that at Google.  I'm just suggesting that
Wikipedia be added to the list of search engines when Firefox is installed,
without having to separately add it (that's particularly useful when a major
release comes out... I've had trouble getting to the site that stores the
search engine extensions).

Second, note that WHICH Wikipedia should be added depends on the
default language.  That's something that's easily handled during the install,
but more tricky later on.  Which is another good reason to do it during
the install.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Summary: Add Wikipedia as a default search engine (using relevant language) → Add Wikipedia to the set of default search engines (using relevant language)
I tried unsuccessfully to get Wikipedia in here:
https://bugzilla.mozilla.org/show_bug.cgi?id=242586

I even had a patch made and ready for review.

Comment 3

12 years ago
Note that wikipedia search engine is available on the Add Engines... page:
http://www.mozilla.org/products/firefox/central#central-engines

I'd like to see it installed by default also.
I've filed a related bug to get wikipedia as a quick search, it's bug 300015.

Comment 4

11 years ago
Looking at the MyCroft page, WikiPedia is the second most searched for item, it's clearly a very popular thing to search through.

I also disagree with Blake Ross' assertion in bug 300015 that more people are going to search in a dictionary than in an encyclopedia - how can he honestly believe this is true? It may have been true in the past when people weren't aware of such material being freely available - the Alexa traffic rank graph here seems to suggest that may have been the case then.
http://www.alexa.com/data/details/traffic_details?&range=2y&size=medium&compare_sites=&y=r&url=meta.wikimedia.org
However the situation has clearly changed, and so I feel that this is definitely worth re-consideration given the different circumstances now than 1.5 years ago.

There's a patch available in bug 300015 if we want to implement it. It's a trivial fix and could easily make Firefox 2.0, and would be beneficial to a large number of users.
Flags: blocking-firefox2?
We already have two general search engines, and an online reference search (Answers.com) that searches across wikipedia and additional sources, so this seems pretty redundant.  We're not planning on adding any more default engines than we already have.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox2? → blocking-firefox2-
Resolution: --- → WONTFIX

Comment 6

9 years ago
Seems like the WONTFIX decision was reversed, since bug 380785 is now FIXED :)
You need to log in before you can comment on or make changes to this bug.