Closed Bug 269775 Opened 16 years ago Closed 16 years ago

Bookmarks toolbar 'shrinks' when window is resized/restored

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: jacob.bramley, Assigned: martijn.martijn)

References

Details

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-UK; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-UK; rv:1.7.5) Gecko/20041110 Firefox/1.0

If the bookmarks toolbar item is placed to the right of the location bar (on the
far right of the navigation toolbar) and the window is restored (from
maximised), re-sized, maximised (from 'restored'), or moved into or from full
screen mode, the location bar appears to 'squash' the bookmarks toolbar so that
chevrons appear. Every time the window is re-sized it shrinks some more.

Correct layout is restored if you open the customise toolbar thing, or if you
edit a bookmark or restart the browser.

Reproducible: Always
Steps to Reproduce:
1. I have just a menu bar, tab bar and navigation bar visible, though I don't
think this makes much difference.
2. On the navigation bar i have back, forward, refresh, stop, location,
bookmarks (containing 2 folders and 2 links).
3. Resize the window, enter / exit full screen or 'restore' the window.
Actual Results:  
Bookmarks toolbar shrinks, chevrons appear in place of missing bookmarks items.
Location bar 'grows'.

Expected Results:  
Location bar should have re-sized to allow space for the bookmarks bar.
*** Bug 269776 has been marked as a duplicate of this bug. ***
Can you attach a screenshot of this?
Attached image After 'restoring'
URL: n/a
I see the same problem on Mac OSX as I do on windows XP.  But it requires
something slightly different on the Mac.  On the Mac the window has to be sized
down enough so that the drop dow arrow reaches the favicon. Or on secure sites
like this one it happens when the lock reaches the favicon.  And like on windows
the bookmarks do not re-expand when the browser width is increased again.  Using
customize fixes this like it does on Windows.  

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0
i'm seeing this on windows xp, and it even happens if i have my bookmarks items
on their own toolbar with nothing else.
I'm having a similar problem, although it appears to have nothing to do with
resizing the window in my case.  I simply come back to work in the morning and
find the chevrons showing despite the fact that the window is the same size as
it was when they weren't showing.  If I maximize and restore the window, the
chevrons disappear and the bookmarks return to normal.  This is on Win2K.  I've
also seen the same think on my wife's XP-Home.

From the Mozillazine forums, it looks like a fair number of people are having
this problem in different scenarios.  See, for exapmle:
http://forums.mozillazine.org/viewtopic.php?t=162582 and
http://forums.mozillazine.org/viewtopic.php?t=173529 
I can't find another bug about the bookmarks folder spontaneously resizing, so
confirming.

This also sometimes happens if you switch users in WinXP, and then log back in.

When this occurs, the entire contents of the toolbar disappear into the chevron.
It doesn't matter what other toolbars are active or stacked beside the bookmarks
toolbar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bookmarks toolbar 'shrinks' when window is resized → Bookmarks toolbar 'shrinks' when window is resized/restored
(In reply to comment #8)
> When this occurs, the entire contents of the toolbar disappear into the chevron.
> It doesn't matter what other toolbars are active or stacked beside the bookmarks
> toolbar.

What you are describing there is bug 266737. While not exactly the same, it's
likely related. Marking depends for now.
Depends on: 266737
Flags: blocking-aviary1.1?
(In reply to comment #9)
> (In reply to comment #8)
> > When this occurs, the entire contents of the toolbar disappear into the chevron.
> > It doesn't matter what other toolbars are active or stacked beside the bookmarks
> > toolbar.
> 
> What you are describing there is bug 266737. While not exactly the same, it's
> likely related. Marking depends for now.

I am running W2K SP4 and FF ver 1.0.1 and am experiencing this as well.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
This should be fixed now, since bug 266737 got fixed. Could someone verify?
*** Bug 296845 has been marked as a duplicate of this bug. ***
Attached patch patch (obsolete) — Splinter Review
Well, removing the margin-left:3px on hbox id="bookmarks-ptf" solves the issue
for me. 
This patch also solves bug 285456 for me.
But with this patch bookmark-items don't leave any room at the right side.
Personally, I don't think that's a problem, but...
Attachment #185504 - Flags: review?(mconnor)
Blocks: 285456
Attached patch patch2Splinter Review
(In reply to comment #13)
> But with this patch bookmark-items don't leave any room at the right side.
Erm, I meant the left side.

And argh, I should have known directly, just replace margin-left with
padding-left, so it gets calculated in the boxObject width.
And with this patch you leave the same appearance (at least with the standard
theme).
Attachment #185504 - Attachment is obsolete: true
Attachment #185504 - Flags: review?(mconnor)
Attachment #185512 - Flags: review?
Attachment #185512 - Flags: review? → review?(mconnor)
Asking for blocking 1.1 again, since this is a really simple patch...
Assignee: bugs → martijn.martijn
Flags: blocking-aviary1.1- → blocking-aviary1.1?
Attachment #185512 - Flags: review?(mconnor) → review+
Flags: blocking-aviary1.1? → blocking1.8b4+
Attachment #185512 - Flags: approval1.8b4? → approval1.8b4+
Whiteboard: [checkin needed][a+]
Checking in browser/base/content/browser.xul;
/cvsroot/mozilla/browser/base/content/browser.xul,v  <--  browser.xul
new revision: 1.264; previous revision: 1.263
done

-> FIXED
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed][a+]
Target Milestone: --- → Firefox1.1
Version: unspecified → Trunk
QA Contact: bugzilla → toolbars
Sorry to bring up an old bug but this is the most accurate description of the problem that I am still having with Firefox. I noticed the behavior a few months back but wasn't able to pinpoint exactly what the cause is. Finally, I figured it out. Here are the steps to reproduce

1. With the window maximized, open the customize toolbars menu and click on Restore Default Set
2. Move the Bookmarks Toolbar Items menu to the left of the Bookmarks button
3. Restore the window so it is not maximized

The result is that the Bookmarks Toolbar Items menu is compressed / squished with two visible arrows "">>"" even though there is plenty of space for the two tiny bookmarks to fit there.

Pictures attached of the step by step
You need to log in before you can comment on or make changes to this bug.