filter dialog suggests filters do work on local folders, which isn't always the case

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
7 years ago

People

(Reporter: info, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

unspecified
x86
Windows XP
fixed-aviary1.0
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Thunderbird 0.9

The filters dialog suggests at the bottom that filters always are automatically 
invoked. However, at the FAQ page and on forums it is being said filters on 
the 'Local Folders' account are NOT run automatically.

To me, the filters should be run automatically. Simply because the global inbox 
feature is great when checking multiple pop-accounts and having only one set of 
filters can simplify this extremely (e.g. for a filter to filter out known 
people into a trusted folder. It doens't matter which account your friends use 
for mailing you....).

So please fix the feature instead of the dialogue box.

NB. The filters do work sometimes. When they stop working, I can get them back 
to work like described below.


Reproducible: Always
Steps to Reproduce:
When the filters for the local folders account stop working, do this:

1. move the file with filters out of the folder with the settings
2. start Thunderbird and close it again
3. move the filter settings file back
4. filters for the local folders account do work (until it stops again...)


Actual Results:  
The filters work temporarily

Expected Results:  
Keep filtering
(Assignee)

Comment 1

14 years ago
I'm going to fix the default server for the dialog first, since that's easiest.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
thanks, david! nominating so it doesn't fall off the 1.0 radar.
Flags: blocking-aviary1.0?
(Assignee)

Comment 3

14 years ago
Created attachment 166492 [details] [diff] [review]
proposed fix

get the incoming server from the account key...otherwise, use the selected
folder, as before.
(Assignee)

Updated

14 years ago
Attachment #166492 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #166492 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

14 years ago
Keywords: fixed-aviary1.0

Comment 4

14 years ago
I agree with the original reporter, having filter not working on local mbox is
very disturbing. Keep in mind that from the user point of view, there is only
one inbox, the one displayed when he launches thunderbird. There is no reason
why the filters should not work on this mailbox.

This is a typical case of implementation perspective taking over the user
perspective. I hope it gets fixed before 1.0
(Assignee)

Comment 5

14 years ago
the way it is now, the user will have to go out of their way to define filters
for local folders (they'll have to pick Tools | message filters and then switch
from their incoming server to the local folders account) so I'm minusing the
rest of this bug.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Keywords: relnote

Comment 6

14 years ago
Using Linux, would it be valid to create a link to the filters' config in the
Local folders' directory from the different pop accounts' directories or do I
risk corruption?

~/.thunderbird/default.20a/Mail/[pop_directory]> ln -s ../Local\
Folders/msgFilterRules.dat .
(Assignee)

Comment 7

14 years ago
Patrick, that would be very risky. Until I can make it so the local folders
filters are shared across pop3 servers, you'll just have to make do with
duplicating the filters you care about on each of your pop3 servers. I'm sorry
for the inconvenience, but I promise I'll get to this for Tbird 1.1

Comment 8

14 years ago
The workaround I have for now is a script called to start-up TB which first
copies the msgFilterRules.dat file from Local Folders to each pop account
directory. The expected result seem to be produced.

Comment 9

13 years ago
(In reply to comment #5)
> so I'm minusing the
> rest of this bug.

Seems to me that with bug 271729 fixed (filters for Local folders working), there is nothing left to do on *this* bug... Anyone care to mark as fixed?
(Assignee)

Comment 10

12 years ago
yes, I believe this is fixed now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.