If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Noresolveonopenblockers doesn't allow removing the dependency when fixing

RESOLVED FIXED in Bugzilla 4.0

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: Jouni Heikniemi, Assigned: Frédéric Buclin)

Tracking

2.18
Bugzilla 4.0
Bug Flags:
approval +
approval4.0 +
blocking2.18 -

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
When noresolveonopenblockers is set to on and you have blockers on a bug, you
cannot simultaneously remove the last blocking relationship and mark the bug as
fixed. Instead, you have to remove the dependency first and then fix the bug
separately.
(Reporter)

Updated

13 years ago
Flags: blocking2.18?
As much as I'd love to see this in 2.18, I think this is going to require too
big of an overhaul to process_bug.cgi to fix to fit the low-risk criteria to go
into the 2.18 branch.  I'm pretty sure the only way to handle this is to move
the dependency processing code earlier in the process than the status change
processing code.
Flags: blocking2.18? → blocking2.18-
(Assignee)

Comment 2

13 years ago
*** Bug 279943 has been marked as a duplicate of this bug. ***

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Updated

11 years ago
Assignee: myk → create-and-change

Comment 3

9 years ago
Likewise, if you have a bug that is already marked RESOLVED and then add open blockers with noresolveonopenblockers set, it will prevent you from making any future updates to the bug. At the very least we should not allow open bugs to be added as blockers to resolved bugs if noresolveonopenblockers is on.
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> Likewise, if you have a bug that is already marked RESOLVED and then add open
> blockers with noresolveonopenblockers set, it will prevent you from making any
> future updates to the bug.

This is bug 565314
(Assignee)

Comment 5

7 years ago
Created attachment 472667 [details] [diff] [review]
patch, v1

set_all() first sets dependencies, so $self->dependson already contains the updated list of blocking bugs.
Assignee: create-and-change → LpSolit
Status: NEW → ASSIGNED
Attachment #472667 - Flags: review?(mkanat)
(Assignee)

Updated

7 years ago
Target Milestone: --- → Bugzilla 4.0

Comment 6

7 years ago
Comment on attachment 472667 [details] [diff] [review]
patch, v1

Looks great and is a nice cleanup! :-)
Attachment #472667 - Flags: review?(mkanat) → review+

Updated

7 years ago
Flags: approval4.0+
Flags: approval+
(Assignee)

Comment 7

7 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Bug.pm
modified template/en/default/global/user-error.html.tmpl
Committed revision 7466.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Bug.pm
modified template/en/default/global/user-error.html.tmpl
Committed revision 7397.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.