Last Comment Bug 27295 - DND doesn't work in mail/news on linux
: DND doesn't work in mail/news on linux
Status: VERIFIED FIXED
: pp, relnote
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Linux
: P3 major (vote)
: ---
Assigned To: Christopher Blizzard (:blizzard)
: Eli Goldberg
: Neil Deakin
Mentors:
: 30773 30803 (view as bug list)
Depends on:
Blocks: 26609
  Show dependency treegraph
 
Reported: 2000-02-10 15:02 PST by Christopher Blizzard (:blizzard)
Modified: 2000-04-19 15:19 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.71 KB, patch)
2000-04-13 22:56 PDT, Christopher Blizzard (:blizzard)
no flags Details | Diff | Splinter Review

Description Christopher Blizzard (:blizzard) 2000-02-10 15:02:38 PST
If you try to drag a message from your inbox to another folder in linux it
doesn't work.  There is drag feedback but the drop event doesn't result in the
move to happen.
Comment 1 Peter Trudelle 2000-02-10 16:02:09 PST
This works on Win32 & Mac. adding beta1, pp to keywords. cc phil
Comment 2 rickg 2000-02-11 16:23:12 PST
As much as we'd love to have it, we can ship beta without this. And this: we're 
very impressed that it works on windows.
Comment 3 Peter Trudelle 2000-02-11 17:52:40 PST
Due to extant bugs, we have to either disable D&D on Linux, which would require 
new code to be written by Netscape engineers, or we could just let blizzard 
finish this work for beta. PDT- means Netscape does more work but doesn't get 
the feature, PDT+ means we get the feature at blizzard's expense. clearing PDT- 
for reconsideration. cc pinkerton.
Comment 4 fenella 2000-02-14 11:45:49 PST
When this bug is fixed, I'll refer to bug 10870 to make sure drag and drop works
in mail/news on Linux.
Comment 5 leger 2000-02-14 17:13:17 PST
Putting on the PDT+ radar for beta1.
Comment 6 leger 2000-02-23 16:08:01 PST
Putting to PDT-, will release note for beta1.
Comment 7 Christopher Blizzard (:blizzard) 2000-02-29 17:02:30 PST
Ok, I've debugged the problem to the point where I need some help from the
mail/news team trying to track it down.  The problem shows up in the
DropOnFolderTree() function in messengerdnd.js:

http://lxr.mozilla.org/seamonkey/source/mailnews/base/resources/content/messengerdnd.js#143

the statement at line 161 is:

var dropOn = treeItem.getAttribute("dd-dropon");

which always returns false.  Where is this attribute set?  Why would it not be
set?  Is it possible that the drop is happening on the wrong folder?  I don't
know much about RDF or the tree view.  I'm hoping the mail/news team can help
out a bit trying to track this down.
Comment 8 (not reading, please use seth@sspitzer.org instead) 2000-02-29 17:12:41 PST
that xul atom (see 
http://lxr.mozilla.org/seamonkey/source/layout/xul/content/src/nsXULAtomList.h#131)

gets set by some xul tree code.

http://lxr.mozilla.org/seamonkey/search?string=ddDropOn

sounds like you need to talk to hyatt or pinkerton.
Comment 9 Mike Pinkerton (not reading bugmail) 2000-02-29 17:18:44 PST
but this works on win32/mac...and it's set only if the data source (not the tree 
view) says that we are allowed to drop on that node.....back to you ;)
Comment 10 Christopher Blizzard (:blizzard) 2000-02-29 19:33:45 PST
Ok, I'll try to figure out why that target is not being set properly.
Comment 11 fenella 2000-03-06 17:53:33 PST
*** Bug 30773 has been marked as a duplicate of this bug. ***
Comment 12 Christopher Blizzard (:blizzard) 2000-03-07 21:32:24 PST
This was in private email, just wanted to add it to the bug...



\layout\xul\content\src\nsXULAtomList.h(131):XUL_ATOM(ddDropOn, "dd-dropon")

/layout/xul/base/src/nsToolbarDragListener.cpp, line 298 --
content->SetAttribute ( kNameSpaceID_None, nsXULAtoms::ddDropOn, onChild
? "true" : "false", PR_FALSE );
/layout/xul/base/src/nsTreeRowGroupFrame.cpp, line 2133 -- else if (
aAttribute == nsXULAtoms::ddDropOn ) {
/layout/xul/base/src/nsTreeItemDragCapturer.cpp, line 236 --
content->SetAttribute ( kNameSpaceID_None, nsXULAtoms::ddDropOn,
onMe ? "true" : "false", PR_TRUE );
/layout/xul/base/src/nsTreeItemDragCapturer.cpp, line 288 --
content->SetAttribute ( kNameSpaceID_None, nsXULAtoms::ddDropOn,
"false", PR_TRUE );
/layout/xul/content/src/nsXULAtomList.h, line 131 -- XUL_ATOM(ddDropOn,
"dd-dropon")

Comment 13 Richard Zach 2000-03-17 11:40:01 PST
*** Bug 32225 has been marked as a duplicate of this bug. ***
Comment 14 Richard Zach 2000-03-17 11:41:18 PST
*** Bug 32225 has been marked as a duplicate of this bug. ***
Comment 15 Ben Bucksch (:BenB) 2000-03-25 02:41:21 PST
Any progress on this?

Comment 16 Ben Bucksch (:BenB) 2000-04-06 14:35:51 PDT
Please reevaluate, this time for beta2.
Comment 17 Ben Bucksch (:BenB) 2000-04-12 20:27:30 PDT
blizzard?

This bug (together with bug 27790) is the largest usability problem of Mailnews
for me.
Comment 18 Peter Trudelle 2000-04-13 11:17:27 PDT
chris, we have to have this done ASAP in M16, bumping severity to major.  If 
you can't target M16, please let us know and I'll reassign it, probably to 
pavlov if it is infrastructure work, or to seth or alecf if only app-level work 
remains.
Comment 19 Christopher Blizzard (:blizzard) 2000-04-13 12:49:57 PDT
I'm working on this right now.  I'll let you know how far I get in the next
couple of hours.
Comment 20 Christopher Blizzard (:blizzard) 2000-04-13 13:42:54 PDT
Ok, now I know why this is happening.  Working on a fix.
Comment 21 Christopher Blizzard (:blizzard) 2000-04-13 15:19:39 PDT
Ok, have a fix.  Once my tree finishes rebuilding and I look at it a little
harder I'll try to get a review.
Comment 22 Christopher Blizzard (:blizzard) 2000-04-13 22:56:28 PDT
Created attachment 7570 [details] [diff] [review]
patch
Comment 23 Christopher Blizzard (:blizzard) 2000-04-13 22:58:12 PDT
Patch attached.  The problem was that before gtk sends the drag_drop signal it
will send a drag_leave signal first.  This caused the state managers for the
drag code for the tree to make the tree item an invalid drag target and the drop
would fail.  We don't actually need the drag_leave signal for anything so I just
removed it.
Comment 24 Christopher Blizzard (:blizzard) 2000-04-13 23:11:09 PDT
*** Bug 30803 has been marked as a duplicate of this bug. ***
Comment 25 Christopher Blizzard (:blizzard) 2000-04-13 23:21:40 PDT
syd has reviewed this.  I'll check it in when the tree stops trying to pretend
it's a message from god or something.
Comment 26 Ben Bucksch (:BenB) 2000-04-14 10:10:04 PDT
worksforme with blizzard's patch modulo bugs.
Comment 27 Christopher Blizzard (:blizzard) 2000-04-14 10:17:28 PDT
What do you mean "modulo bugs?"
Comment 28 Ben Bucksch (:BenB) 2000-04-14 11:03:50 PDT
When I filed several msgs via D&D and then replied to another msg, I saw the
drag icon move from the folder, where I filed the msgs, to the current mouse
cursor position several times in an interval of maybe 5s. Looked very spooky
(sp?).

I also had severe problems with D&D in the bookmarks manager (bookmarks inserted
at wrong position, although the visual feedback was correct, etc.) and was not
sure, if they will also appear in mailnews.
Comment 29 Ben Bucksch (:BenB) 2000-04-14 20:46:47 PDT
The composer doesn't have to be open - I also saw it with onyl the reader being
open.

BTW: Thanks trudelle for helping to get the ball rolling and tnx blizzard for
fixing.
Comment 30 Christopher Blizzard (:blizzard) 2000-04-14 22:49:54 PDT
Fix checked in for this bug.  I opened a seperate bug for the "ghost window" for
anyone that cares.  Please see bug #35932 for that.
Comment 31 Christopher Blizzard (:blizzard) 2000-04-17 11:13:12 PDT
Please ignore the spam.  Changing address.
Comment 32 Christopher Blizzard (:blizzard) 2000-04-17 13:33:12 PDT
bustage from my reassign
Comment 33 fenella 2000-04-17 15:00:28 PDT
Linux (2000-04-17-11 16)
Drap and drop works both in POP and IMAP.

Note You need to log in before you can comment on or make changes to this bug.