If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[UPDATED] Add Extension: Enhanced History Manager

RESOLVED FIXED in 1.0

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: MW, Assigned: alanjstr)

Tracking

unspecified
x86
Windows XP

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Win XP; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)

Enhanced History Manager extension revives the nifty Mozilla/Netscape History
Manager functionality (and more) into FireFox.
Link to extension is (rename from ZIP to XPI)
http://home.ripway.com/2004-7/139975/FireFox/Enhanced_History_Manager_0.4.1.02.zip

for FireFox .08 thru 1.0
Tested Only On Windows OS, Probably Mac. Not sure about Other OS's 
Author: AnonEmoose
Version: Enhanced History Manager 0.4.1.02
Homepage: http://home.ripway.com/2004-7/139975/FireFox/index.html
mozillaZine Thread: http://forums.mozillazine.org/viewtopic.php?t=97504

also available in Italian translated by: Madman 
http://home.ripway.com/2004-7/139975/FireFox/Enhanced_History_Manager_0.4.1.02-Italian.zip

No known Bugs & compatible with extensions such as UndoCloseTab, AdBlock,
DownloadWith, IEView, OpenBook and many more



Reproducible: Always
Steps to Reproduce:
1.
2.
3.




Features:
- Optional Toolbar button Toggles 'History Manager' in Side Bar (Hot Key is
Ctrl+Shift+H)
- Menu Items under 'Go' and 'View ---» Sidebar'
- MiddleClick (or MouseWheel Click) on Toolbar button brings up History Manager
Window
- MiddleClick (or MouseWheel Click) on link(s) opens the link(s) in a New Tab(s)
- Preference to Swap button action. *To swap Click/MiddleClick defaults, enable
thru about:config. Locate pref 'hcpm.Swap.Default'. Modify value to "true"

- Sort by either 'Day', 'Site' (Folder View), 'Day--»Site' or Long List.
- Sort by Title, Location, First/Last Visited, Visit count etc.
- Sort Ascending/Descending.
- Quick Search (ie. by 'Title' -- same as FireFox default)
- Advanced Search: 'Title', 'Location' & subsets (contains, starts/ends with,
is/is not, doesn't contain)
- Open one or Multiple links in Window(s)/Tab(s)
- Add one or Multiple Links as a bookmark(s)
(Assignee)

Comment 1

13 years ago
I have a feeling that description is going to be a bit long.
Assignee: nobody → Bugzilla-alanjstrBugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

13 years ago
hehe.. I figured I'd put most of th einfo and it could be edited down as you see
fit.

Presumedly the first 5 'bullets' should be adequate.
(Reporter)

Comment 3

13 years ago
perhaps like this.....

Features:
- Optional Toolbar button Toggles 'History Manager' in Side Bar (Hot Key is
Ctrl+Shift+H)
- Menu Items under 'Go' and 'View --» Sidebar'
- MiddleClick (or MouseWheelClick) on link(s) opens the link(s) in a New Tab(s)
- Preference to Swap button action. *To swap Click/MiddleClick defaults, enable
thru about:config. Locate pref 'hcpm.Swap.Default'. Modify value to "true".
(Reporter)

Comment 4

13 years ago
sorry for bugspam.

I forgot to add the 5th bullet in reply #3. Please disregard #3 and use this if
possible:


Features:
- Optional Toolbar button Toggles 'History Manager' in SideBar (HotKey is
Ctrl+Shift+H)
- MiddleClick/MouseWheelClick the Toolbar button opens up History Manager Window
- Menu Items under 'Go' and 'View--»Sidebar'
- MiddleClick/MouseWheelClick on link(s) opens the link(s) in  New Tab(s)
- Preference to Swap button action. *To swap Click/MiddleClick defaults, enable
thru about:config. Locate pref 'hcpm.Swap.Default'. Modify value to "true".
 




(Assignee)

Comment 5

13 years ago
I need you to put the language packs inside a single XPI in order for me to list
others.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> I need you to put the language packs inside a single XPI in order for me to list
> others.

In that case leave out the italian version for now and just list the original. 
Thanks.

Comment 7

13 years ago
I tested it and I found a problem:
if you uninstall it while the sidebar is open, chrome is not properly
deregistered and an empty sidebar is shown at next restart and then forever. 
I worked-around reinstalling the extension and the uninstalling it with the
sidebar closed, but I guess I have to mark this tested-
Whiteboard: tested-
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)
> I tested it and I found a problem:
> if you uninstall it while the sidebar is open, chrome is not properly
> deregistered and an empty sidebar is shown at next restart and then forever. 
> I worked-around reinstalling the extension and the uninstalling it with the
> sidebar closed, but I guess I have to mark this tested-

That is not a bug, it is User error. The chrome *IS* properly de-registered. Why
would uninstall the extension while it's own sidebar is showing. Basically you
left a reference in your localstore.rdf to open a now non-existant sidebar. All
u need to do is to delete/edit the localstore.rdf. 
Whiteboard: tested- → tested

Comment 9

13 years ago
Is the reference being left behind in localstore.rdf a Firefox bug or a bug in
your extension? It doesn't sound like expected behavior to me.
Whiteboard: tested
(Reporter)

Comment 10

13 years ago
just an addendum to comment #7 

minor FireFox issue that it doesn't remove obsolete stuff from localsore.rdf


 This extension has been out for months and only one other person (aside from
yourself) ever had that problem that I am aware of, Mook. You can see his tongue
in check comment here realizing that it not the extension fault rather <abbr
title="problem exists between keyboard and chair">PEBKAC</abbr>  hehehe :-) :-)
http://forums.mozillazine.org/viewtopic.php?p=703045#703045
(Reporter)

Comment 11

13 years ago
(In reply to comment #9)
> Is the reference being left behind in localstore.rdf a Firefox bug or a bug in
> your extension? It doesn't sound like expected behavior to me.

true....Uninstalling an extension with it's own sidebar open doesn't seem like
expected behavior... lol

Whiteboard: tested
(Reporter)

Comment 12

13 years ago
sorry for bugspam

Just tested Download Mangager Tweak extension (which has the option to open
Dowload Manager in a sidebar) and it exhibits the same exact behavior if
unistalled while it's own sidebar is still open. I'm certain that *any*
extension that has it's own sidebar (and it's open when u uninstall) will have
the same outcome. 

Comment 13

13 years ago
(In reply to Comment #11)
You're not allowed to tested+ your own extension, and so far, this one's only
been given tested-.
I'm also not sure I'm comfortable with an extension author who doesn't take
reported problems particularly seriously.
Whiteboard: tested → need-testing
(Reporter)

Comment 14

13 years ago
(In reply to comment #13)
> (In reply to Comment #11)
> You're not allowed to tested+ your own extension, and so far, this one's only
> been given tested-.
> I'm also not sure I'm comfortable with an extension author who doesn't take
> reported problems particularly seriously.

I think you may have misunderstood my intentions. My intended humor & dry
sarcasm apparently doesn't go over as well when it's written.  I do take
reported issues seriously but in my judgement this doesn't fall into that
category and is not a bug. I did not ignore the issue and I posted a detailed,
straightfoward cause & remedy.   

I removed the '-' because this extension was tested and minused only because of
this one issue. I've explained why & how the problem comes about (user error),
I've pointed you to other extensions which exhibit the same behavior (download
manager tweak & any other extension which inserts a sidebar), and also pointed
to the fix (edit/remove localstore.rdf or reinstall extension & close sidebar
then uninstall again), and since it's a FireFox issue. It's not really an
extension issue. 

I also considered the fact that only ONE user (mook -- who is pretty tech savvy,
as we know) aside from Giorgio reported the issue and now knows why it happened;
mook also realized what how it got messed up clearly stating that it was not the
extension itself. No one else has pointed to (nor have I experienced) any bugs
in *many months* this has been out.

If you feel that I took too much liberty by changing the Whiteboard Status, then
I guess I was presumptuous.

Didn't mean to be so lengthy, just really wanted to clear up your doubts.
(Assignee)

Updated

13 years ago
Assignee: Bugzilla-alanjstrBugs → nobody
(Assignee)

Comment 15

13 years ago
I am satisfied with the testing performed.  It is a Firefox bug that when the
extension is uninstalled it should "fix" the active sidebar.
Assignee: nobody → Bugzilla-alanjstrBugs
Whiteboard: need-testing → tested+
(Assignee)

Comment 16

13 years ago
You need to change your install.rdf to values you've actually tested with.  As
far as I know, Firefox 1.9+ has not been released :-).  Try 1.0 instead.
(Reporter)

Comment 17

13 years ago
(In reply to comment #16)
> You need to change your install.rdf to values you've actually tested with.  As
> far as I know, Firefox 1.9+ has not been released :-).  Try 1.0 instead.

hehe... Fixed
(Reporter)

Comment 18

13 years ago
 addtn't info
I finally located the official Firefox bug pertaining touninsatll when the
extension's own sidebar is still open. It is  bug 249883
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Whiteboard: tested+ → In queue
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

13 years ago
sorry to be a pain but can you update UMO a minor change to homepage url

http://home.ripway.com/2004-7/139975/FireFox/
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: In queue
(Assignee)

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 20

13 years ago
New Version - 0.5.1.00
XPI link -
http://home.ripway.com/2004-7/139975/FireFox/download.php?filename=Enhanced_History_Manager_0.5.1.00.xpi

Compatible with FireFox .08 - 1.1+ (compatible with 1.8 branch - tested on
nightlies)

Can you update description to:

Features:
 - Optional Toolbar button (HotKey is Ctrl+Shift+H)
 - Menu Items under 'Go' and 'View --> Sidebar' 
 - MiddleClick/MouseWheelClick on link(s) opens the link(s) in New Tab(s) 
 - Preference to Swap button action (Click/MiddleClick/CTRL+MiddleClick) 
    *To swap Click/MiddleClick/CTRL+MiddleClick defaults, Locate pref
'hcpm.Open.Where' and switch the order of (sidebar,tab,window) to suit your needs.
1st entry = Normal Click (default is sidebar)
2nd entry = MiddleClick/MouseWheelClick (default is tab)
3rd entry = CTRL+MiddleClick/MouseWheelClick (default is window)
!!! Be sure to keep a comma between each entry!!! 

Be sure to have the sidebar closed when uninstalling or upgrading.

Many Thanks
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Add Extension: Enhanced History Manager → [UPDATED] Add Extension: Enhanced History Manager
(Reporter)

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.