DHTML menus draw behind flash banner(s) and are obscured

RESOLVED DUPLICATE of bug 137189

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 137189
15 years ago
13 years ago

People

(Reporter: ccurzio+mozilla, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When attempting to navigate certain sites that have DHTML menus where the
menubar is above a Flash movie, the Flash movie is drawn on the topmost layer of
the page and obscures any DHTML behind it.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.ecsusa.com/
2. Hover over the menubar options (Products,Downloads,Support/Service,News, etc.)
3. Note that the menus that pop up are obscured by the flash banner. (AdBlock it
to see the menu itself)

Actual Results:  
The menu(s) were obscured by the flash banner. 

Expected Results:  
Draw the menus above the flash movie.
WFM with WinXP: can you reproduce with a clean profile, with no extensions?
Adblock may well be messing things up even when it isn't blocking.
Reporter

Comment 2

15 years ago
Tested with a fresh, empty profile. Same behavior with or without adblock enabled. 

Comment 3

15 years ago
Isn't this a dupe of bug 189608?

Comment 4

15 years ago
Yeah, it's not clear that there's any way for an end-user to work around this
behavior. In IE, the identical thing happens. This may be because the Flash
movie is invoked by an <OBJECT> tag, which the browser treats as a separate
window above everything in the window below it (at least the things created
before the <OBJECT> tag). On the other hand, MS writes that ActiveX controls
are windowless...see http://support.microsoft.com/?id=177378 for further
confusion. Whatever the precise reason, it appears that, consistent with the
earlier bug mentioned, it is an issue for the web page's author, and users
should complain to the webmaster if a site's menus are dysfunctional.
I am seing the same kind of problem on the home page of Asustek at
http://www.asus.com/index.htm. IE displays it correctly. With Firefox, I cannot
use most part of the menus because they are behind the flash object.

Comment 7

15 years ago
This is not a Firefox bug. The problem is in the z-order of stacking HTML
elements. The stacking order on a web page is determined by the sequence they
appear in the HTML. You can however use CSS to set z-order values for page
elements. Higher z-order elements appear on top of lower z-order elements.
Simply wrap your .swf code in a DIV and set the DIV's z-order with CSS.

If you have a complex page with several overlapping Flash elements that need to
change their stacking order when they are interacted with, you may need to use
an actionscript fscommand to trigger some javascript which changes the Flash
movie to bring it to the top, and another one to put it back where it was.
*** Bug 295697 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
In reply to comment #7 from Scott Whittaker:

> The problem is in the z-order of stacking HTML
> elements.

If this was true then this bug will be also seen on Windows platform and it is
not. It doesn't work no matter how high z-index is set.

------------------------------

In reply to comment #1 from Phil Ringnalda:

> WFM with WinXP

It is Linux platform bug.

------------------------------

In reply to comment #4 From Jefferson:

> Yeah, it's not clear that there's any way for an end-user to work around this
> behavior. In IE, the identical thing happens.

It does not if you set <param name="wmode" value="transparent"> within <object>
tag, as documented in
http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_15523
So it could be Linux Flash plugin bug not Gecko.

Comment 10

14 years ago
The url has no flash. Did they remove it?

Comment 11

14 years ago
Posted image Problem doesn't hapen on IE6 (obsolete) —

Comment 12

14 years ago
Posted image Problem does hapen on Firefox 1.6 (obsolete) —

Comment 13

14 years ago
I've just made a page with a DHTML menu and a flash banner
(http://patologia.ocorpohumano.com.br/_base.htm). The same problem described
above is hapening to me. The banner is displaying in front of the menu. I read
that page about turning the flash movie transparent, but it doesn't help. It
would just turn the background transparent, not the whole movie.
As I showed on the images, the bug doesn't hapen on IE6. So, if they resolved
the problem, there must be a way to do the same in Firefox, right?

Comment 14

14 years ago
(In reply to comment #13)
> I've just made a page with a DHTML menu and a flash banner
> (http://patologia.ocorpohumano.com.br/_base.htm). 

That is not what this bug is about, and the problem y ou have is that you dont
have wmode="transparent" attribute on the embed

Updated

14 years ago
Attachment #199967 - Attachment is obsolete: true

Updated

14 years ago
Attachment #199968 - Attachment is obsolete: true

Comment 15

14 years ago
(In reply to comment #14)
> (In reply to comment #13)
> > I've just made a page with a DHTML menu and a flash banner
> > (http://patologia.ocorpohumano.com.br/_base.htm). 
> 
> That is not what this bug is about, and the problem y ou have is that you dont
> have wmode="transparent" attribute on the embed

I've set the wmode to transparent, but the banner disapears (see it by yourself
at http://patologia.ocorpohumano.com.br/_base-wmode.htm). What I think this
function is for is to allow flash movies to have a transparent background. But
my banner hasn't this kind of thing. And if my complaint doesn't fit in this
bug, would it be wise to start a new Bug?
(In reply to comment #15)
> I've set the wmode to transparent, but the banner disapears (see it by yourself
> at http://patologia.ocorpohumano.com.br/_base-wmode.htm). 
Try wmode="opaque".
WFM by saving _base-wmode.htm and changing "transparent" to "opaque".

Comment 17

14 years ago
(In reply to comment #16)
> (In reply to comment #15)
> > I've set the wmode to transparent, but the banner disapears (see it by yourself
> > at http://patologia.ocorpohumano.com.br/_base-wmode.htm). 
> Try wmode="opaque".
> WFM by saving _base-wmode.htm and changing "transparent" to "opaque".

Hey, wonderfull! It works fine on Firefox now (http://patologia.ocorpohumano.com.br/_base-wmode2.htm). It also works fine on IE. Thankyou very much!

Comment 18

14 years ago
(In reply to comment #16)
> (In reply to comment #15)
> > I've set the wmode to transparent, but the banner disapears (see it by yourself
> > at http://patologia.ocorpohumano.com.br/_base-wmode.htm). 
> Try wmode="opaque".
> WFM by saving _base-wmode.htm and changing "transparent" to "opaque".

Hey, wonderfull! It works fine on Firefox now (http://patologia.ocorpohumano.com.br/_base-wmode2.htm). It also works fine on IE. Thankyou very much!

Comment 19

14 years ago
http://www.hotlink.com.my/level2/hotlevel2.asp?AID=442

I'm having the same problem described with this website but I'm on windows.

Comment 20

13 years ago
http://www.thorpepark.co.uk/
and
http://www.chessington.co.uk/
mouseover the menus at the top, theya appear behind the flash.
Linux, firefox 1.5.0.3

Comment 21

13 years ago

*** This bug has been marked as a duplicate of 137189 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.