Last Comment Bug 274221 - Re-roll wintools.zip
: Re-roll wintools.zip
Status: RESOLVED WORKSFORME
:
Product: mozilla.org
Classification: Other
Component: MozillaBuild (show other bugs)
: other
: x86 Windows XP
: -- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 255460 354793 (view as bug list)
Depends on: 208737 242870 255460 273414
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-11 13:37 PST by Brian Haskin (Janzert)
Modified: 2008-10-06 11:33 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Stripped down tools archive (172.10 KB, application/x-zip-compressed)
2005-07-12 10:36 PDT, Howard Chu
cls: review-
Details
moztools-static with unnecessary binaries removed (249.14 KB, application/octet-stream)
2006-10-09 10:57 PDT, Vladimir Vukicevic [:vlad] [:vladv]
benjamin: review+
Details

Description Brian Haskin (Janzert) 2004-12-11 13:37:46 PST
Many of the current contents of wintools.zip are either no longer needed or
actively cause problems, the directory structure is a mess and it contains cvs
entries from a repository that seems to no longer exist. To help prevent this
from re-occuring in the future as little as possible should be included in
wintools.zip.

The goal of this bug would be to minimize both the contents and actual final
size of wintools.zip, while normalizing the directory structure.

Brian
Comment 1 Howard Chu 2005-07-12 10:36:23 PDT
Created attachment 189071 [details]
Stripped down tools archive

This is a stripped down zip file containing the minimal set of files needed to
build Mozilla. Also in the original archive, the include files were corrupted,
and had \r\r\n line endings. The bogus line endings caused the compilers to
complain. I've fixed them to use just \r\n in this archive.

There is no install.bat here, the files are archived under a "moztools"
directory. Just extract it where you want it, but don't forget to set MOZ_TOOLS
accordingly.
Comment 2 Howard Chu 2005-07-12 10:46:28 PDT
Comment on attachment 189071 [details]
Stripped down tools archive

This bug has been making it a real pain for newcomers to roll a Windows build.
It would be nice to see it resolved soon. I've pointed my MSYS build docs at
this attachment to help lessen the pain in the meantime.
Comment 3 cls 2005-07-12 12:02:57 PDT
Comment on attachment 189071 [details]
Stripped down tools archive

As I pointed out in bug 255460, I'd rather not ship those files as a bundle. 
We'll keep needing to re-release this zip everytime we obsolete something and
that's apparently a painful exercise since it's rarely done.  How does this zip
compare to wintools-dotnet.zip?  (Who uploaded that?) If we stick with
bundling, then we should make sure to version the zip this time.

Since we're re-releasing the files, we should check that the include files work
if you're using unix line-endings as well and probably bump the libidl version
to 0.6.8 so that we have parity with the vc71 libs in
http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/ .
Comment 4 Howard Chu 2005-07-12 12:28:15 PDT
(In reply to comment #1)
> Created an attachment (id=189071) [edit]
> Stripped down tools archive

(mid-air collision, reposting)

For reference, here's the contents of this archive:

Archive:  moztools.zip
 Length   Method    Size  Ratio   Date   Time   CRC-32    Name
--------  ------  ------- -----   ----   ----   ------    ----
       0  Stored        0   0%  01/23/01 12:19  00000000  moztools/
       0  Stored        0   0%  01/23/01 12:19  00000000  moztools/bin/
  162304  Defl:X    53729  67%  04/08/99 14:04  85d5d05e 
moztools/bin/libIDL-0.6.dll
   30208  Defl:X    14440  52%  04/28/98 19:35  0f59c12e  moztools/bin/nsinstall.exe
  112128  Defl:X    50536  55%  04/08/99 14:04  a98fddcf  moztools/bin/glib-1.2.dll
       0  Stored        0   0%  01/23/01 12:19  00000000  moztools/lib/
   66162  Defl:X     4791  93%  04/08/99 14:04  29d1f6e0 
moztools/lib/libIDL-0.6.lib
  272780  Defl:X    17450  94%  04/08/99 14:04  8c95a068  moztools/lib/glib-1.2.lib
       0  Stored        0   0%  01/23/01 12:19  00000000  moztools/include/
    3615  Defl:X     1011  72%  04/07/99 22:04  e597702f  moztools/include/config.h
   92918  Defl:X    23679  75%  04/07/99 22:04  615eb6ae  moztools/include/glib.h
    5155  Defl:X     1674  68%  04/07/99 22:04  a197aa63 
moztools/include/glibconfig.h
       0  Stored        0   0%  01/23/01 12:19  00000000  moztools/include/libIDL/
   24270  Defl:X     5764  76%  04/08/99 14:04  ba65a03d 
moztools/include/libIDL/IDL.h
    3058  Defl:X     1320  57%  04/08/99 06:04  600960cc 
moztools/include/acconfig.h
--------          -------  ---                            -------
  772598           174394  77%                            15 files
Comment 5 Howard Chu 2005-07-12 12:55:54 PDT
(In reply to comment #3)
> (From update of attachment 189071 [details] [edit])
> As I pointed out in bug 255460, I'd rather not ship those files as a bundle. 
> We'll keep needing to re-release this zip everytime we obsolete something and
> that's apparently a painful exercise since it's rarely done.

OK. I didn't realize the full intent of your comment on bug 255460, and nobody
else commenting there seemed to respond to it.

> How does this zip compare to wintools-dotnet.zip?  (Who uploaded that?)

I have no idea. This zip is just a repackaging of the original wintools.zip
files, with the header files fixed.

> If we stick with
> bundling, then we should make sure to version the zip this time.

Good idea. 

> Since we're re-releasing the files, we should check that the include files work
> if you're using unix line-endings as well and probably bump the libidl version
> to 0.6.8 so that we have parity with the vc71 libs in
> http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/ . 

I guess it would make more sense to just create vc6-glib-xxx and vc6-libIDL-xxx.

Anyway, these bugs have been lying around for most of a year with no real
action. What happened to Brian?
Comment 6 cls 2006-10-02 14:03:41 PDT
*** Bug 354793 has been marked as a duplicate of this bug. ***
Comment 7 Vladimir Vukicevic [:vlad] [:vladv] 2006-10-09 10:57:17 PDT
Created attachment 241734 [details]
moztools-static with unnecessary binaries removed

Stripped-down moztools.  Contents:

       0  Stored        0   0%  01/24/06 23:56  00000000  moztools/
       0  Stored        0   0%  10/09/06 10:55  00000000  moztools/bin/
   30208  Defl:X    14440  52%  02/13/06 17:23  0f59c12e  moztools/bin/nsinstall.exe
       0  Stored        0   0%  02/13/06 17:23  00000000  moztools/include/
    3025  Defl:X     1329  56%  02/13/06 17:23  27c16c65  moztools/include/acconfig.h
    3538  Defl:X     1024  71%  02/13/06 17:23  b2dac82d  moztools/include/config.h
   91557  Defl:X    23825  74%  02/13/06 17:23  32865073  moztools/include/glib.h
    4921  Defl:X     1657  66%  02/13/06 17:23  c051d133  moztools/include/glibconfig.h
       0  Stored        0   0%  01/24/06 23:56  00000000  moztools/include/libIDL/
   23987  Defl:X     5838  76%  02/13/06 17:23  91bdc1a2  moztools/include/libIDL/IDL.h
   34325  Defl:X     9295  73%  09/02/03 18:15  55cbb06e  moztools/include/pthread.h
    4552  Defl:X     1837  60%  08/19/03 05:31  855b50a8  moztools/include/sched.h
       0  Stored        0   0%  02/13/06 17:23  00000000  moztools/lib/
  308154  Defl:X    94355  69%  02/13/06 17:23  2a6f9f8e  moztools/lib/glib-1.2_s.lib
  323422  Defl:X    97510  70%  02/13/06 17:23  5f9a3b09  moztools/lib/libIDL-0.6_s.lib
Comment 8 Benjamin Smedberg [:bsmedberg] 2006-10-13 13:51:35 PDT
In trunk builds, this is easy to review with
jar:https://bugzilla.mozilla.org/attachment.cgi?id=241734!/

:-)
Comment 9 Vladimir Vukicevic [:vlad] [:vladv] 2006-10-16 16:06:01 PDT
So wait, who needs to put this in place? =/
Comment 10 Benjamin Smedberg [:bsmedberg] 2006-10-16 16:10:49 PDT
preed, and move the existing moztools to a dated download.
Comment 11 Vladimir Vukicevic [:vlad] [:vladv] 2007-01-04 16:35:15 PST
*** Bug 255460 has been marked as a duplicate of this bug. ***
Comment 12 Ted Mielczarek [:ted.mielczarek] 2008-10-06 11:33:41 PDT
WFM in MozillaBuild.

Note You need to log in before you can comment on or make changes to this bug.