Save flags having the same name on product change

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Frédéric Buclin, Assigned: Frédéric Buclin)

Tracking

({selenium})

2.19.1
Bugzilla 3.0
selenium
Dependency tree / graph
Bug Flags:
approval +
blocking2.20 -
testcase +

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
If two different flag types have the same name in two distinct products, moving
a bug from one product to the other should keep the corresponding flags.
Actually, all flags from flag types which are not in both products are removed.
This is a pain for example with all these review+/- superreview+/- approval+/-
flags which we certainly want to keep (as long as these flag type names exist in
both products).

This is suggested in bug 261995 comment 4 and responds to a real need, for
example bug 274704.

LpSolit: justdave, does it make sense to keep flags if they have the same name?
I would say yes!
justdave: LpSolit: Myk says so in his last comment of that bug
justdave: go find it, and if there isn't one, file it ;)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Flags: blocking2.20?
I'll take this for 2.20, but not blocking release on it.
Flags: blocking2.20? → blocking2.20-
Target Milestone: --- → Bugzilla 2.20
(Assignee)

Updated

12 years ago
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
(Assignee)

Comment 2

12 years ago
*** Bug 290755 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

12 years ago
Note to self: look at Bugzilla::Flag::process():

foreach my $flag_id (@$flag_ids) { clear($flag_id) }

and update flags.type_id for flags which still apply in the new product.
Severity: normal → enhancement
(Assignee)

Comment 4

12 years ago
I won't have time to play with it before the 2.22 freeze
Target Milestone: Bugzilla 2.22 → ---
(Assignee)

Updated

12 years ago
Target Milestone: --- → Bugzilla 2.24
What's the status on this? This caused problems again today when moving devmo stuff to its new product. :/
QA Contact: mattyt-bugzilla → default-qa
(Assignee)

Comment 6

11 years ago
(In reply to comment #5)
> What's the status on this? This caused problems again today when moving devmo
> stuff to its new product. :/
> 

This bug is high in my priority list, but bug 322285 has to land first (because it's higher in my priority list), and itself depends on bug 329537, which depends on mkanat. So pester mkanat to get bug 329537 fixed asap. :)

Comment 7

11 years ago
all of those dependencies are gone. we're still hoping to see this :)
(Assignee)

Comment 8

11 years ago
(In reply to comment #7)
> all of those dependencies are gone. we're still hoping to see this :)
> 

This bug now depends on changes made in bug 174039 and bug 343810. They both should land very soon now (say in the next 10 days). I already started working on this bug today. I can probably have a patch within 2-3 weeks, in time for Bugzilla 3.0.
(Assignee)

Comment 9

11 years ago
My patch is almost ready. I can attach it as soon as bug 343809 lands (I need its _validate() function). Waiting for myk and his review. :)
Depends on: 343809
Keywords: dogfood
Keywords: dogfood
Whiteboard: [wanted-bmo]
(Assignee)

Comment 10

11 years ago
Created attachment 235287 [details] [diff] [review]
patch, v1
Attachment #235287 - Flags: review+
(Assignee)

Updated

11 years ago
Flags: approval?
Whiteboard: [wanted-bmo]
Flags: approval? → approval+
(Assignee)

Comment 11

11 years ago
Checking in Bugzilla/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Bug.pm,v  <--  Bug.pm
new revision: 1.143; previous revision: 1.142
done
Checking in Bugzilla/Flag.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Flag.pm,v  <--  Flag.pm
new revision: 1.75; previous revision: 1.74
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Keywords: relnote
(Assignee)

Updated

11 years ago
Flags: testcase?
*** Bug 362497 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

11 years ago
Blocks: 364216

Comment 13

10 years ago
Added to the relnotes currently attached to bug 349423.
Keywords: relnote
(Assignee)

Updated

10 years ago
Flags: testcase? → testcase+
(Assignee)

Updated

10 years ago
Blocks: 391073
(Assignee)

Updated

10 years ago
Keywords: selenium
You need to log in before you can comment on or make changes to this bug.