Closed Bug 275636 Opened 20 years ago Closed 18 years ago

Templatise 'newchangedmail' email (BugMail)

Categories

(Bugzilla :: Email Notifications, enhancement, P1)

2.19.1
enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 3.0

People

(Reporter: mkanat, Assigned: batosti)

References

Details

Attachments

(2 files, 2 obsolete files)

We need to make 'newchangedmail' into a template instead of a parameter.

See the patches on bug 84876 for hints and implementations.
Blocks: 100089
No longer blocks: 100089
Blocks: 70710
Kerio would like this, so I'll try to get it in for 2.20.
Assignee: justdave → mkanat
Target Milestone: --- → Bugzilla 2.20
Priority: -- → P1
Assignee: mkanat → nobody
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
Blocks: 268577
Assignee: nobody → eseyman
Depends on: 215148
Status: NEW → ASSIGNED
Blocks: 311448
No longer blocks: 311448
The trunk is now frozen to prepare Bugzilla 2.22. Enhancement bugs are retargetted to 2.24.
Target Milestone: Bugzilla 2.22 → Bugzilla 2.24
No longer blocks: 70710
Blocks: 135812
QA Contact: mattyt-bugzilla → default-qa
Attached patch batosti_v1 (obsolete) — Splinter Review
Assignee: eseyman → batosti
Attachment #232770 - Flags: review?(LpSolit)
Attached patch batosti_v1_fix (obsolete) — Splinter Review
Attachment #232770 - Attachment is obsolete: true
Attachment #233258 - Flags: review?(LpSolit)
Attachment #232770 - Flags: review?(LpSolit)
Comment on attachment 233258 [details] [diff] [review]
batosti_v1_fix

Looks good. I saw no regression. r=LpSolit
Attachment #233258 - Flags: review?(LpSolit) → review+
Flags: approval?
Comment on attachment 233258 [details] [diff] [review]
batosti_v1_fix

Don't use terms.Bugzilla in the headers. If they make it into something with a space, it will break email.

They're headers--users don't see them. Just keep them standard across all Bugzillas by not renaming them.
Attachment #233258 - Flags: review-
Comment on attachment 233258 [details] [diff] [review]
batosti_v1_fix

Also, why in the world did you do Bugzilla::Template->create()??? Use Bugzilla->template!
Flags: approval?
(In reply to comment #7)
> (From update of attachment 233258 [details] [diff] [review] [edit])
> Also, why in the world did you do Bugzilla::Template->create()??? Use
> Bugzilla->template!
> 

batosti said that using Bugzilla->template was conflicting with the current template being processed, e.g. in process_bug.cgi when process.html.tmpl calls bugmail.html.tmpl.
This fix in 009bugwords.t will be required to not complain about X-Bugzilla.
Attachment #233313 - Flags: review?(mkanat)
Comment on attachment 233313 [details] [diff] [review]
Do not complain about X-Bugzilla

Yeah, LpSolit explained on IRC that ?<! means "find  this regex only if it doesn't start with these characters."
Attachment #233313 - Flags: review?(mkanat) → review+
Why not just using the syntax used in bug 135812

X-B[%#%]ugzilla-Type: 

Attached patch batosti_v2Splinter Review
i use Bugzilla::Template->create() instead Bugzilla->template because the bugmail is called by a template and if i call the process method from Bugzilla->template it's rewirte the actual template and an error is given.
Attachment #233258 - Attachment is obsolete: true
Attachment #233588 - Flags: review?(LpSolit)
(In reply to comment #11)
> Why not just using the syntax used in bug 135812
> 
> X-B[%#%]ugzilla-Type: 
> 

Because that's a ugly hack
Comment on attachment 233588 [details] [diff] [review]
batosti_v2

I checked that replacing Bugzilla::Template->create() by Bugzilla->template generates an error.

We should remove SendBugMail from Template.pm IMO, which is only used in template/en/default/bug/process/bugmail.html.tmpl

Nit: probably should we 'use Bugzilla::Template' from BugMail.pm. Not sure this is required though.

r=LpSolit
Attachment #233588 - Flags: review?(LpSolit) → review+
Flags: approval?
Flags: approval? → approval+
Checking in Bugzilla/BugMail.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/BugMail.pm,v  <--  BugMail.pm
new revision: 1.88; previous revision: 1.87
done
Checking in Bugzilla/Config/MTA.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Config/MTA.pm,v  <--  MTA.pm
new revision: 1.10; previous revision: 1.9
done
Checking in t/009bugwords.t;
/cvsroot/mozilla/webtools/bugzilla/t/009bugwords.t,v  <--  009bugwords.t
new revision: 1.4; previous revision: 1.3
done
Checking in template/en/default/admin/params/mta.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/params/mta.html.tmpl,v  <--  mta.html.tmpl
new revision: 1.6; previous revision: 1.5
done
RCS file: /cvsroot/mozilla/webtools/bugzilla/template/en/default/email/newchangedmail.txt.tmpl,v
done
Checking in template/en/default/email/newchangedmail.txt.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/email/newchangedmail.txt.tmpl,v  <--  newchangedmail.txt.tmpl
initial revision: 1.1
done
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Blocks: 466968
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: