Last Comment Bug 276808 - mozilla-xremote-client "openURL($xuri,new-tab)" now opens new window instead of tab
: mozilla-xremote-client "openURL($xuri,new-tab)" now opens new window instead ...
Status: RESOLVED WORKSFORME
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- major with 5 votes (vote)
: ---
Assigned To: tabbed-browser
:
Mentors:
Any URL
: 278437 (view as bug list)
Depends on: 278867
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-02 18:00 PST by M ODonnell
Modified: 2008-04-04 06:33 PDT (History)
17 users (show)
dbaron: blocking1.8b-
bzbarsky: in‑testsuite?
bzbarsky: in‑litmus?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description M ODonnell 2005-01-02 18:00:32 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20050101
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6) Gecko/20050101

mozilla-xremote-client "openURL($xuri,new-tab)" (as invoked from EXMH when I
click an URL in a msg) worked reliably as recently as mozilla1.8a6.20041129 but
now that I't the mozilla1.8a6.20050101 build it ALWAYS opens a new window
instead of just using a tab in an existing window.

Reproducible: Always

Steps to Reproduce:

1. from Linux command line (with Mozilla already running) just say

  mozilla-xremote-client "openURL(http://www.mozilla.org/,new-tab)"

...and a new window will be opened instead of a tab.

Actual Results:  
A new window is opened instead of a tab

Expected Results:  
A new tab in an existing window should have been created.
Comment 1 Akkana Peck 2005-01-13 18:28:06 PST
Confirming.  This is a major loss of functionality.  Requesting blocking status.
Comment 2 Akkana Peck 2005-01-13 18:50:05 PST
It's actually worse than that.  mozilla -remote 'openURL(http://mozilla.org)'
also opens in a new window, even without the new-tab.  There seems to be no way
to call mozilla -remote now without opening a new window.  Eek!
Comment 3 Akkana Peck 2005-01-16 23:20:58 PST
There's a new pref, browser.link.open_external, which according to a terse
comment on http://www.mozilla.org/unix/customizing.html#prefs should affect this
behavior somehow.  But I've tried setting it to 1, 2, and 3 via about:config
(user.js seems to be no longer working in 1.8a6!) and with all three settings
mozilla -remote 'openURL(http://mozilla.org)' opened a new window.  

The comment on the customizing page notes: "(May not work quite right in 1.8a
Suite builds on Windows)" but the pref seems to be completely ignored on Linux,
so that comment may not go far enough.
Comment 4 Akkana Peck 2005-01-16 23:22:17 PST
DanM, is this behavior related to the other tabbed browsing prefs we were
discussing in bug 278429?
Comment 5 Dan M 2005-01-18 10:43:57 PST
I'm changing this bug's product to Suite. Sure it's more a core problem but in
this case there really is an app distinction. This works in Firefox, though bug
267435 maintains that it's partially broken there. I'm prepared to believe that
it's completely broken in the Suite. See bug 278867.
Comment 6 Dan M 2005-01-18 10:46:18 PST
*** Bug 278437 has been marked as a duplicate of this bug. ***
Comment 7 Hidehiro Kozawa 2005-02-03 05:34:51 PST
In Japanese bugzilla one reported that make with 'cvs co -r1.44
mozilla/xpfe/components/xremote/src/XRemoteService.cpp'
is not reproduced.

relate bug 172962, 263689?
Comment 8 David Baron :dbaron: ⌚️UTC-7 (review requests must explain patch) 2005-02-17 12:48:58 PST
Too late for 1.8b, but it should block 1.8b2.
Comment 9 Wolfgang Rosenauer [:wolfiR] 2005-02-20 04:32:56 PST
isn't this fixed?
I can't reproduce this since two or three weeks now. But will check again.
Comment 10 Dan M 2005-02-20 09:05:22 PST
Bug 231984 helped but I would have thought it wasn't enough. Still if you find
that everything is working, may as well close the bug.
Comment 11 Wolfgang Rosenauer [:wolfiR] 2005-02-23 23:03:04 PST
WFM now with 20050223 build.
Comment 12 Christopher Blizzard (:blizzard) 2005-02-24 07:00:17 PST
Marking worksforme based on comments.
Comment 13 Akkana Peck 2005-02-27 09:09:04 PST
Not fixed: reopening.  In 1.8b1, opening as new-tab works; but attempting to
open in the same tab/window (see comment 2) opens in a new tab as well.
Comment 14 Misak Khachatryan 2008-04-04 02:39:36 PDT
Mozilla/5.0 (X11; U; Linux i686; rv:1.9pre) Gecko/2008040301 SeaMonkey/2.0a1pre
Working as expected. Reopen if your test differs.

Note You need to log in before you can comment on or make changes to this bug.