Closed Bug 277187 Opened 15 years ago Closed 11 years ago

unable to change the "and place my signature" pref if no signature is set

Categories

(MailNews Core :: Account Manager, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: sspitzer, Assigned: rsx11m.pub)

References

Details

Attachments

(2 files, 1 obsolete file)

unable to change the "and place my signature" pref, it is always disabled

1) go into the account manager, and choose compose and addressing panel for an
account.
2) try to change the "and place my signature" pref

I'm not able to change the value.  the pref appears "locked" and disabled.

I've seen this on win xp with tbird 1.0, and I've been told mac has it too.
The control is disabled if the account doesn't have a signature configured.
Could you open the main account settings page for the account--the page where
you set your name and email address--and verify that you've checked "attach this
signature" and set a signature filename?
works fine here

note it's only enabled if you actualy have a signature getting attached to that
identity otherwise the app disables it
It's also disabled unless the previous item is set to "start my reply above the 
quote."
I just encountered this symptom as reported, and I see it with TB 1.0 and 
1.0+0222.  At first I thought it might have had to do with accessing the pref on 
a secondary identity, or via the Manage Identities window, but I see the same 
symptom now on a fresh restart of 1.0 and editing via the Account Settings' 
Composition page (default identity).

I know I checked this using 1.0 when this bug was first reported and it worked 
as expected then.

I hit this while testing for bug 284058.
I'm seeing this problem in Mozilla, too: not only in 1.8b2-0309, but also in 
1.7.5; and it appears to be profile-related, altho I can't figure what the
signifcant difference is.

The two files in the ZIP are prefs-failing.js and prefs-working.js.  
With the former loaded in the profile, 1.7.5 and 1.8b don't enable the "place
my signature" field when "start my reply above the quote" is selected.	

Both profiles work as expected with 1.6.
(In reply to comment #6)
> Created an attachment (id=177014) [edit]
> The two files in the ZIP are prefs-failing.js and prefs-working.js.  
> With the former loaded in the profile, 1.7.5 and 1.8b don't enable the "place
> my signature" field when "start my reply above the quote" is selected.	
But one of them doesn't have attach_signature set...
(In reply to comment #7)
> (In reply to comment #6)
> > Created an attachment (id=177014) [edit] [edit]
> > The two files in the ZIP are prefs-failing.js and prefs-working.js.  
> > With the former loaded in the profile, 1.7.5 and 1.8b don't enable the
> > "place my signature" field when "start my reply above the quote" is
> > selected.	
>
> But one of them doesn't have attach_signature set...

D'oh!  You're absolutely right.  I wonder if that's what Seth ran into.
I just ran into this, couldn't figure out why it was always disabled. Then I read this bug, and realized I didn't have a sig for that account... And yes, I bet this is what this bug is about.  

Is it really a point in disabling signature position when no signature is set up?
I'll take a patch that gets rid of the disable logic for this Magnus. 
Maybe it would be more obvious if we moved the signature to Composition?
QA Contact: account-manager
Assignee: mscott → nobody
OS: Windows XP → All
Hardware: PC → All
Duplicate of this bug: 425063
Assignee: nobody → mkmelin+mozilla
Magnus, are you working on this bug or can I take it?

If it's just about simplifying the logic for disabling that menu, rolling back the additions I've made during bug 324495 plus the logic based on the checkbox should be fairly straightforward.
Haven't done anything about it yet, so here you go.
Assignee: mkmelin+mozilla → rsx11m.pub
Thanks, patch follows soon...
Status: NEW → ASSIGNED
Version: unspecified → Trunk
Summary: unable to change the "and place my signature" pref, it is always disabled → unable to change the "and place my signature" pref if no signature is set
Attached patch Proposed fix (obsolete) — Splinter Review
This reduces both code complexity and user confusion. The dependencies on the signature prefs are removed, the menu remains still enabled only for "above the quote" though as it doesn't apply to any of the other options. The patch also removes the two hidden XUL elements which were needed as a workaround to get the signature pref settings from the main account page. That doesn't have any side effects, those were accessed strictly read only.
Attachment #384262 - Flags: ui-review?(clarkbw)
Attachment #384262 - Flags: superreview?(bienvenu)
Attachment #384262 - Flags: review?(mnyromyr)
Attachment #384262 - Flags: ui-review?(clarkbw) → ui-review+
Product: Thunderbird → MailNews Core
QA Contact: account-manager → account-manager
Attachment #384262 - Flags: review?(mnyromyr) → review+
Unbitrotted for bug 490118 changes in directory structure, only the path names have been modified after removal of /resources/ in mailnews.

Carrying forward ui-r=clarkbw and r=mnyromyr
Attachment #384262 - Attachment is obsolete: true
Attachment #389482 - Flags: ui-review+
Attachment #389482 - Flags: superreview?(bienvenu)
Attachment #389482 - Flags: review+
Attachment #384262 - Flags: superreview?(bienvenu)
Attachment #389482 - Flags: superreview?(bienvenu) → superreview+
Thanks for the reviews, push on comm-central please.
Keywords: checkin-needed
Whiteboard: [c-n: comm-central]
Checked in: http://hg.mozilla.org/comm-central/rev/228e78806cbf
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [c-n: comm-central]
Target Milestone: --- → Thunderbird 3.0b4
Blocks: 505431
You need to log in before you can comment on or make changes to this bug.