If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"My Sidebar" does not show bookmarks on initial sidebar operation

VERIFIED WORKSFORME

Status

SeaMonkey
Sidebar
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: ckim, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
From Bug Helper:
User-Agent: Mozilla/4.7 [Kondara-ja] (X11; I; Linux 2.2.14-2k11 i686)
BuildID:    2000021510
Launching Mozilla with "My Sidebar" closed will lead to inconsistent
behavior of "My Sidebar".
Opening "My Sidebar" by clicking on the "Blue bar" gives you normal
bookmark tree view.
However, opening "My Sidebar" by dragging sidebar border line gives
you no bookmark tree view while the bookmark tab is highlighten
Besides, clicking on the bookmark tab does not work.
Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla with "My Sidebar" closed
2. Click on the "Blue bar" of "My Sidebar" and open "My Sidebar"
3. The above operation gives you bookmark tree view in "My Sidebar"
   This is good.
4. Close "My Sidebar" and quit Mozilla
5. Again, Launch Mozilla with "My Sidebar" closed
6. Drag "My Sidebar" vertical border line and open it
7. There will be no bookmark tree view shown in "My Sidebar"
8. Click on "Bookmarks" tab
9. Again, no bookmark tree view will be shown

Expected Results:  Drag-opening of "My Sidebar" should give bookmark tree view
when the "Bookmarks" tab is highlighten.

Comment 1

18 years ago
I see this also, though I don't notice any difference between opening with the
splitter or opening with a drag.

This happens with all panels. If you start with the sidebar closed, no content
is shown the first time you open it.

Nice catch ckim.

This is not beta1 material.
(Reporter)

Comment 2

18 years ago
I also confirmed that there is no difference between opening sidebar by
splitter and dragging.
I will re-check this to find the right procedure to have the same symptom.
Anyway, sorry for posing incorrect report.

Comment 3

18 years ago
I'm seeing this on Win98 too.

Comment 4

18 years ago
*** Bug 31418 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
This bug is very important, and its status should be changed to "Major."  I hope
this will be fixed by M15, so that field should be added as well.

Comment 6

18 years ago
*** Bug 32318 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
marking beta1 because johng had marked the dup beta1
Keywords: beta1

Comment 8

18 years ago
The other more common way to reproduce this bug is detailed in duplicate bug 32318.

This happens everytime the user closes the Sidebar before quitting.  The next
time they launch mozilla and open My Sidebar, the tab will be empty - this is
true for all tabs, not just Bookmarks.

It's a common problem and makes My Sidebar look broken.  If the fix is low risk,
this should be beta1.

Comment 9

18 years ago
The beta1 train is basically closing its doors.  We'd need info that the fix was
in hand, tested, and low risk... and might almost need it checked in by Sunday
night :-/.
Bottom line: Unless an engineers *happens* to be around this weekend, and
happens to make great progress... it is simply getting too late to consider.
We'll talk about the bug at the PDT meeting on Monday... but I wanted you all to
understand the situation.
Thanks,
Jim
(Assignee)

Comment 10

18 years ago
We don't need this for beta1. I'll fix this for beta2.

Comment 11

18 years ago
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]

Comment 12

18 years ago
*** Bug 34267 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
spam: changing qa contact on sidebar bugs from paulmac to shrir@netscape.com 
(all 67 of them!)
QA Contact: paulmac → shrir
(Assignee)

Comment 14

18 years ago
I saw this before, but I can no longer reproduce it.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
Works for me:
Platform: PC
OS: Redhat 6.2 Linux 2.2.14
Mozilla Build: 2000103108 M18 Trunk Build

Marking as verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.