Closed Bug 278940 Opened 16 years ago Closed 14 years ago

Make AMO's search feature not suck

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ted, Unassigned)

References

Details

Attachments

(1 file)

Get version numbers back in, only show results for your platform/OS, etc.
Status: NEW → ASSIGNED
Showing only compatible results may just confuse someone.  If they're searching
for Pinball, and they have Firefox 1.1, they wouldn't find it.  But they'd know
it was on the site, so they'd be frustrated.  Gonna have to ponder this.
There's two things
1) Search results showing version & compatibility
2) Being able to perform an advanced search

For the latter, bug 247810 has an attachment for this.  

I don't want the search results to have more than one row per main ID, so we'll
have to roll things up.
I also want to make the search form have what you searched for filled in.  Right
now when you do a search, the search form in the header is empty.
I think we need to transition from quicksearch to advanced search.  In other
words, quicksearch is just a temporary measure.  

Advanced search would have its own search form with various dropdowns to refine
the results.  if its not bitrotted, try the search.php from the other bug.  
You should respect compatibilty information, by default. Compatibilty info is
*important* to the presentation of Firefox (or any app) to people who are new.
do NOT rely on application errors to catch your mistakes, by that point, the
User experience has failed.
Target Milestone: 1.0 → 1.1
I think the search feature seems somewhat broken.  I have done several searches
for things I know exist, yet I get zero results.  The reason is to do with the
filtering by OS, which Google has got wrong (having presumably just done what
would normally be expected of it).  Therefore, some attention needs to be given
to the way the filtering-by-OS works.

Also I'd really like to see a page of extension titles - all of them (perhaps
filtered by OS), so I can search using the browser instead of relying on the
search engine.  At the moment, there are 19 pages in the All Extensions
category, so searching by Google is the only way. And its broken. :-(
Rick: are you talking about the Google search, or the new search that hasn't
been rolled out to the live site yet?  This bug is about the latter.
Going from
themes/showlist.php?application=firefox&version=1.0&os=Windows&category=Compact

to clickong on Search makes us lose our "remembered" information like the
detected OS, app, and version.  
We should replace spaces with wildcards.  Doing a search for "undo close tab"
should have found the extension named "undoclosetab"
Just searched for 'thunderbird redirect', and it did not pull up the Mail
ReDirect extension page:

https://addons.update.mozilla.org/extensions/moreinfo.php?application=thunderbird&category=Miscellaneous&numpg=10&id=550

Case-correct search did not work either.

Russell
Russel: it's not the case that's making that search not work.  Search only
searches the extension name and description, neither of which contain the word
"thunderbird".  Also comment 9 would probably cause us to not find it anyway,
even if thunderbird was in there.
Hmmm.  We might want to consider removing certain words when querying, like
"Mozilla", "TB", "Thunderbird".... 

And of course if someone uses keywords like AND or OR, we don't handle those. 
Same with negation.
Target Milestone: 1.1 → 2.0
Assignee: ted.mielczarek → Bugzilla-alanjstrBugs
Status: ASSIGNED → NEW
QA Contact: mozilla.update → web-ui
v2 = sexy. Do we think resolved?
v2 is sexy, but some of the ideas from here are still valid.  Paul, can you create a patch against trunk?
I've not been following v2 for a while so I'd need to update the tree and find the new place to put this in. I'm sure morgamic would be able to do this easier so I've added a CC for him. If not then I'll put it on the list.
Mass change - bugs to be read / (re)confirmed.
Assignee: Bugzilla-alanjstrBugs → nobody
Priority: -- → P5
Bugspam makes us be-come druggies
Fa-la-la-la-la, la-la-la-la
Get morgamic some more coffee
Fa-la-la-la-la, la-la-la-la

Updating all the bugs which have "Update" or "UMO" in them.
Summary: Make update's search feature not suck → Make AMO's search feature not suck
Depends on: 347202
I believe we should close this (now that AMOv3 was released) and for improvements to the new search page there is already a bug out there; also, new bugs should ideally be more specific.
Sounds good, this was pretty much just to fix the crappiness of my original search impl.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.