If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No way to have several locales of the same extension listed and updated

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
13 years ago
2 years ago

People

(Reporter: Alex Sirota (iosart), Assigned: alanjstr)

Tracking

unspecified

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Consider the following scenario - an author releases extension version 0.5
This version contains 3 locales. Two days after the version is released and
listed on UMO, the author receives another translation from a volunteer. There
is no way for the author to have this additional translated version listed
without releasing a new version of the extension. If the author indeed releases
a new version, all the existing users are forced to upgrade the extension, when
in fact no new features were added and the new language probably doesn't
interest most of them.

The author should be able to add any number of separate packages, each having
the same version and containing any number of locales. When first installing the
extension, the user is presented with a list of all the available locales. When
upgrading, the update service will try to locate a new version of the extension
that corresponds to the user locale. If not found, there are two choices (should
be configurable by the extension author):
1. Serve the latest English version of the extension
2. If the author has a reason to believe that a new locale will be added soon,
he might specify this, and the users asking for updates having this locale will
see the older version ("no update found") until the new locale is added. This
preference should be configurable on a per-locale basis.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

13 years ago
That would be a nightmare to manage, both on the application side and on the
website side.

The author can re-release version 0.5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

13 years ago
Closely related to (depends on?) bug 258878
(Assignee)

Comment 3

13 years ago
Come back when bug 258878 has been resolved.  Once I have a better handle on how
the applications will deal with languages, we can take a look at how the website
can accomodate.  I would not want to prevent someone from knowing a new version
is released just because it doesn't have their locale.
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> I would not want to prevent someone from knowing a new version
> is released just because it doesn't have their locale.

That's exactly the problem with bug 258878 - users see an update is available
and if the update doesn't include their locale that would always break their
browser! 
If the browser cannot deal with this problem, it can be solved on the UMO side
in the meantime - the two should really complement each other. Things like that
(browser breaking) aren't very good for Firefox reputation in the non-English
speaking countries.
Duplicate of this bug: 476730
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.