Thunderbird imports mixes up accounts and folders

RESOLVED DUPLICATE of bug 268034

Status

--
minor
RESOLVED DUPLICATE of bug 268034
14 years ago
12 years ago

People

(Reporter: naderrau, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Consistently when trying to install Thunderbird 1.0 I am getting all my imports
from Mozilla 1.7.5 but the folders belong to account A are under account B and
vice versa.

Reproducible: Always

Steps to Reproduce:
1..Setup Mozilla mail to recieve mail with rules for three different accounts
and sort it into about 50 different folders.
2.Install Thunderbird.
3.Import everything from Mozilla 1.7.5 to Thunderbird.


Actual Results:  
Everything is imported but account settings are mixed up with folders, i.e. ISP
mail folders show up under account called school, school folders show up under
ISP account.


It appears that it's just a folder issue.  I checked which mail folder was
pointing at which directory and renamed localhost-1 to localhost-2 and
localhost-2 to localhost-1 and everything came up roses.

Comment 1

14 years ago
Same thing for me, but on Debian GNU/Linux with five pop accounts and local
folders.  I was migrating from Mozilla 1.7.5-1 to Thunderbird version 1.0
(20050117).  No errors when importing, but my pop accounts were all mixed up.

I think this should be a priority, because if users cannot trust the program to
import from its cousin, Mozilla, then I don't know if they will want to switch.

Comment 2

14 years ago
Same for me. I was upgrading from Mozilla 1.7.3 to Thunderbird 1.0.3.  I have
about 12 accounts spread over 4 domains and 1 SMTP setting.  Everything (like
the account identifiers and POP settings) seemed to migrate correctly except
that the 12 accounts were often not associated with the correct physical
directory of mail messages (Local folders). On the Server Settings option, the
long pathname would point to one of the folders always within the CORRECT
domain, but the particular account within that domain would not always be
pointing to the correct group of mail messages.

Having to reorder the pointers was an unexpected annoyance, because I had to
crreate some dummy folders and then reset the Local folder pointers one at a
time and then close and reopen Thunderbird to have the duplicates checking code
get the new setting.

Oh, and I was NOT using the option that lets one put all the incoming messages
into a common Inbox, but keeping them as they were in the Mozilla mailer.    
 - dharris234 at mindspring.com

Comment 3

13 years ago
Related to/duplicate of bug 268034?

Comment 4

13 years ago
I have 6 accounts on 2 domains using the 1.7.5 Mozilla Suite... all works fine.
With Thunderbird 1.0.6 two separate things occur.

1. The 4th account shows the folders associated with the 1st account. The
folders are also accessible from the 1st account. these two accounts use the
same ISP address. pop.frognet.net for the first account and pop.frognet-1.net
for the 4th

2. The 5th account fails to show any folders although they are there using
Mozilla suite. This account is also the same ISP  mail.frognet.net

I might add that the 2nd and 3rd accounts are Hotmail accounts using hotpop and
127.0.0.1 as the address. Unless Hotmail is down the two hotmail accounts appear
to work properly in both the Mozilla Suite and Thunderbird.


Feel free to communicate with me either by email or telephone and I will work
with you on solving the problem

regards
Thomas

Comment 5

13 years ago
(In reply to comment #3)
> Related to/duplicate of bug 268034?
> 

Yeps, sorry that i didn't noticed that one, i found bug 260966 but noticed it was stated as resolved, but it also seems to relate to that one.
And 281584.

But those bug references above don't mention anything about mail filters though,  it's important since mail filters belonging with the folder structures move along with them to the other account.
I just am indicating it does not seem to be just a structure in confusing some tables but as well as in an interpretation of the preference configuration file.

Vince.
Component: Installer → Migration
QA Contact: migration
(In reply to comment #5)
> (In reply to comment #3)
> > Related to/duplicate of bug 268034?
> > 
> 
> Yeps, sorry that i didn't noticed that one, i found bug 260966 but noticed it
> was stated as resolved, but it also seems to relate to that one.
> And 281584.
> 
> But those bug references above don't mention anything about mail filters
> though,  it's important since mail filters belonging with the folder structures
> move along with them to the other account.

Having just posted the fix on bug 260966, I can say that that bug would also affect mail filters as well as the result effect of the bug is that mail folders are getting mixed around servers and the folders include the mail filter files.

Therefore marking as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 260966
(In reply to comment #6)
> Having just posted the fix on bug 260966, I can say that that bug would also
> affect mail filters as well as the result effect of the bug is that mail
> folders are getting mixed around servers and the folders include the mail
> filter files.
> 
> Therefore marking as duplicate.
> 
> *** This bug has been marked as a duplicate of bug 260966 ***

Ok, my fault, this should have been a duplicate of bug 268034 -> correcting.
Duplicate of bug: 268034
You need to log in before you can comment on or make changes to this bug.