Closed Bug 282183 Opened 17 years ago Closed 15 years ago

sync xpfe listbox.xml with toolkit listbox.xml

Categories

(Core :: XUL, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.8beta2

People

(Reporter: mconnor, Assigned: sgautherie)

References

Details

(Whiteboard: [SergeG: Waiting for bug 280153 comment 23])

Attachments

(2 obsolete files)

 
Blocks: 282177
URL:
Depends on: 274712
Diff from Xpfe to Toolkit version.

These came from Toolkit versions:
{{
1.11	ben%bengoodger.com	2005-02-25 01:07		274712 - new
options dialog
1.2	blakeross%telocity.com	2002-11-10 18:25		Fix the delay
when arrow keying up and down in the themes/extensions listboxes (and other
listboxes).
}}
(In reply to comment #1)
> Created an attachment (id=176653) [edit]
> 2005.03.08 X2T diff report

This one would look simple enough for me to take:
What would be the expected non-regression test(s) for these changes ?
(Jan: Could you update your address on <http://www.mozilla.org/owners.html> ?)
Comment on attachment 176653 [details] [diff] [review]
2005.03.08 X2T diff report
[Checked in: Comment 6]

r+sr=me

The test would be to open e.g. Themes preferences and look how quickly it
responds to the arrow keys.
*** Bug 271935 has been marked as a duplicate of this bug. ***
Comment on attachment 176653 [details] [diff] [review]
2005.03.08 X2T diff report
[Checked in: Comment 6]


Check in: { 2005-03-09 05:47	neil%parkwaycc.co.uk	mozilla/ xpfe/ global/
resources/ content/ bindings/ listbox.xml	 1.23 }
Attachment #176653 - Attachment description: 2005.03.08 X2T diff report → 2005.03.08 X2T diff report [Checked in: Comment 6]
Attachment #176653 - Attachment is obsolete: true
(In reply to comment #4)
> (From update of attachment 176653 [details] [diff] [review] [edit])
> r+sr=me

(Neil, for the record, could you add these flags to the patch too ;->)

> The test would be to open e.g. Themes preferences and look how quickly it
> responds to the arrow keys.

I tried this and Languages (-> Add):
I can say it still works :-)
(then I could not tell the (VK_UP/VK_DOWN) speed difference ... anyway.)
Assignee: nobody → cbiesinger
Target Milestone: --- → mozilla1.8beta2
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
serge, it was your patch :) no reason to assign to me.
Assignee: cbiesinger → gautheri
Attachment #176653 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #176653 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #176653 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #176653 - Flags: superreview+
Attachment #176653 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #176653 - Flags: review+
Attachment #176653 - Attachment is obsolete: false
A few space nits,
and a |var| redeclaration.
Attachment #210717 - Flags: superreview?(neil)
Attachment #210717 - Flags: review?
Attachment #210717 - Flags: review? → review?(mconnor)
Depends on: 280153
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [SergeG: Waiting for bug 280153 comment 23]
Attachment #210717 - Flags: superreview?(neil)
Attachment #210717 - Flags: superreview+
Attachment #210717 - Flags: review?(mconnor)
Attachment #210717 - Flags: review+
Comment on attachment 210717 [details] [diff] [review]
(Bv1) nits, in the meantime
[Checked in: Comment 10]


Check in: { 2006-02-24 07:16	bugzilla%standard8.demon.co.uk }
Attachment #210717 - Attachment description: (Bv1) nits, in the meantime → (Bv1) nits, in the meantime [Checked in: Comment 10]
Attachment #210717 - Attachment is obsolete: true
Attachment #176653 - Attachment is obsolete: true
Depends on: 304676
SeaMonkey is now using toolkit, do we still need to port anything from xpfe's listbox.xml to toolkit or can we close this bug?
No, the only bonus xpfe listbox has over toolkit is that it has none of the regressions caused by bug 281053 (which are few and far between for listboxes).
in this case, I'm re-marking the bug fixed (due to it containing fixes that have been checked in). Please reopen or file new bugs if we run across something unexpected we still would need to port to toolkit.
Status: REOPENED → RESOLVED
Closed: 17 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.