Searching for bookmarks in Sidebar or Library ignores keywords (doesn't find matches in Organize Bookmarks Manager)

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
13 years ago
3 years ago

People

(Reporter: Hadmut Danisch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)

When managing bookmarks and giving a bookmark a keyword, the 
sidebar bookmark search function does not find it.

Reproducible: Always

Steps to Reproduce:
1. Enter a bookmark and give it some keyword
2. View->Sidebar->Bookmarks
3. Enter the keyword in the search entry field

Actual Results:  
Does not find the bookmark

Expected Results:  
Should find the bookmark

Comment 1

13 years ago
I get the same results in 1.0.4 on Windows XP. Bookmark search does not find
keyword entries in ether the sidebar search or the Bookmark Manager search.

Updated

13 years ago
Depends on: 176400
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 3

10 years ago
valid for library too
Summary: sidebar bookmark search ignores keywords → bookmark search ignores keywords

Updated

10 years ago
Duplicate of this bug: 462088

Updated

10 years ago
OS: Linux → All
Hardware: x86 → All
Summary: bookmark search ignores keywords → Searching for bookmarks in Sidebar or Library ignores keywords (doesn't find matches in Organize Bookmarks Manager)
Which file(s) in mxr do we need to look at to change this?

There's just no way to manage your keyworded (NOT tagged) bookmarks in any useful way, FF doesn't even show keywords as an (optional) column in search results.
(In reply to comment #5)
> There's just no way to manage your keyworded (NOT tagged) bookmarks in any
> useful way, FF doesn't even show keywords as an (optional) column in search
> results.
I'm glad to be wrong there, we're just missing the column picker icon on column header, but you can actually display keywords column in Library's search results by going through View -> show columns menu. That's better than nothing, but not half as good as it could be, e.g. when we could just search for them keywords...
So question remains:

> Which file(s) in mxr do we need to look at to change this?
Marco, ping?

(In reply to comment #5)
> Which file(s) in mxr do we need to look at to change this?

The procedure of changing a specific bookmark with keyword is really overly complicated.
nsNavHistory.cpp has a filtering method, but searching is already a bit slow due to the fact we can't use indices nor like, since there aren't many keywords I guess the perf downside would be worse than the gain.
The benefit to search for the keywords is very low and would also be a perf hog, would be better to spend resources for a fulltext search or similar, keywords are intended to give different benefits than searchability.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 10

3 years ago
Over two years ago, you closed this bug because it "would be better to spend resources for a fulltext search or similar".  Did this ever happen?

If not, can this bug be re-opened?

The functionality is desperately needed, and performance issues that were reportedly present 5 years ago should no longer exist.
Flags: needinfo?(mak77)
(In reply to quality+bugzilla from comment #10)
> Over two years ago, you closed this bug because it "would be better to spend
> resources for a fulltext search or similar".  Did this ever happen?
> 
> If not, can this bug be re-opened?

Nope, but that answer is still valid.
Moreover, now keywords are no more bound to bookmarks, they now relate to URIs. The plan is to eventually add a view to the Library to manage keywords directly, similar to what happens to tags.

> The functionality is desperately needed, and performance issues that were
> reportedly present 5 years ago should no longer exist.

I'm sorry that you are really in need of that functionality, but unfortunately it's not a priority cause it's unlikely most users might need it. An add-on could easily plug that functionality for users willing it.
Flags: needinfo?(mak77)
You need to log in before you can comment on or make changes to this bug.