Cannot search URL (location), only the name

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: Rack, Assigned: Pierre Chanial)

Tracking

(Blocks: 1 bug)

Trunk
Future
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Bookmark - enhanced find.

Comment 1

15 years ago
This has been in the release notes since 0.1 I believe. Setting status to New
(do we really not have this reported already?)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Target Milestone: --- → After Firebird 1.0
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 3

13 years ago
Why is this bug "After Firefox 1.0"? Even bug 171575 (Implement "find bookmark")
is set as "Firefox 1.0".
Created attachment 158509 [details] [diff] [review]
No locale change patch

Some more labels would make UI more user-friendly, I think.

e.g.
Search: |foo	 | in |Location|

I'm not sure "in" is grammatically correct though.

Updated

13 years ago
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0?

Updated

13 years ago
Attachment #158509 - Flags: review?(mconnor)
I don't know how we're going to deal with UI changes post PR, so this might not
even make 1.0.

Its not a blocker at present, if its safe/low-risk enough, we might consider it,
but we wouldn't block the release on this.

Will review as soon as I have time.
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0-
Comment on attachment 158509 [details] [diff] [review]
No locale change patch

There's really no reason for the dropdown menu -- IMO, searching should always
search url/name/description/shortcut.  Being able to select which one to look
for, esp. for a quick search dialog, seems like UI bloat.

Would gladly take a patch that just always searched all of them, though.
Attachment #158509 - Flags: review?(mconnor) → review-
> There's really no reason for the dropdown menu -- IMO, searching should always
> search url/name/description/shortcut.  Being able to select which one to look
> for, esp. for a quick search dialog, seems like UI bloat.though.

Everything in one toolbar is reasonable, 
because users can search bookmarks in the same maner
as they do with browser.
Vlad, do you think bug 171575 is still valid?

Comment 8

13 years ago
and if i find a bockmark, I look again so long in which folder it is.
Please help me for more comfort and more user-friendly.
thanks to for execution soon.
*** Bug 268667 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
and if i find a bockmark, I look again so long in which folder it is.
Please help me for more comfort and more user-friendly.
thanks to for execution soon.
OS: Linux → All
Hardware: PC → All
Version: unspecified → Trunk
(In reply to comment #8)
> and if i find a bockmark, I look again so long in which folder it is.
> Please help me for more comfort and more user-friendly.
> thanks to for execution soon.

bug 171575 (hopefully soon)

mod summary
Summary: Cannot search within the URL, only the name → Cannot search URL (location), only the name

Comment 12

12 years ago
*** Bug 303617 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Blocks: 265048, 282765
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Duplicate of this bug: 365240

Comment 15

11 years ago
The below was, duplicatively (sorry!), posted as bug 365240. I am reposting here because it shows an example of what a user wants to do. 
 - - - - - -
My bookmarks include the press releases page of various central banks. Eg.:
   http://www.federalreserve.gov/boarddocs/speeches/2006/
   http://www.bankofengland.co.uk/publications/news/2006/
As 2006 ends I want to replace in my large collection of bookmarks instances of "2006" with "2007". Please could the bookmarks manager acquire a menu item "Find in Bookmarks...  Ctrl+F" that allows searches for strings in the titles and the URLs? 
Julian,
There are several extensions to FF two of which I use that do exactly what you want:

https://addons.mozilla.org/firefox/3543/
Advanced Bookmark Search | Firefox Add-ons | Mozilla Corporation

https://addons.mozilla.org/firefox/494/
Enhanced Bookmark Search | Firefox Add-ons | Mozilla Corporation

Although there is a lot of overlap in functionality between the two I use them both to give me the most flexible bookmark searching.
Duplicate of this bug: 376692

Comment 18

11 years ago
Bug 376692?  A "Resolved Duplicate"??? Where is it resolved?

While I'm confused as to how this a duplicate of (this) bug 176400 based on my
description and the context of the bug report, I also can see why this
bug/issue has never been addressed and fixed.  If this is original bug, it's
much too vague for anyone to understand.

However, Julian D. A. Wiseman noted above two FF add-ons that may serve the
functionality I desire.  Seems someone else out there saw the necessity of this functionality and went ahead and developed the enhancement seeing the FF development team wasn't.

Also, Pierre Chanial is assigned this issue/bug.  Shouldn't he be on the CC list?

Thanks

Comment 19

11 years ago
(In reply to comment #18)
> Bug 376692?  A "Resolved Duplicate"??? Where is it resolved?

All dupes have "resolved" just for the sake of sorting bugs.

Also lately the focus is on Places that is going to replace Bookmark, so someone can submit a bug in the other category.

Comment 20

9 years ago
Works for me in Firefox 3.

Comment 21

9 years ago
(In reply to comment #20)
> Works for me in Firefox 3.

Likewise for me, in history and bookmark sidebars, urlbar, and library/organizer.

Marking WFM (and moving to Places component).

If I err, someone please correct me.

PS
> "Pierre Chanial is assigned this issue/bug.  Shouldn't he be on the CC
> list?"

Assignee's bugmail is automatic, I believe.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
Resolution: --- → WORKSFORME

Comment 22

9 years ago
I think the first comment - "enhanced find" - really covers what's needed here - unfortunately, it wasn't clear enough ;-)

The Firefox bookmark search functionality is lame at best.  In addition to Name and Location, bookmark information can be stored in keywords and description While tags can be searched, keywords and description are not.  Why?  Why even have them?

Also, one you find a bookmark, there's no way on Earth to know where in your bookmarks library the bookmark resides.

Hopefully the "Places" component functionality is more robust...
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.