rectangles around selected text

RESOLVED FIXED in mozilla1.9alpha1

Status

Core Graveyard
GFX: Win32
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Joseph Izso, Assigned: dougt)

Tracking

Trunk
mozilla1.9alpha1
Other
Windows CE

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Familiar 0.72; en-US; rv:1.7a) Gecko/20040218 Minimo/0.1

Before and after selection Minimo adds "rectangles" (special characters, perhaps?).
First rectangle is selected, second is after selection.

Because this adds two characters in text, paragraphs are reformatted with
selection changes.

Reproducible: Always

Steps to Reproduce:
1. Open web apge
2. Select some text on page
Actual Results:  
There should appear rectangles and text should move

Expected Results:  
Only select text without adding some special characters to selection.
(Assignee)

Updated

13 years ago
Blocks: 277211
(Reporter)

Comment 1

13 years ago
Created attachment 178945 [details]
screenshot of selected text with rectangles arround it
(Assignee)

Comment 2

12 years ago
*** Bug 316900 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

12 years ago
Created attachment 203554 [details] [diff] [review]
Patch v.1

This seams to work.

If only the if-statement would result in the same thing.  I find that every predicate evals to zero.
(Assignee)

Comment 4

12 years ago
Comment on attachment 203554 [details] [diff] [review]
Patch v.1

Could you advise on the above patch?
Attachment #203554 - Flags: review?(masayuki)
Comment on attachment 203554 [details] [diff] [review]
Patch v.1

I cannot accept this patch.
We should not use #ifdef on XP code(of course, we don't have another way, we should go).

Now, we don't know why |PaintAsciiText| doesn't work fine on WinCE yet.
We need to know truth.

Why is |text| broken on |PaintAsciiText|?
I think that |DrawString| breaks |text| on WinCE, right?

Isn't regression of bug 260663?
Attachment #203554 - Flags: review?(masayuki) → review-
Created attachment 203599 [details] [diff] [review]
proposal patch

I think that the |text| is broken by 

3400 rv = aRenderingContext.GetWidth(currenttext, currentlength,newWidth); //ADJUST FOR CHAR SPACING

I think that the WinCE's GetTextExtentPoint32 is set NULL to lpString[cbString].
> BOOL GetTextExtentPoint32( 
> HDC hdc, 
> LPCTSTR lpString, 
> int cbString, 
> LPSIZE lpSize
> );

Please check this patch. I cannot test this.
(Assignee)

Comment 7

12 years ago
Comment on attachment 203599 [details] [diff] [review]
proposal patch

works for me.  Thank you!
Attachment #203599 - Flags: review+
Ah, don't we need sr for this?
Assignee: dougt → masayuki
Created attachment 203607 [details] [diff] [review]
Added the comment
Attachment #203554 - Attachment is obsolete: true
Attachment #203599 - Attachment is obsolete: true
Attachment #203607 - Flags: review+
Status: NEW → ASSIGNED
Component: Minimo Front-End → GFX: Win32
Product: Minimo → Core
Target Milestone: --- → mozilla1.9alpha
Version: unspecified → Trunk
OS: other → Windows CE
Attachment #203607 - Flags: superreview?(dveditz)
(Assignee)

Comment 10

12 years ago
Comment on attachment 203607 [details] [diff] [review]
Added the comment

i might be able to hide this stuff inside windows ce shunt library (mozilla/build/wince/shunt)... In this way, we do not have to add more ifdefs into the gfx code.
Attachment #203607 - Flags: superreview?(dveditz) → superreview-
(Assignee)

Updated

12 years ago
Assignee: masayuki → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 11

12 years ago
found the problem in the shunt layer....

http://lxr.mozilla.org/mozilla/source/build/wince/shunt/win32A.cpp#649

I am removing this mistake.

Thanks for your help Masayuki!
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.