Search bar: cannot drop down list of search engines or access "Add engines..."

VERIFIED FIXED in Firefox1.5

Status

()

P1
normal
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: mano, Assigned: aaronlev)

Tracking

({access, sec508})

Trunk
Firefox1.5
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Apparently, there is no way to fire the "Add engines..." command (available from
the engines dropdown menu) using the keyboard.

For the reference, here's what we do for anything else in the search field:
  1. Switching between serach engines is available via Accel+Arrows
  2. "Clear search history" is an entery of the field context menu (AppKey /
Control+Space)
(Assignee)

Comment 1

14 years ago
Similar to bug 263853 for URL bar.

The F4 and Alt+down arrow keys should both work to drop down the list. Weird:
the down arrow drops down a different list -- of your recent searches, but you
can't drop that one down with the mouse.

So there are currently two drop downs, one only for the kbd (search history) and
one only for the mouse (engine type), and neither use the normal drop down
commands (F4 and Alt+down).
Keywords: sec508
Priority: -- → P1
Summary: Search bar's "Add engines..." command is inaccessible → Search bar: cannot drop down list of search enginers or access "Add engines..."
Assignee: p_ch → aaronleventhal
Component: Search → Keyboard Navigation
QA Contact: search → jruderman

Updated

14 years ago
Summary: Search bar: cannot drop down list of search enginers or access "Add engines..." → Search bar: cannot drop down list of search engines or access "Add engines..."
(Assignee)

Updated

14 years ago
Assignee: aaronleventhal → doronr
(Assignee)

Updated

14 years ago
Blocks: 291034
(Assignee)

Updated

14 years ago
No longer blocks: 291034
(Assignee)

Comment 2

14 years ago
We can fix F4/Alt+Down/Alt+Up for closing later. I know how to do it, but it
must be done in layout/xul/base/src menu code. similar to how it's done for XUL
menulist. That's not as high priority right now because just pressing Alt by
itself, or pressing tab or escape will close the menu. I think Escape is the
most common way in any case.
Assignee: doronr → aaronleventhal
Status: NEW → ASSIGNED
Attachment #190870 - Flags: review?
(Assignee)

Updated

14 years ago
Attachment #190870 - Flags: review? → review?(mconnor)
Attachment #190870 - Flags: review?(mconnor) → review+
(Assignee)

Updated

14 years ago
Attachment #190870 - Flags: approval1.8b4?

Updated

14 years ago
Attachment #190870 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Comment 3

14 years ago
Checking in browser/base/content/search.xml;
/cvsroot/mozilla/browser/base/content/search.xml,v  <--  search.xml
new revision: 1.25; previous revision: 1.24
done
Checking in browser/locales/en-US/chrome/browser/searchbar.properties;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/searchbar.properties,v 
<--  searchbar.properties
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 4

14 years ago
*** Bug 298810 has been marked as a duplicate of this bug. ***
> // XXX Why did mStringBundle say that formatStringFromName
> is not a method?

mStringBundle.getFormattedString() should work.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox1.1
(Assignee)

Comment 6

14 years ago
*** Bug 306777 has been marked as a duplicate of this bug. ***
*** Bug 311842 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.