[sr] Serbian: Firefox, Thunderbird

RESOLVED FIXED

Status

defect
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: veljko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

290.00 KB, application/octet-stream
Pike
: review+
Details
2/3
290.00 KB, application/octet-stream
Pike
: review+
Details
3/3
248.25 KB, application/octet-stream
Pike
: review+
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; tekaz)
Build Identifier: 

Hi, I would like to start localizing Firefox for serbian language.
sr_CS

My name is Veljko Stanojevic, member of serbian Gnome translation team.

Reproducible: Always

Comment 1

14 years ago
*** Bug 283457 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
Please file a second bug in mozilla.org product for getting an L10n CVS account
and mark it blocking this one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: serbian translation → Firefox: Serbian (sr-CS)
(Reporter)

Comment 3

14 years ago
L10n CVS account
Flags: certification-l10n+
clearing certificatioin-l10n flag as I don't see a sr-CS ffox 1.0.1 build yet.
Flags: certification-l10n+
Blocks: 283843
According to Sale (see bug 288497), Serbian languages in (Serbia) and (Bosnia)
are the same. Therefore, I would suggest to go only with one Serbian localization
using the short sr code for it.
OS: Linux → All
Hardware: PC → All
Summary: Firefox: Serbian (sr-CS) → Registration of Serbian (sr) Firefox localization
In bug 297125, Filip Malicevic <filip@lakinetwork.com> declared his interest in
 Serbian localization of Thunderbird. Since Firefox and Thunderbird have a
toolkit in common, I'm turning this bug into general Serbian localization bug.

Veljko or Sale, would you mind to provide us the status of Firefox localization.
Summary: Registration of Serbian (sr) Firefox localization → Registration of Serbian (sr) localization of Firefox and Thunderbird.
*** Bug 297125 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
We would love to see progress here soon, we gonna branch for 1.1 late next week,
and then getting into the tree for 1.1 will be harder.

Next things we need are sources of your localization attached to this or the 
CVS account bug for review.

Comment 9

14 years ago
I have been started working on 1.1. I hope that's ok.

Comment 10

14 years ago
I have been notified by mail, by Strahinja Kustudic, that he has almost finished
complete translation of Firefox.
I will see with him how to finish it and post files.

Comment 11

14 years ago
For the record, Thunderbird has been translated into Serbian recently, an XPI is
available, thus adding to the Firefox translation which has been available for
some time now. We will work towards an official Mozilla build.

More details are available at: http://www.nasepismo.net (in Serbian) and the
mailing list: razgovor@nasepismo.net (Also in Serbian, but English is also
acceptable)
For the record, Firefox has been translated into Serbian recently, an XPI is
available. I'll work towards an official Mozilla build.

More details are available at:
http://scar.gradac.net//index.php?modul=forum&id=preuzimanja&f=1 (in Serbian)

Here is direct links:
- Firefox 1.0.x:
http://scar.gradac.net//preuzimanja/1/2/firefox-1.0.sr-YU.langpack.xpi
(cyrillic & latin)
- Firefix 1.5.x: http://scar.gradac.net/preuzimanja/1/3/srCS-ff_1.5.xpi
(presently only cyrillic version)

It's not finished yet (97% done).

Comment 13

13 years ago
How about registering a sr-CS localization team? I sent mails to Veljko and Nikola, and here's a reminder for the rest of the gang. AFAIK, the Firefox translation is ready, while Thunderbird needs an update to 1.5.

Comment 14

13 years ago
I would like to lift the official Serbian l10n for Firefox and Thunderbird off the ground. Following advice from BUG 297125, I contacted the OPs for this bug (Veljko and Sale) asking them how to proceed.

However, I got no reply from either of them. They may be busy, their emails might have changed, they might have moved or whatnot. While there is a ton of legitimate reasons for not replying, I still feel we've a showstopper here and I urge for this to change.

Therefore:

May I ask that the Serbian L10N be re-assigned to someone who actually replies to emails?! 

I can nominate myself, and you would be rather safe to accept the nomination, given that I have prepared a community translation of Thunderbird and thus have a personal reason to push the thing all the way.

Feedback appreciated,
f

Comment 15

13 years ago
Hi, I am sorry for not responding. Currently I am busy at school, so I do not have much time. I can help sometimes, but I suggest you not to count on me as a main person.


Suggestion:
I think that we should have better communication between members, and I think that we need manager who would give to other members small tasks, to awoid that everyone tries to translate from scratch. 

If we do that way then you can count on me, because in free time I could do few tasks.
There's another l10n request for Serbian in bug 328304 from Nikola Milinkovic. 

Comment 17

13 years ago
Bug 302295 is also about a Serbian Firefox translation, filed by Emil Beli.

Comment 18

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; tekaz)
> Build Identifier: 
> 
> Hi, I would like to start localizing Firefox for serbian language.
> sr_CS
> 
> My name is Veljko Stanojevic, member of serbian Gnome translation team.
> 
> Reproducible: Always

I support this!
St0rMs Org.
Bela Crkva

Comment 19

13 years ago
*** Bug 328304 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
How about we lift this issue off the ground?

May I apply for a l10n CVS account, please?

Thanks,
f

Comment 21

13 years ago
(In reply to comment #20)
> May I apply for a l10n CVS account, please?

Ok, I learned that things work differently: I should complete the l10n and attach it here, rather than tinker the CVS. 

Seems reasonable. Thus please ignore my previous request.

10xf

Comment 22

13 years ago
Greets all. 

For those who are interested, we started tinkering with the l10n for 2.0.0 etc at
http://cowfarm.no-ip.org:9000/mozilla
Након скоро два месеца, најбурнијијх у мом животу, нашао сам времена да прилагодим свој стари превод новом Mozilla Firefox 2.0-у!

Превод је прилично сређенији и прочишћенији од претходног, мада као ни сваки други превод није савршен.

Програм је преведен 100%, са свим порукама о грешкама, саветима, итд., а делимично је преведен и Систем помоћи (Help)!

Сваки коментар је добро дошао.

Превод можете пронаћи на:
http://scar.gradac.net/index.php?modul=forum&id=preuzimanja&f=1&t=4

Хвала на интересовању и подршци!
Nikola, could you post your last comment in English?

Comment 25

12 years ago
I have used Nikola`s translation and with some modifications adopted it for both Serbian Cyrillic and Serbian Latin translation of Firefox for GNU/Linux and MS Windows. Also, I have created Serbian localized Firefox builds for GNU/Linux (you can get it at http://nvo.linuxo.org/node/47 )
Please report any bugs you found. Thanks Nikola :) 

After almost two mounts, the most stressed in my life,
I've found some time to upgrade my old translation
with new Mozilla Firefox 2.0!

Translation is much better then previous,
yet it is not perfect. :)

Translation is 100% done, with partly Help done!

Any comment is welcome.

Translation .xpi files you can download from:
http://scar.gradac.net/index.php?modul=forum&id=preuzimanja&f=1&t=4

Thanks for interests and support!

Comment 27

12 years ago
Hello all.

In the following few messages I submit the first, tentative, Serbian locale for Mozilla.  

Following the agreement, the locale is named 'sr'.  This thread gives more info why this is so, with Axel Hecht agreeing on the locale name:
http://groups.google.com/group/mozilla.dev.l10n/browse_thread/thread/357fdc475b8711cb/76994254316df818?lnk=st&q=filip+miletic+axel+hecht&rnum=1#76994254316df818

I submit an archive named sr.zip, split into 3 parts which are produced by the unix 'split' utility.  To assemble, attach files one to another in the lexicographical order of their respective file names. 

The locale is a product of a fairly distributed effort.  The Firefox translation is based on the excellent work done by Nikola Radovanovic, which is reused with permission.  The Thunderbird translation was done by Ljubisa Radovanovic and me.  

I compiled all the translations into the form suitable for inclusion as a Mozilla locale.

Most of the messages are translated and of those, most should be translated well.  I submit this partly to get the feedback from Mozilla and understand what improvements need to be made.

Comment 28

12 years ago
Attachment #252544 - Flags: review?

Comment 29

12 years ago
Posted file 2/3
Attachment #252545 - Flags: review?(l10n)

Updated

12 years ago
Attachment #252544 - Flags: review? → review?(l10n)

Comment 30

12 years ago
Posted file 3/3
Attachment #252546 - Flags: review?(l10n)

Updated

12 years ago
Duplicate of this bug: 302295

Updated

12 years ago
Attachment #252544 - Flags: review?(l10n) → review+

Updated

12 years ago
Attachment #252545 - Flags: review?(l10n) → review+
Comment on attachment 252546 [details]
3/3

Ok, this looks ready to get started.

Review nits:

You won't need the en-US search plugin xml files, just list.txt.

Please localize bookmarks.html, by translating the link titles, and replacing the en-US twice in each URL with sr.

Taking.

Would you please add information about your team to http://wiki.mozilla.org/L10n:Teams:sr, similar to what I did at http://wiki.mozilla.org/L10n:Teams:de?

Thanks
Attachment #252546 - Flags: review?(l10n) → review+

Updated

12 years ago
Blocks: 370623
Filed a cvs account bug for filmil. Btw, the review for Thunderbird is apparently not very in-depth, we'll decide to take Serbian there after 2.0, we're too late in the game for 2.0 right now.

Comment 34

12 years ago
(In reply to comment #32)
> Would you please add information about your team to
> http://wiki.mozilla.org/L10n:Teams:sr, similar to what I did at

Info added.
Filip, I filed bug 377412 to get a bugzilla component for the Serbian localization, I'll file a landing bug once that component is up. If you need assistance with landing, just poke in #l10n. If not, be sure to land on the trunk only so far.
Summary: Registration of Serbian (sr) localization of Firefox and Thunderbird. → [sr] Serbian: Firefox, Thunderbird

Updated

12 years ago
Status: NEW → ASSIGNED
Landing is bug 377456, this is FIXED.

Any update on getting your peers and co-owners listed on the wiki? That'd help a great deal.

http://l10n.mozilla.org/buildbot/linux-incubator/builds/33/step-moz%3Acomparelocales/0 mentions one last remaining missing file, woot, extensions/reporter/chrome/reporterOverlay.properties. And you can remove the obsolete entries from other-licenses/branding/firefox/brand.properties
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 37

12 years ago
Yes, I'm on it as we type.

Updated

12 years ago
Duplicate of this bug: 305892

Updated

12 years ago
Duplicate of this bug: 374034
You need to log in before you can comment on or make changes to this bug.