Firefox hangs up with page with 2 FLASH Movies

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Dennis Devine, Assigned: Blake Ross)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Tested page on Windows and with IE and Safari, but Firefox hangs up
when attempting to render page with 2 FLASH MOVIES.

Reproducible: Always

Steps to Reproduce:
1. Go to view HTML page http://www.thesingingwater.com
2. Firefox hangs while rendering page (OK with Safari)
3.

Actual Results:  
continuous rainbow wheel spins

Expected Results:  
page should load correctly, effects with both Flash Movies should work,
and user should be able to click side links.

Tested page on Windows IE, Windows Firefox and Mac Safari and works fine.
Other examples of 2 Flash movies found on other sites. 
Problem specific to Mac Firefox version.
which Flash Version Do you have installed ?
Use "about:plugins" to see the installed Version (use it as URL)
Severity: normal → critical
Keywords: hang

Comment 2

13 years ago
This is also occuring in Mozilla Suite 1.8b2 build 2005030510.  

flash player/plugin    shockwave flash 7.0.24.0

A couple of other sites that cause the hangup
http://www.emusic.com/promo.html
http://worldometers.info/

If mouse button is held down (can be in the finder or another application as
well as in the browser window) the graphic spins.

Comment 3

13 years ago
*** Bug 285057 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
Based on bug 285057 this seems to be a aviary branch issue...

Comment 5

13 years ago
*** Bug 287119 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
Three dups... think its time to confirm the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

13 years ago
(In reply to comment #6)
> Three dups... think its time to confirm the bug.

Happens with me too.  Let me know if I can be of any assistance.  The browser
can handle 2 small flash movies, but as the # grows, the more cpu it requires. 
It works fine on windows and safari and ie on mac.

Comment 8

13 years ago
Happens for me too on lots of different sites. Since flash is commonly used in
advertisements and since flash gaming sites typically have advertisements, this
happens a lot.

Comment 9

13 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050414
Firefox/1.0+
Shockwave Flash 7.0 r19

Seems like a bug in the Mac version of the Flash plugin

Comment 10

13 years ago
For me, Firefox hangs about a dozen times a day due to this bug. Any time there
are multiple instances of the flash plugin running, firefox will hang. If you
use tabbed browsing and visit sites with advertising, you are going to encounter
this bug a bunch. Can anyone confirm this yet?

Comment 11

13 years ago
Jake,

What version are you using at the momment... Personally I got feed up with the
bug, well flash in general (since maybe I might visit 2 sites a month actaully
need flash), so I just  Flashblock.

I'm also using Deer Park now... and I haven't noticed it with 1.0.4 after I
installed Flashblock so I can't say if it exist in Deer Park.

Comment 12

13 years ago
haven't had a crash for quite awhile now.  I have Jave disabled but everything
else is running.  using FF 1.0.4

Comment 13

13 years ago
I am running 1.0.4 as well, but I get this crash constantly. I can tell when its
about to happen because firefox becomes very unresponsive. If I quickly close
the tab contain a flash object, firefox will return to normal, otherwise I will
get the spinning beachball forever and need to force quit.

I also reinstalled the latest flash plugin, but that didnt fix it.

Updated

13 years ago
Blocks: 300398

Comment 14

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006
(No IDN) Firefox/1.4.1

http://www.thesingingwater.com/
what happens to me on this website is that firefox takes 65% of my 1.5ghz G4 cpu.
if more flash things are open, it freezes.

I noticed that if I open the website in a tab and don't show it, it just takes
around 7%. If the tab is shown, then it's 65%.

Comment 15

13 years ago
*** Bug 285767 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
*** Bug 303832 has been marked as a duplicate of this bug. ***

Comment 17

13 years ago
> Steps to Reproduce:
> 1. Go to view HTML page http://www.thesingingwater.com
> 2. Firefox hangs while rendering page (OK with Safari)

I can reproduce this, also with the the other sites mentioned in #2.
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

libflashplayer.so  Shockwave Flash 7.0 r25

The "funny" thing is that even Opera(Mozilla/4.0 (compatible; MSIE 6.0; X11;
Linux i686; en) Opera 8.02) reproducable freezes too. I also have these freezes
in Thunderbird, but I have no idea if these things are connected with each other.
I will willingly provide more information on request.


Comment 18

13 years ago
> The "funny" thing is that even Opera(Mozilla/4.0 (compatible; MSIE 6.0; X11;
> Linux i686; en) Opera 8.02) reproducable freezes too. 

After deleteing the one and only file 'libflashplayer.so' and one file called
something like 'flash*.xmd' (can't remember exactly) file in
/usr/lib/opera/plugins, opera can open these critical pages. But i think this is
an expected behavior. Even if there is no 'libflashplayer.so' left on my HD,
firefox still crashes. 

Comment 19

13 years ago
If some of you previous commenters have a chance -- 

Kindly try this link:

http://www.museum.tv/home.php

We're trying to figure out if this is Camino-only, or a Mac-only, Flash-related or even a core products bug.  Hope you get the picture...

Comment 20

13 years ago
(In reply to comment #19)
> If some of you previous commenters have a chance -- 
> Kindly try this link:
> http://www.museum.tv/home.php

Freeze, *low* cpu-usage.

Kernel: 2.6.13-1.1532_FC4
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

about:plugins (shorted)
MIME-Typ 	Beschreibung 	Endungen 	Aktiviert
* 	All types 	.* 	Nein
Shockwave Flash

    Dateiname: libflashplayer.so
    Shockwave Flash 7.0 r25

MIME-Typ 	Beschreibung 	Endungen 	Aktiviert
application/x-shockwave-flash 	Shockwave Flash 	swf 	Ja
application/futuresplash 	FutureSplash Player 	spl 	Ja

Comment 21

13 years ago
(In reply to comment #20)

Sorry I forgot to mention two things:

1. There is no libflashplayer.so in my file system.
   ls /usr/lib/firefox-1.0.7/plugins/
   libjavaplugin_oji.so  libnullplugin.so


2. If more information is needed, i will provide them..!

Greetings Jan

Comment 22

13 years ago
My test case is (FF 1.0.7, OS 10.4.2, 1Ghz PBook):

http://homestarrunner.com/main23.html

After it loads, run your cursor down the right hand navigation ovals. Eventually it will start spinning and hang for 10s+. Does not happen in Safari or Firefox 1.0.7 on Win32.

m.

Comment 23

13 years ago
(In reply to comment #22)
> My test case is (FF 1.0.7, OS 10.4.2, 1Ghz PBook):
> http://homestarrunner.com/main23.html
> After it loads, run your cursor down the right hand navigation ovals.
> Eventually it will start spinning and hang for 10s+. Does not happen in Safari
> or Firefox 1.0.7 on Win32.

My problems are solved! I keep my system (FC) up2date via yum and some major repositories. At this point of time I can't say which components changed here, but all sites mentioned above, are now displayed without a freeze!
Thanks for your quick help!

Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7 

Comment 24

13 years ago
(In reply to comment #22)
> My test case is (FF 1.0.7, OS 10.4.2, 1Ghz PBook):
> 
> http://homestarrunner.com/main23.html
> 
> After it loads, run your cursor down the right hand navigation ovals.
> Eventually it will start spinning and hang for 10s+. Does not happen in Safari
> or Firefox 1.0.7 on Win32.

With FF 1.5beta2 I don't see any freezing or "beachballs" on OS X. Performance is very sluggish but this might be expected.

m.

Comment 25

13 years ago
In 1.5b2 on OS X I was not able to make Firefox hang using this method :)  I then went back to version 1.0.6 and it hung in about 5 seconds, so it seems the problem has been addressed, at least for my setup.

Comment 26

13 years ago
(In reply to comment #23)
Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

I was too pertly. I sometimes have this freezes again, but I found a solution that works for me. I have no idea if the problem under Mac OS can be related to this, I hardly can imagine. 
Whenever firefox freezes, a "killall esd", stop the freeze and the page continues loading. Flash Afterwards flash content works properly...

Comment 27

12 years ago
Is this related to Firefox hanging when long videos on http://video.google.com are played? Firefox practically grinds to a halt.

Comment 28

12 years ago
* apologies I didn't clarify: this is on Windows XP and happens with either Flash Player 7 or 8 installed.

Comment 29

12 years ago
This has not been a problem since v1.5 and I am unable to reproduce it in 2.0RC1 using my original methods. Marking as fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 30

12 years ago
Switching to worksforme since we dont know what patch fixed this.  Sorry for the mixup.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.