Last Comment Bug 285374 - sync xpfe colorpicker.xml with toolkit colorpicker.xml
: sync xpfe colorpicker.xml with toolkit colorpicker.xml
Status: VERIFIED FIXED
:
Product: Toolkit
Classification: Components
Component: XUL Widgets (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla13
Assigned To: Serge Gautherie (:sgautherie)
:
:
Mentors:
http://mxr.mozilla.org/mozilla/find?s...
Depends on: 156459 274712 292668 354065
Blocks: 282177
  Show dependency treegraph
 
Reported: 2005-03-08 17:29 PST by Serge Gautherie (:sgautherie)
Modified: 2012-02-20 17:31 PST (History)
7 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
(Av1) Set background color as a property, not as an attribute [Checked in: Comment 4] (1.01 KB, patch)
2012-02-15 22:32 PST, Serge Gautherie (:sgautherie)
neil: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2005-03-08 17:29:04 PST
Quoted from bug 282177 comments:
{{
 ------- Additional Comment #3 From Chris Thomas (CTho)  2005-03-08 06:59 PST 
[reply] -------

Somebody unsync'ed colorpicker.xml


------- Additional Comment #4 From Gavin Sharp 2005-03-08 07:40 PST [reply] -------

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=colorpicker.xml&filetype=match&date=explicit&mindate=2005-02-25+01%3A07&maxdate=2005-02-25+01%3A07&cvsroot=%2Fcvsroot
}}
Comment 1 Robert Kaiser 2007-06-10 14:42:26 PDT
SeaMonkey is using toolkit now, is there still anything we need to port from xpfe colorpicker.xml to toolkit or can we close this bug?
Comment 3 Serge Gautherie (:sgautherie) 2012-02-15 22:32:53 PST
Created attachment 597693 [details] [diff] [review]
(Av1) Set background color as a property, not as an attribute
[Checked in: Comment 4]

Per comment 2.
(Untested.)

This comes from bug 292668.

http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/content/widgets/colorpicker.xml#443
{
443       <property name="color">
...
448           this.mColorBox.setAttribute("style", "background-color: " + val);
...
454       <method name="initialize">
...
457           this.mColorBox.style.backgroundColor = this.color;
}
Comment 4 Serge Gautherie (:sgautherie) 2012-02-16 17:53:23 PST
Comment on attachment 597693 [details] [diff] [review]
(Av1) Set background color as a property, not as an attribute
[Checked in: Comment 4]

https://hg.mozilla.org/mozilla-central/rev/7e1855af184c


Succeeded as
https://tbpl.mozilla.org/?tree=Try&rev=920bb07ca312
Comment 5 Philip Chee 2012-02-16 19:49:40 PST
Thanks Serge!
Comment 6 Serge Gautherie (:sgautherie) 2012-02-20 17:23:45 PST
Comment on attachment 597693 [details] [diff] [review]
(Av1) Set background color as a property, not as an attribute
[Checked in: Comment 4]

Ftr, this had already been done by
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/toolkit/content/widgets/colorpicker.xml&rev=HEAD&mark=1.17

It looks like it was missed somehow during the cvs->Hg transition :-/
(Note that this is odd, as r1.17 is tagged with HG_REPO_INITIAL_IMPORT.)
Comment 7 Serge Gautherie (:sgautherie) 2012-02-20 17:31:56 PST
(In reply to Philip Chee from comment #2)
> As far as I can see only one line left to port:

I confirm, after digging into cvs and hg histories for these 2 files.

V.Fixed

Note You need to log in before you can comment on or make changes to this bug.