Last Comment Bug 286483 - Thunderbird OS X builds missing prompt alert icon
: Thunderbird OS X builds missing prompt alert icon
Status: RESOLVED FIXED
: fixed1.8
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: PowerPC Mac OS X
: P2 normal (vote)
: Thunderbird1.1
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
:
:
Mentors:
: 311429 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 14:53 PST by Scott MacGregor
Modified: 2005-10-17 14:21 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Alert sheet with blank space for icon (18.34 KB, image/png)
2005-08-25 12:54 PDT, Kevin Gerich
no flags Details
icon64.png (10.66 KB, image/png)
2005-10-08 05:37 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
no flags Details
patch (2.00 KB, patch)
2005-10-08 05:47 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
mscott: review+
mscott: approval1.8rc1+
Details | Diff | Splinter Review
fix generic-branding builds (972 bytes, patch)
2005-10-11 03:49 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
benjamin: review+
mscott: superreview+
asa: approval1.8rc1+
Details | Diff | Splinter Review
*do'h* (492 bytes, patch)
2005-10-17 13:39 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
benjamin: review+
mscott: superreview+
mscott: approval1.8rc1+
Details | Diff | Splinter Review

Description Scott MacGregor 2005-03-16 14:53:20 PST
I just noticed the password prompt for the Mac builds doesn't show the blue
globe icon that it used to for all question based prompts. 

I tracked this down to a change to mozilla\toolkit\global.css by bsmedberg as
part of the branding changes for Bug #282057. 

It changed the alert prompts to use an icon located at:

"chrome://branding/content/icon64.png"

But I see no such file called icon64.png in mozilla\toolkit\themes for it to use.
Comment 1 Benjamin Smedberg [:bsmedberg] 2005-03-16 15:25:35 PST
mscott, I thought that icon was application specific (that icon was the "not
official branding" version of the Firefox logo. Do you want the same blue globe
for tbird, or another icon? Should it be affected by the
--enable-official-branding flag like it is for Firefox?
Comment 2 Scott MacGregor 2005-03-16 15:33:37 PST
ah I see what's going on. Does this mean that official firefox builds would get
a globe with a fox instead of the generic blue globe in these dialogs? Or is it
always the generic blue globe?

I guess I'm happy with the behavior we had before, which would be using the
generic blue globe for both regular and official builds since the fox wouldn't
make sense for an official thunderbird build.

cc'ing Kevin in case he wants to have a special thunderbird image in these alert
prompts that would have a generic and an an official form.
Comment 3 Benjamin Smedberg [:bsmedberg] 2005-03-16 15:38:55 PST
I'll add the generic globe so it's not blank, and Kevin can add a branded
version later.
Comment 4 Benjamin Smedberg [:bsmedberg] 2005-04-06 15:40:23 PDT
The generic globe is fixed, but this should really have an app-specific icon
like Firefox does.
Comment 5 Kevin Gerich 2005-08-25 12:54:40 PDT
Created attachment 193841 [details]
Alert sheet with blank space for icon

I just built on the 1.8 branch (without the official branding flag) and I get
alert sheets without the icon. I get a message "No chrome package registered
for chrome://branding/content/icon64.png". Is my build not flaky or is this
still a problem?
Comment 6 Scott MacGregor 2005-08-25 15:41:46 PDT
I see that too with official branding disabled actually.

With official branding, I get a blue globe.
Comment 7 Scott MacGregor 2005-08-25 17:33:21 PDT
Benjamin, is this ifef correct:

http://lxr.mozilla.org/seamonkey/source/mail/base/jar.mn#47

I think this should be #ifdef MOZ_USE_GENERIC_BRANDING

although that wouldn't explain why icon64.png isn't showing up in generic builds
since it is outside of the ifdef.
Comment 8 Scott MacGregor 2005-08-26 11:26:31 PDT
Well I think the ifndef should be an ifdef so I'm gonna correct it and Benjamin
can tell me if I'm doing something wrong :)

Fixed branch and trunk
Comment 9 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-06 16:56:28 PDT
*** Bug 311429 has been marked as a duplicate of this bug. ***
Comment 10 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-06 16:57:57 PDT
Taking...
Comment 11 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-08 05:37:56 PDT
Created attachment 198920 [details]
icon64.png

goes to /mozilla/other-licenses/branding/thunderbird/content
Comment 12 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-08 05:47:44 PDT
Created attachment 198921 [details] [diff] [review]
patch
Comment 13 Scott MacGregor 2005-10-10 09:58:52 PDT
Comment on attachment 198921 [details] [diff] [review]
patch

thanks Asaf. Go ahead and check this into the branch and trunk.
Comment 14 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-10 11:10:28 PDT
Trunk:

Checking in other-licenses/branding/thunderbird/content/jar.mn;
/cvsroot/mozilla/other-licenses/branding/thunderbird/content/jar.mn,v  <--  jar.mn
new revision: 1.6; previous revision: 1.5
done
Checking in mail/base/jar.mn;
/cvsroot/mozilla/mail/base/jar.mn,v  <--  jar.mn
new revision: 1.87; previous revision: 1.86
done
Checking in icon64.png;
/cvsroot/mozilla/other-licenses/branding/thunderbird/content/icon64.png,v  <-- 
icon64.png
initial revision: 1.1
done
Comment 15 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-10 11:21:17 PDT
1.8 branch:
Checking in other-licenses/branding/thunderbird/content/jar.mn;
/cvsroot/mozilla/other-licenses/branding/thunderbird/content/jar.mn,v  <--  jar.mn
new revision: 1.5.2.1; previous revision: 1.5
done
Checking in mail/base/jar.mn;
/cvsroot/mozilla/mail/base/jar.mn,v  <--  jar.mn
new revision: 1.84.2.3; previous revision: 1.84.2.2
done
Comment 16 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-11 03:44:58 PDT
(In reply to comment #7)
> Benjamin, is this ifef correct:
> 
> http://lxr.mozilla.org/seamonkey/source/mail/base/jar.mn#47
> 
> I think this should be #ifdef MOZ_USE_GENERIC_BRANDING
> 
> although that wouldn't explain why icon64.png isn't showing up in generic builds
> since it is outside of the ifdef.

Right. and for that reason, i managed to break the icon in *non*-official
builds, Benjamin?

(Note the about window seem to be already broken there...)
Comment 17 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-11 03:49:54 PDT
Created attachment 199155 [details] [diff] [review]
fix generic-branding builds
Comment 18 Scott MacGregor 2005-10-11 09:03:18 PDT
Comment on attachment 199155 [details] [diff] [review]
fix generic-branding builds

did you intend to remove the xpcnativewrappers part of the content branding
line?
Comment 19 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-11 10:39:36 PDT
Yeah, it's now turned on by default.
Comment 20 Benjamin Smedberg [:bsmedberg] 2005-10-11 17:12:03 PDT
Comment on attachment 199155 [details] [diff] [review]
fix generic-branding builds

please keep the xpcnativewrappers ;-)
Comment 21 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-15 04:17:23 PDT
Checking in jar.mn;
/cvsroot/mozilla/mail/base/jar.mn,v  <--  jar.mn
new revision: 1.89; previous revision: 1.88
done
Comment 22 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-15 11:32:44 PDT
1.8 branch:
Checking in mail/base/jar.mn;
/cvsroot/mozilla/mail/base/jar.mn,v  <--  jar.mn
new revision: 1.84.2.5; previous revision: 1.84.2.3
done
Comment 23 Scott MacGregor 2005-10-17 08:56:28 PDT
The 10/17 build today is has the generic icon in the mail start page instead of
the offical artwork. This looks like the only recent change that could have
broken that.

(Windows)
Comment 24 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-17 09:35:53 PDT
*weird*. Which icon (filename) is used in the start page? is it broken in other
places (read: about dialog)?
Comment 25 Scott MacGregor 2005-10-17 09:37:44 PDT
(In reply to comment #24)
> *weird*. Which icon (filename) is used in the start page? is it broken in other
> places (read: about dialog)?

thunderbird-watermark.png

Rest of the branding looks ok. I believe I had this same problem when I tried to
fix this generic branding flag a couple months ago. I'll see if I can find the bug.
Comment 26 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-17 13:39:11 PDT
Created attachment 199842 [details] [diff] [review]
*do'h*

though, i'm not sure why it didn't happen for the rest of the branding package.
Comment 27 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-10-17 14:21:08 PDT
1.8 branch:
Checking in Makefile.in;
/cvsroot/mozilla/mail/base/Makefile.in,v  <--  Makefile.in
new revision: 1.9.2.1; previous revision: 1.9
done

trunk:
Checking in Makefile.in;
/cvsroot/mozilla/mail/base/Makefile.in,v  <--  Makefile.in
new revision: 1.10; previous revision: 1.9
done

Note You need to log in before you can comment on or make changes to this bug.