Installing / updating a theme creates a copy of the jar in the chrome directory

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050316 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050316 Firefox/1.0+

When installing a theme for the first time or updating an existing theme a copy
of the theme's jar file is placed in the profile's chrome directory. When there
is already a file with the same name located there a -# is appended to the file
name (e.g. theme-2.jar) which will then cause updates to themes to create a
second jar file in the theme's chrome directory instead of replacing the
existing jar file. This is a spin off of bug 251026.

Reproducible: Always

Steps to Reproduce:
1. install or update a theme
Actual Results:  
There is a copy of the jar file for the theme in the profile's chrome directory.

Expected Results:  
No extra jar files hanging around

Comment 1

14 years ago
Just like Bug 271220 ?
(In reply to comment #1)
> Just like Bug 271220 ?
Actually no, that bug describes a problem that existed with the EM code prior to
the recent EM landing where upgrading a theme would leave multiple theme jar
files in the theme's chrome directory and I am pretty sure that bug 271220 is
fixed by the EM landing. What this describes is the theme's jar file being
copied into the profile's chrome directory.
Posted patch simple patch (obsolete) — Splinter Review
Dan - This is a simple one liner. This patch moves the closing of the zip
reader to before the zip file is deleted. This is located in #ifdef MOZ_XUL_APP
so it should not affect seamonkey.

requesting rs
Assignee: bugs → moz_bugzilla
Status: NEW → ASSIGNED
Attachment #182070 - Flags: review?(dveditz)
Nominating due to this being a simple fix and without this patch there are
issues with the new chrome.manifest files since this bug causes the jar filename
to change.
Flags: blocking-aviary1.1?
Comment on attachment 182070 [details] [diff] [review]
simple patch

I found a second issue that looks like it will require a modification to this
same code so I am clearing review. I should be done within the next day with an
updated patch
Attachment #182070 - Attachment is obsolete: true
Attachment #182070 - Flags: review?(dveditz)
Posted patch patch (obsolete) — Splinter Review
This patch moves the closing of the zip reader to before the zip file is
deleted and adds a param to nsIExtensionManager::installItemFromFile that bug
292506 will need. This change is located in an #ifdef MOZ_XUL_APP so it should
not affect seamonkey. This would need to be landed with the patch from bug
292506.
Attachment #182312 - Flags: review?(dveditz)
Attachment #182312 - Attachment is obsolete: true
Attachment #182312 - Flags: review?(dveditz)

Updated

14 years ago
Attachment #182813 - Flags: review?(benjamin)
Attachment #182813 - Flags: review+
Attachment #182813 - Flags: approval-aviary1.1a?

Updated

14 years ago
QA Contact: bugs → benjamin

Comment 8

14 years ago
Comment on attachment 182813 [details] [diff] [review]
patch

a=asa
Attachment #182813 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
checked in - thanks timelyx - resolved fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Flags: blocking-aviary1.1?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.