Closed Bug 286664 Opened 16 years ago Closed 2 years ago

Investigate Moving Account Settings into the Options (Preferences) Dialog

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1096006

People

(Reporter: mscott, Unassigned)

References

Details

Attachments

(5 files)

Explore re-writing the account manager dialog to look like another panel in the
options dialog. 

This would be a lot of work and may not be something we end up doing but I want
to at least look at it a little bit.
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird1.1
Attached image screen shot
I made this using smoke and mirrors just to demonstrate the concept (although
the account tree is actually live)
Some ideas to reorganize some options of the account manager:

Make it sense to konfigure the "outgoing server (smtp)" for every identity or
isn't it better to put this option to the "server settings" ?

The options "emtpy trash on exit" and "local directory" should be placed in
another tab, because they have nothing to do with the "server settings" (pop3).
Instead of these two options we can put the "disk space" option "to save disk
space, do not download: messages larger than xx" at that place.

Maybe we should make another tab called "identities" where you can configure the
default and the other identities and put the two options to the "general" tab.
I think it would make sense to separate "identities" further from "accounts" -- 
each mail account and newsgroup would have a default identity, but the identity-
specific settings should not be shown as option pages for the account.  You 
don't fetch messages for an identity, you fetch for an account (or newsgroup); 
you *send* mail from an identity.

As an alternate to integrating the two dialogs, the Account Settings dialog 
could be designed like the new Options dialogs, with top-level items for Mail, 
News, RSS, SMTP, Identities
Attached image another idea
Not nearly as nice obviously, but this approach would actually be do-able in
the 1.1 time frame as opposed to the first approach.

Instead of re-writing the account manager logic, we just embed it as it is
inside of the options dialog. If we make the dialog a little wider, this
solution is available with very little effort. 

Of course it is aesthetically not as nice as the original idea.
The 1st approach is definately the one to go for IMO - it fits in much better
with the way the options panel is designed. The payoff is worth the extended
timeframe.
Attached image updated screen shot
Current snapshot of what I've got so far. The misc panel is still under major
consstruction, I just put it there to get some of these things out of the way.

If only it worked as good as it looked :(

Gonna be another week or more before the account manager re-write portion is
complete.
I don't know, what to think about the account integration into the options dialog.

In the past it was confusing, where to find some options. But general options
were in the options dialog and account related options were in the account
manager - after using Tb for some time, everyone could know this. How will it be
in future. First time users will still ask: why there are some options here and
there. Theses options will only be in different topics/panels instead of
different dialogs. Okay we don't have to close one dialog, to open the other
one. That's an improvement.

The misc panel is only to get some things out of the way. Don't make the fault,
to produce new separated dialogs. The new UI was intended to have ONE dialog and
not some new different windows/dialogs.

I'd like to see the accounts on the left side and tabs instead of the old
tree-panels > but don't change the structure of the old tree.
I like the new dialog very much. Let me propose a modified version of this 
dialog, which unifies account management and identity management. Please have 
a look at the attached screen shot and the following explanations:

The list box on the left side contains identities as well as accounts.
The tabs on the right side are almost the same for both identities and 
accounts.
The separate dialogs for managing identities and for editing identities are 
not needed any more.

This way identity management becomes very intuitive and needs far less mouse 
clicks:

To create a new identity, just select the appropriate account and click „Add 
Identity“.
To delete an identity, just select the identity and click „Delete“.
To edit an identity, just select the identity and do your changes in the tabs 
on the right side.
Attached image Mockup screen shot
That UI reinforces the unnecessary and distracting model of "identities 
contained by accounts."  Identities can and should be separate, standalone 
entities.  In particular, there should be support for "shared identities" so 
that, for instance, I can have one identity for newsreading and use it for 
multiple news accounts.
not for 1.1
Target Milestone: Thunderbird1.1 → Thunderbird1.5
Flags: blocking-aviary2?
Flags: blocking-firefox2? → blocking-thunderbird2?
Flags: blocking-thunderbird2? → blocking-thunderbird2-
Target Milestone: Thunderbird1.5 → Thunderbird2.0
Target Milestone: Thunderbird2.0 → Thunderbird 3
OS: Windows XP → All
Hardware: PC → All
QA Contact: preferences
Flags: wanted-thunderbird3?
Scott are you still working on that or we should clear assign?
I don't think we're going to be able to do this for 3.0, but cc'ing Bryan. Also, assigning to nobody@mozilla.org
Assignee: mscott → nobody
Status: ASSIGNED → NEW
Flags: wanted-thunderbird3? → wanted-thunderbird3-
Is this feature still being considered?

I think it is a good idea.

An add-on for Thunderbird 3.0 moves account settings from Tools menu to options dialog.

https://addons.mozilla.org/en-US/thunderbird/addon/54144

Quote the author:
"Like in many applications these days, the Tools menu is a misnomer: it often contains essential and not just auxiliary functionality. Thunderbird is particularly hopeless in this respect, as it not only has the general Preferences dialog hidden in this menu, but also the separate Account settings and Add-ons dialogs.

Firstly the Preferences dialog isn't a "tool" and should therefore not appear in this menu. Secondly, other dialogs that modify the application's settings should really be part of the general 'Preferences' dialog. That way they will also be available under the common shortcut for invoking the Preferences dialog."

What about implementing this feature directly in Thunderbird in a next version?
Duplicate of this bug: 703556
I think the UI people would still like this being done.

I am not yet decided even though the screenshots here are nicer than I imagined it :)
But as I am hacking in the account manager and see some of its shortcomings that I am slowly polishing, I am not fond of breaking it again while moving it under Preferences. It would depend how hard it would be to migrate, how much of the existing infrastructure can be preserved.
Severity: normal → enhancement
Target Milestone: Thunderbird 3 → ---
On the other hand, maybe a first step could be to put a button in Prefs/General pane (the same way as "Manage addons" is) that would open the Account manager.
Summary: Investigate Moving Account Settings into the Options Dialog → Investigate Moving Account Settings into the Options (Preferences) Dialog
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096006
You need to log in before you can comment on or make changes to this bug.