Dragging a picture to another software drags the URL instead

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: M-Rick, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr-FR; rv:1.7.6) Gecko/20050227 Firefox/1.0.1 (PowerBook)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr-FR; rv:1.7.6) Gecko/20050227 Firefox/1.0.1 (PowerBook)

When dragging a picture from a web page to another document, like a mail in
Apple mail, or Text Edit, instead of dragging the pictures, it drags the URL.
This doesn't respect the Apple Interface guidelines at all and it is very
annoying, needs first to drag on the desktop and then in the appropriate
document ...

Reproducible: Always

Steps to Reproduce:
assuming a dupe, but HIG stuff catches my eye.

Comment 2

13 years ago
probably bug 279270

Comment 3

13 years ago
*** Bug 287178 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Component: OS Integration → Drag and Drop
Product: Firefox → Core
Version: unspecified → Trunk
When you drag, we put both the image and the text in the drag data.  The app
you're dropping into then picks which one it wants.  Sounds like it's just
picking the "wrong" one (not the one you want it to pick).

Comment 5

13 years ago
depend bug234921 ?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Assignee: bugs → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: os.integration
*** Bug 319863 has been marked as a duplicate of this bug. ***

Comment 8

11 years ago
I think Boris Zbarsky hits the point and this bug should be marked invalid and closed.
(In reply to comment #8)
> I think Boris Zbarsky hits the point and this bug should be marked invalid and
> closed.

No, read the discussion in bug 279270, specifically bug 279270 comment 11 (this is basically the drag version of that bug).  The most reasonable workable fix that does what the user intends is to not put the url in the drag at all (since "ordering" the image before text may not help). 

Updated

11 years ago
Duplicate of this bug: 371461

Comment 11

10 years ago
Josh, who's doing Mac drag stuff in Core these days now that Colin's gone? This seems like it might be a fairly simple fix with the right eyes on it.
QA Contact: drag-drop
All,

The last comment seems to be from 2008. Is their any update on this? I switched to Safari as that allowed me to drag and drop images from the browser directly into any image application such as Fireworks CS4. This functionality use to exist in Firefox back in version 2 or so, but broke in a later version.

Now with Safari 4, the functionality has broke once again. So until Apple fixes the problem in their browser hoping Firefox can fix there's. If someone can try, I would be more than happy to help test out solutions. Thanks!
This seems to WFM in Camino 2.0b4 and a recent mozilla-central fx (with Stickies and TextEdit as drag destinations, and the image+link combination Camino banner at the top of http://caminobrowser.org/ as the source).

Poking with Pasteboard Inspector, it looks like we put the image before the other flavors, so unless this is somehow working in 1.9.0 and 1.9.3 but broken in 1.9.1 and 1.9.2, I think this bug is WFM.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Hardware: PowerPC → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.