Crash when dragging URL into address bar [@ msvcrt.dll - nsXPTCStubBase::Stub242 / XPTC_InvokeByIndex ]

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: x22RWEN, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

1.0 Branch
x86
Windows XP
crash
Points:
---
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

The following steps cause Firefox 1.0.2 to crash.

Reproducible: Always

Steps to Reproduce:
1. Go to
http://austinwm.club.fr/HTLM/Photos/T/The_Earthquake/Natural_Disasters_01.jpg
2. Drag the pic into the address bar




Much of the backtrace seems useless, but here's the top:

Program received signal SIGSEGV, Segmentation fault.
0x77c478c0 in strlen () from C:\WINDOWS\system32\msvcrt.dll
(gdb) bt
#0  0x77c478c0 in strlen () from C:\WINDOWS\system32\msvcrt.dll
#1  0x004a1824 in firefox!?SetShowPrintProgress@nsPrintSettings@@UAGIH@Z ()
(Reporter)

Updated

13 years ago
Keywords: crash

Comment 1

13 years ago
I can also reproduce on Windows XP SP2 with Firefox 1.0.2.  Firefox cashes hard
when viewing https://bugzilla.mozilla.org/mozilla-banner.gif and draging the img
to address bar.
CONFIRMING.  

Talk back:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=4642521#id

Stack Trace:
msvcrt.dll + 0x378c0 (0x77c478c0)
nsXPTCStubBase::Stub242  [../../../../../../dist/include/xpcom/xptcstubsdef.inc,
line 244]
XPCWrappedNative::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2034]
XPC_WN_CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1284]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/jsinterp.c,
line 949]
js_Interpret 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/jsinterp.c,
line 2993]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/jsinterp.c,
line 966]
js_Interpret 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/jsinterp.c,
line 2993]
js_Invoke 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/jsinterp.c,
line 966]
nsXPCWrappedJSClass::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp,
line 1318]
nsXPCWrappedJS::CallMethod 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp,
line 449]
XPT_ArenaMalloc 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/xpcom/typelib/xpt/src/xpt_arena.c,
line 232]
nsEventListenerManager::AddScriptEventListener 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1124]
nsEventListenerManager::RegisterScriptEventListener 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1236]
nsXULElement::GetAttrNameAt 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2450]
nsXULElement::GetAttrNameAt 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2426]
nsXULElement::GetAttrNameAt 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2426]
nsGenericElement::GetElementsByTagNameNS 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 1565]
nsHTMLInputElement::Focus 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/html/content/src/nsHTMLInputElement.cpp,
line 1069]
nsGenericElement::GetElementsByTagNameNS 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 1565]
ComputeClipRect 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5480]
PresShell::ContentStatesChanged 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5177]
nsViewManager::DispatchEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2090]
nsViewManager::CreateBlendingBuffers 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1555]
nsViewManager::GetRectVisibility 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/view/src/nsViewManager.cpp,
line 4006]
nsWindow::WidgetToScreen 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 940]
nsNativeDragTarget::QueryInterface 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsNativeDragTarget.cpp,
line 106]
nsNativeDragTarget::DispatchDragDropEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsNativeDragTarget.cpp,
line 208]
ole32.dll + 0x118e86 (0x775f8e86)
ole32.dll + 0x1190c8 (0x775f90c8)
ole32.dll + 0xefc98 (0x775cfc98)
ole32.dll + 0xefb20 (0x775cfb20)
nsDragService::InvokeDragSession 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsDragService.cpp,
line 113]
nsDragService::InvokeDragSession 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsDragService.cpp,
line 93]
nsContentAreaDragDrop::ExtractURLFromData 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsContentAreaDragDrop.cpp,
line 394]
nsEventListenerManager::RegisterScriptEventListener 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1247]
nsEventListenerManager::RegisterScriptEventListener 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1227]
nsXULElement::GetAttrNameAt 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2450]
nsXULElement::GetRef 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 3689]
GlobalWindowImpl::SetNewDocument 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/dom/src/base/nsGlobalWindow.cpp,
line 650]
nsDocument::HasChildNodes 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsDocument.cpp,
line 3019]
nsGenericElement::Normalize 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 1638]
nsGenericElement::JoinTextNodes 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 1632]
nsGenericElement::JoinTextNodes 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 1632]
nsHTMLImageElement::QueryInterface 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/html/content/src/nsHTMLImageElement.cpp,
line 221]
nsEventStateManager::HandleAccessKey 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 957]
nsEventStateManager::PreHandleEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/content/events/src/nsEventStateManager.cpp,
line 664]
ComputeClipRect 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5469]
PresShell::ContentStatesChanged 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5177]
nsViewManager::DispatchEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2090]
nsViewManager::CreateBlendingBuffers 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1555]
nsViewManager::GetRectVisibility 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/view/src/nsViewManager.cpp,
line 4006]
nsWindow::WidgetToScreen 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 940]
nsWindow::DispatchMouseEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5160]
nsWindow::DispatchMouseEvent 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5375]
nsWindow::DealWithPopups 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1237]
USER32.dll + 0x8709 (0x77d48709)
USER32.dll + 0x87eb (0x77d487eb)
USER32.dll + 0x89a5 (0x77d489a5)
USER32.dll + 0x89e8 (0x77d489e8)
PeekKeyAndIMEMessage 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/widget/src/windows/nsAppShell.cpp,
line 91]
nsAppShellService::SetXPConnectSafeContext 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 201]
main 
[c:/builds/tinderbox/Fx-Aviary1.0.1-l10n/WINNT_5.1_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: clean-report
WFM on latest trunk, but I can reproduce on 1.0.2.
Version: unspecified → 1.0 Branch

Comment 3

13 years ago
FF102/WXP -> TB4678559Y
Summary: Crash when dragging URL into address bar → Crash when dragging URL into address bar [@ msvcrt.dll - nsXPTCStubBase::Stub242 / XPTC_InvokeByIndex ]

Comment 4

13 years ago
*** Bug 287848 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Depends on: 288006

Comment 5

13 years ago
*** Bug 287962 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
*** Bug 288872 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Sorry for the dupe.  See Talkback data:
--------------
Talkback data:
--------------
TB4813394W
TB4813236Z
TB4813088M
TB4813060K
TB4810913W

Comment 8

13 years ago
*** Bug 288895 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking-aviary1.5?
Looks to be branch-only, please nominate for b4 if it's in the deer park alpha 2
topcrashers.
Flags: blocking-aviary1.5? → blocking-aviary1.5-

Comment 10

12 years ago
Mass edit: Changing QA to default QA Contact
QA Contact: davidpjames → password.manager

Comment 11

12 years ago
Mass edit: Setting correct QA for location bar/autocomplete. My bad. I forgot I had once been Autocomplete QA too. Hmm, why can't I just set the QA of bugs to the default QA of the component in a mass edit rather than having to do it manually...?
QA Contact: password.manager → location.bar

Comment 12

11 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060925 Minefield/3.0a1 ID:2006092514 [cairo]

--> WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ msvcrt.dll - nsXPTCStubBase::Stub242 / XPTC_InvokeByIndex ]
You need to log in before you can comment on or make changes to this bug.