Closed Bug 28792 Opened 21 years ago Closed 19 years ago

missing a publishing facility in the editor

Categories

(SeaMonkey :: Composer, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.9

People

(Reporter: agn, Assigned: Brade)

References

Details

(Whiteboard: [publish] 120 days)

Attachments

(1 file, 3 obsolete files)

Suggestion:



Shouldn't there be a publishing facility in the editor, which make it

possible to publish documents to a Netscape Enterprise Server (Iplanet

Web Server 4.0)?
yes, publishing is missing; add keyword "help wanted"
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: helpwanted
OS: other → All
Hardware: PC → All
Summary: I'm missing a publishing facility in the editor → missing a publishing facility in the editor
Target Milestone: M20
It would be joly if it would be fixed... before planned M20 deadline.

It is for me the last stopper from using mozilla.
adam@cfar.umd.edu--I agree.  It would be great if this would get fixed.  
Unfortunately at this point, we don't have anyone signed up to do this work.  If 
you know of someone who might be interested in working on this feature, please 
have him or her send me e-mail.  Thanks!
URL: All
*** Bug 32053 has been marked as a duplicate of this bug. ***
reassign my M20 bugs to beppe so the editor rfe's are all in one spot :-)
Assignee: brade → beppe
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Severity: normal → enhancement
Adding 4xp as this was in Netscape 4.x
Keywords: 4xp
moving to future milestone
Target Milestone: M20 → Future
I use "Publish" to put all my weekly status report to 
ftp://ftang@ftang/u/ftang/status/2000 (http://warp/u/ftang/status/2000 ). This 
bug is the reason that I don't want to use Netscape6 to write my weekly status 
report. So... by the request from clayton, put nsbeta2 into keyword. 
"Composer:  Why didn't everybody use Composer to do their status reports this 
week? You must have submitted a dogfood bug if you didn't use it. Funny, I don't 
see any dogfood bugs submitted."
Here it come....
Keywords: dogfood
Making this dogfood- and nsbeta2-, this feature was cut from the product.
Whiteboard: [dogfood-][nsbeta2-]
I'll take a look at this.

Can anyone give me a clear, precise description of how publish is supposed to 
function (any the UI involved, etc.)?  Will the UI and functionality be pretty 
much the save as nav4 composer?  Thanks!
Adding nsbeta2 keyword to bugs with nsbeta2 triage value in status field so the 
queries don't get screwed up
Keywords: nsbeta2
This is one of the reason that I don't use SeaMonkey but use 4.x. PDT meeting
give a dogfood- to this one by arguing that I can work around by 1. save the
document into a local fiel, 2 do a ftp upload. However, this is not ture,
because 1. 4.x allow me to use publish w/ http protocol instead of ftp, 2. there
are no ftp upload in SeaMonkey neither. (see my newly file bug 48548)
er, ryan, don't we have a bug on this already?
I'll take this one and see what I can get done.
Assignee: beppe → rcassin
Status: ASSIGNED → NEW
*** Bug 6257 has been marked as a duplicate of this bug. ***
This looks like a candidate for the "Upgrading to Netscape 6" guide, which 
documents for the existing Communicator customer the changes in features and 
functionality they can expect in N6.
Removing kristif. robinf is now the documentation contact for Composer.
cc myself and Håkan
I'm going to attach a screenshot from Macintosh 4.x; unfortunately it doesn't 
show that next to the filename label should be an edit field.  This isn't the 
final specification for the Publish dialog but it's a start.

Note: there will also need to be a preferences panel implemented for publishing.
Keywords: dogfood, nsbeta2nsbeta1
Whiteboard: [dogfood-][nsbeta2-]
Just to let y'all know: I am working on the XUL for this dialog.
Blocks: 51746
I'm putting this back over into brade's lap, and assigning to 1.0
Assignee: rcassin → brade
Target Milestone: Future → mozilla1.0
Whiteboard: [publish]
Adding roberts, jenm, danielmc, davidjwilliams, and johng to cc: list.

This currently marked as M1.0, but recent feedback from internal users (DogFood)
and 2 distributors (so far), have highlighted that this should be fixed sooner,
than later . . .

Note: Internal 4.x users may be unwilling to migrate to using the new browser.
Some distributor partners have highlighted this as a need to support their
customer base.  
Keywords: nsdogfood
Indeed. I can surely see the need for this for many types of users.
Keywords: nsenterprise
http://curl.haxx.se/ appears to implement what we're after.  Why not contact the
authors on their mailing list and see if they're willing to work on the publish
facility for mozilla?

The libcurl looks perfect for linking with mozilla to provide the publish
functionality.
Depends on: 88208
*** Bug 90036 has been marked as a duplicate of this bug. ***
Depends on: 90550
This is the tracking bug, right?  Adding 90550 (rewriting urls) to the list.
Keywords: nsBranch
clearing out old keywords

this will not make the nsbranch milestone, it is scheduled for the 1.0 milestone
Keywords: helpwanted, nsbeta1
Whiteboard: [publish] → [publish], [nsBranch-]
Removing nsenterprise nomination.
Keywords: nsenterprise
Keywords: nsBranchnsbranch
*** Bug 97384 has been marked as a duplicate of this bug. ***
Blocks: 98550
Minusing this one for this round.
Keywords: nsbranchnsbranch-
Whiteboard: [publish], [nsBranch-] → [publish]
spam composer change
Component: Editor: Core → Editor: Composer
Status: NEW → ASSIGNED
Whiteboard: [publish] → [publish] EDITORBASE 120 days
Attached file XUL dialog based in 4.x version (obsolete) —
This attachment is a basic XUL shell with more or less the same look as the 4.x
version. There is no JS or DTD currently. 

Brade, please provide a spec if you want a different look, and I will implement
it if you like, along with the hooking up of functionality.
Comment on attachment 50502 [details]
XUL dialog based in 4.x version

Patch is not relevant. New specs and follow-up patches will be placed in bug #88208
Attachment #50502 - Attachment is obsolete: true
Blocks: 107067
Keywords: nsbranch-
*** Bug 111218 has been marked as a duplicate of this bug. ***
Depends on: 110779
No longer blocks: 98550
Depends on: 98550
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
Target Milestone: mozilla1.0.1 → mozilla0.9.9
*** Bug 119302 has been marked as a duplicate of this bug. ***
Depends on: 120659
Attached patch changes to composer (obsolete) — Splinter Review
In GetOutputFlags() method in editorUtilities.js:
+      var prefService = GetPrefsService();
+      if (prefService.getBoolPref("editor.prettyprint"))
should be:
+      var prefs = GetPrefs();
+      if (prefs.getBoolPref("editor.prettyprint"))
Comment on attachment 67122 [details] [diff] [review]
changes to composer

I don't think you want to include the changes to editor.js and
editorOverlay.xul, correct?
removing editorbase, adding nsbeta1+
Keywords: nsbeta1+
Whiteboard: [publish] EDITORBASE 120 days → [publish] 120 days
Attached patch updated diffs for Composer (obsolete) — Splinter Review
Attachment #67122 - Attachment is obsolete: true
Comment on attachment 67980 [details] [diff] [review]
updated diffs for Composer

r=cmanske
You might consider using "persistObj" instead of "persistAPI"
Attachment #67980 - Flags: review+
Comment on attachment 67980 [details] [diff] [review]
updated diffs for Composer

sr=hewitt
Attachment #67980 - Flags: superreview+
Comment on attachment 67980 [details] [diff] [review]
updated diffs for Composer

changes checked in; obsolete
Attachment #67980 - Attachment is obsolete: true
Comment on attachment 67980 [details] [diff] [review]
updated diffs for Composer

changes checked in; obsolete
No longer blocks: 107067
Depends on: 124480
This is essentially done; there are a few outstanding issues to be resolved but
users can now publish documents using a daily build.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
publishing framework is in...marking verified in 2/18 build.

a whole new set of bugs arew being filed for the publishing
functionality. Feel free to join in the bug filing, but please
look for DUPS first. Here are an initial set of bugs filed:

126243
126244
126246
126247
126239
126258
126261

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Depends on: 371174
You need to log in before you can comment on or make changes to this bug.