Histroy sidebar doesn't update if folder is open by date and site

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: hidenosuke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050401 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050401 Firefox/1.0+

Site in the history sidebar doensn't update if folder is opned
viewing by date and site.

Reproducible: Always

Steps to Reproduce:
1.Open history sidebar
2.Set view by date and site
3.Open Today folder
4.Open site exclude in the Today folder

Actual Results:  
The site isn't displayed in Today folder.

Expected Results:  
The site is displayed in Tdoday folder.

In the case that the folder is closed, History updates correctly.

Comment 1

14 years ago
I see this in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050329
Firefox/1.0+

It only occurs if the page is already in the history (but not for today). If you
go to a site not in the history it gets added immediately.
Reporter

Comment 2

14 years ago
(In reply to comment #1)
> I see this in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050329
> Firefox/1.0+
> 
> It only occurs if the page is already in the history (but not for today). If you
> go to a site not in the history it gets added immediately.

Yes. My report was not accurate.
Thanks for your help.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Reporter

Comment 4

14 years ago
This is not fixed yet.
Confirming by comment 1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is probably a dupe of bug 173676, this bug has a bit better summary
though. See bug 173676 comment 6.

Other visual polish bugs around History Sidebar:
bug 248766, bug 250551
Reporter

Comment 6

13 years ago
I think this is invalid because  Places doesn't have
'By date and site' method.
Though if you wait long enough, you can call it fixed, since the reinvention of Places as the backend with the current UI should give you a "View by site and date" that doesn't have this bug.
Assignee: bugs → nobody
QA Contact: mozilla → history
Reporter

Comment 8

13 years ago
Latest trunk build doesn't have this problem any more.
New history sidebar based on the Places may fix it.
I confirmed Windows and Linux trunk build.
Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.