Mail Filters not automatically working on Local Folders when united

RESOLVED DUPLICATE of bug 271729

Status

Thunderbird
Account Manager
--
minor
RESOLVED DUPLICATE of bug 271729
13 years ago
13 years ago

People

(Reporter: dmaizer, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; he-IL; rv:1.7.6) Gecko/20050226 Firefox/1.0.1
Build Identifier: version 1.0 (20041206) - hebrew build

After I set all of my mail accounts to use the Local Folders Inbox, Unsent,
etc., and re-created all my Mail Filters on the Local Folders account, the
filters do not automatically run when there's new mail - and everything just
piles up in my Inbox.

Reproducible: Always

Steps to Reproduce:
1.Unite all accounts to use Local Folders
2.Create one or more filters on Local Folders "account"
3.Remove/disable all filters on other accounts
4. D/l new mail - no filtering done

Actual Results:  
No filtering on incoming mail was done

Expected Results:  
Filtering should have been done

If I enter the filters' dialog box and select them all (they're all checked
Active  BTW), and "apply now" them, it works - but that's manual, not automagical.
http://kb.mozillazine.org/Thunderbird_:_FAQs_:_Filters -- see "Creating
filters", second paragraph.

fixed on trunk for 1.1, when using account deferral (global inbox) both the
incoming and target account's filters are run when getting mail (bug 271729
comment 15).

*** This bug has been marked as a duplicate of 271729 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.