Command line options are not launching current version of Netscape 6

VERIFIED DUPLICATE of bug 63454

Status

Core Graveyard
Cmd-line Features
P1
normal
VERIFIED DUPLICATE of bug 63454
18 years ago
9 years ago

People

(Reporter: Grace Bush, Assigned: Samir Gehani)

Tracking

({helpwanted, relnote})

Trunk
PowerPC
Mac System 8.5
helpwanted, relnote
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] relnote-user)

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Download and install NSMacInstaller for 2000022312  (not necessary to remove 
Mozilla Registry or Documents Folder)
2. Installer launches Netscape 6 (or ProfileManager) depending on configuration
3. Close and try to relaunch with Netscape ProfileManager - or any Netscape 
command line icon

Actual results: If 4.x is open, browser comes up with one line ARGS:= 
ProfileManager, if 4.x is not open, and older build of Netscape6 is on system, 
that build will be launched.  If no older build exists, an error message is 
given saying that application cannot be launched because it is in the trash 
(last place build existed before emptying) 
Netscape 6 can be launched with the icon in the Netscape Folder

Expected results: command line options working as before for testing

Simon, I assigned to you since you handled that last 'command line' bug, please 
reassign if this is an error.

Comment 1

18 years ago
This is happening because Netscape 6.0 has the same creator code as 4.x. If you 
rebuild your desktop database, the files should do the right thing in 6.0.

This is a problem that we need to think about.
Status: NEW → ASSIGNED
Target Milestone: M16
(Reporter)

Comment 2

18 years ago
adding Samir to cc list

noting that if Mozilla Registry and Documents are removed, user is confined to 
create and use one profile since no ProfileManager functions are accessible  ( 
can run old build and create some) 

Comment 3

18 years ago
Regarding the rebuild desktop suggestion:  Does the rebuild desktop have to
happen before we install the new build(s)?  Because I tried rebuilding desktop
after I'd installed and that didn't do diddly.

Also adding lchiang to cc list.

And lastly, m16? Thats a ways out...

Comment 4

18 years ago
I'd like to nominate for beta 1:
(1) according to Laurel, rebuilding the desktop does not work for this conflict
(2) no ProfileManager options are available for use if user removes registry 
file (which we sometimes suggest the user to do)
(3) if the user doesn't have an older build, we may not bring the Profile 
Manager up which is needed for new profile creation or migration.

Keywords: beta1

Comment 5

18 years ago
Add dependency on the command-line files type/creator bug 29269
Depends on: 29269

Comment 6

18 years ago
PDT- for beta1. Talked with Simon and we agreed to add these comments to the 
beta1 release note: Recommend to drag command line files directly onto the 
Netscape6 icon, rather than double clicking. Double clicking *may* work if you 
rebuild your desktop database.
Keywords: relnote
Whiteboard: [PDT-]

Comment 7

18 years ago
CC'ing sspitzer and alecf per their request

Comment 8

18 years ago
removing sspitzer from cc my mistake

Updated

18 years ago
Depends on: 32540

Comment 9

18 years ago
-> XPApps
Component: Browser-General → XPApps

Comment 10

18 years ago
M17
Target Milestone: M16 → M17

Comment 11

18 years ago
Samir: I think this would get fixed if the installer opens a Finder window to 
display the newly-installed Netscape, when installation is complete (perhaps it 
does this already?).

This forces the Finder to update the desktop database, which should cause it to 
then use the latest version of 'MOSS' to open files.
Assignee: sfraser → sgehani
Status: ASSIGNED → NEW
Target Milestone: M17 → M18

Comment 12

18 years ago
updating QA contact
QA Contact: asa → sairuh
Component: XP Apps → XP Apps: Cmd-line Features
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: beta1, relnote → relnote2
Keywords: relnote2 → relnote
Whiteboard: [PDT-] → [PDT-] relnote-user
i've added some relnote info in bug 50809, in my 2000-11-02 17:46 comments,
which are likely related to this bug.
(Assignee)

Updated

18 years ago
Priority: P3 → P1
Resetting missed milestones
Target Milestone: M18 → ---
Keywords: helpwanted, nsbeta1-
Netscape Nav triage team: this is not a Netscape beta stopper.
(Assignee)

Comment 16

17 years ago
The fix for bug 63454 will fix this.

*** This bug has been marked as a duplicate of 63454 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 17

17 years ago
verify
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.