bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

dragging separator in bookmarks menu creates empty bookmark

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: Fredrik Branstrom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050402 Firefox/1.0.2 (MOOX M2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050402 Firefox/1.0.2 (MOOX M2)

In my bookmarks menu I've separated groups of subdirectories with separators. I
tried to move one of them and got an empty bookmark where it should have been
moved to. The separator remained in its original place.

I thought this was weird, but I didn't bother much at the time and went on with
my life. However, since that time I've seen it more times and I thought it was
time to report it even though I can't always reproduce it.

I'm going to attach a screenshot to this bug...

Reproducible: Sometimes

Steps to Reproduce:
1. Just start with your own set of bookmarks and make sure you have separators
in the menu.
2. Try to drag a separator.
3. I dragged it upwards, between two folders for example. Try that if you can't
reproduce it, I guess.

Actual Results:  
The bookmarks menu closed as soon as I had dragged the separator, and when I
opened it again, in the place where the separator should now be, was an empty
bookmark with a standard blank icon. See screenshot.

The separator stayed in its original place and stays there even after I delete
the weird empty bookmark.

When I right-click the "dummy", I get the normal 

Expected Results:  
The separator should have moved to its new position and not have stayed in its
original position.

No "dummy" - weird empty bookmark entry - should have been created.

I can delete the "dummy" - sometimes that's fine, and then maybe I can move the
separator if I try again or move it to another place, but sometimes it happens
again. I can't figure out what the behaviour is caused by.
(Reporter)

Comment 1

13 years ago
Created attachment 180727 [details]
The properties window of the "dummy" item that is created...
(Reporter)

Comment 2

13 years ago
Created attachment 180728 [details]
The "dummy" item in the bookmarks menu
(Reporter)

Updated

13 years ago
Attachment #180728 - Attachment description: The properties of the "dummy" item that is created... → The "dummy" item in the bookmarks menu
(Reporter)

Updated

13 years ago
Attachment #180727 - Attachment description: The "dummy" item in the bookmarks menu → The properties window of the "dummy" item that is created...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050414
Firefox/1.0+
I see this also. For the time being I will mark that it depends on bug 288509 as
I suspect if a patch fixes one, it will fix the other.
Status: UNCONFIRMED → NEW
Depends on: 288509
Ever confirmed: true
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050414
Firefox/1.0+

confirmed on Trunk ->NEW
No longer depends on: 288509

Updated

13 years ago
Depends on: 288509
(Reporter)

Comment 5

13 years ago
I forgot to write that last part or the description got truncated... This is
what it should have said:

When I right-click the "dummy", I get the normal properties window, as can be
seen on the screenshot, but all the fields are empty.
A few bookmark and dragging bugs have been fixed recently, can someone confirm
this is still reproducible using a recent trunk build?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050421
Firefox/1.0+

WFM
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050421
Firefox/1.0+
Dragging a seperator in the Bookmarks > menu still results in a bogus bookmark
entry being created for me.

Comment 9

13 years ago
Dragging the seperator indeed results in an emty bookmark for me on:
WinXP Gecko/20050421 Firefox/1.0+
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050422
Firefox/1.0+
OK this seems to be happening sporadically, so here are steps to reproduce for sure.
1. Create a new profile, start filefox with said profile.
2. Go to the Bookmarks > menu
3. Move the mouse over the first divider (directly below "Manage Bookmarks")
4. Click and hold the left mouse button
5. Drag the divider down one space and release the left mouse button

Result: A bogus (empty) bookmark entry is created.

It should be noted that if you do this on an existing profile, and your first
attempt to move the divider goes down past many bookmarks then the bogus entry
may not be created, and then all subsequent attempts to drag&drop the divider
work as expected (no bogus entry created).

Restarting the browser and attempting the repo steps may then create a bogus entry.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050422
Firefox/1.0+(FF0.9 profile/bookmarks)

I can reproduce the last case:
1.when I drag the separator below "Manage Bookmarks.."
2.or drag the one below "Bookmarks Toolbar Folder" and drag it back again
*** Bug 298755 has been marked as a duplicate of this bug. ***
*** Bug 298984 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
Confirmed in:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Assignee: vladimir+bm → nobody
*** Bug 344667 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 17

12 years ago
This bug is still with us in Firefox 2.0 (tested under XP Pro SP2.)  I also noticed that this same bug can be triggered by dragging the top and bottom scrolling arrows (if you have them) into the bookmark list.
WFM in current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081215 Minefield/3.2a1pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.