Helper app dialog incomplete for non-nsStandardURL types

VERIFIED FIXED in mozilla1.8final

Status

()

Toolkit
Downloads API
P1
normal
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: dveditz, Assigned: Gavin)

Tracking

({fixed-aviary1.0.5, regression})

Trunk
mozilla1.8final
fixed-aviary1.0.5, regression
Points:
---
Bug Flags:
blocking-aviary1.0.5 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Spun off from suite bug 290829; similar, but different symptoms and fix.

The helper app dialog tries to protect any user:pass information from prying
eyes. However, if the source URI is of a type that does not support .userPass
then an exception is thrown and the dialog is not initialized properly.

For example, try to load data:foo/bar,blahblahblah and note that there's no
default for the radio buttons, no "Open" with dropdown, etc.
Created attachment 181231 [details] [diff] [review]
Toolkit patch

Same patch as the core version ported to toolkit.
Assignee: bugs → gavin.sharp
Status: NEW → ASSIGNED
Attachment #181231 - Flags: review?(mconnor)
Priority: -- → P1
Target Milestone: --- → Firefox1.1

Updated

13 years ago
Attachment #181231 - Flags: review?(mconnor) → review+
Attachment #181231 - Flags: approval-aviary1.1a?
Whiteboard: [patch-r+] [checkin needed]

Comment 2

13 years ago
Comment on attachment 181231 [details] [diff] [review]
Toolkit patch

a=asa
Attachment #181231 - Flags: approval-aviary1.1a? → approval-aviary1.1a+
Whiteboard: [patch-r+] [checkin needed] → [patch-r+][checkin needed][a+]
Checked in by timeless.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [patch-r+][checkin needed][a+]
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0.4?
(Reporter)

Updated

13 years ago
Blocks: 291627
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0.5? → blocking-aviary1.0.5+
Keywords: regression
Whiteboard: have patch
(Reporter)

Comment 4

13 years ago
*** Bug 291627 has been marked as a duplicate of this bug. ***
Created attachment 185825 [details] [diff] [review]
Branch patch

Patch against the branch. The other patch probably still applies, but a fresh
patch doesn't hurt. Requesting approval for a simple, low risk regression fix.
I don't have checkin access, so if someone could check this in once approved
that would be great.
Attachment #185825 - Flags: approval-aviary1.0.5?
(Reporter)

Comment 6

13 years ago
Comment on attachment 185825 [details] [diff] [review]
Branch patch

a=dveditz for the branch. Land soon if you're going to
Attachment #185825 - Flags: approval-aviary1.0.5? → approval-aviary1.0.5+
(Reporter)

Updated

13 years ago
Whiteboard: have patch → need landing
Landed by mconnor, adding fixed-aviary1.0.5.
Keywords: fixed-aviary1.0.5
verified fixed with 200506170x-1.0.5 firefox builds on linux fc3 and mac os x 
10.4.1. the resulting helper app dialog now contains a choice between the Open
with (button to Browse for app) and Save to Disk radiobuttons.
Status: RESOLVED → VERIFIED
Whiteboard: need landing

Updated

12 years ago
Flags: testcase+

Updated

11 years ago
Flags: in-testsuite+ → in-testsuite?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.