Double-check Opera shortcuts for accuracy

RESOLVED DUPLICATE of bug 310419

Status

--
minor
RESOLVED DUPLICATE of bug 310419
14 years ago
3 years ago

People

(Reporter: jwalden+fxhelp, Assigned: jwalden+fxhelp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

I mentioned in bug 263228 comment 8 that we needed to double-check shortcuts for
accuracy but never noticed a comment in response (the referenced URL).  Now,
it's finally time to follow up on bug 263228 comment 15 (which has been sitting
in my inbox for about 5 months now), which was a reminder to follow up on the
incorrect keyboard shortcuts.

This would be nice to get for 1.1, but because we're not actually evangelizing
Opera and the information's not actually going to be used by Firefox Help end
users, it's not pressing.

See also the following URL for more keyboard shortcut source material:

http://www.opera.com/features/keyboard/

This shouldn't be difficult to do, but there's a decent chance that I lack
sufficient time to get it done along with everything else I'd like to get for 1.1.

Comment 1

14 years ago
See also bug 298835, which is sort of a duplicate of this one, but some
shortcuts are checked there.

Comment 2

14 years ago
Posted patch Updates Opera Shortcuts (obsolete) — Splinter Review
Some Opera Shortcuts only work on the Numeric Pad, I marked those ones with
Numeric as per http://www.opera.com/features/keyboard/.
There is a mix of <br/> and <br /> tags in the document, I always used <br />.
Attachment #187504 - Flags: review?(steffen.wilberg)

Comment 3

14 years ago
Posted patch Updates Opera Shortcuts (obsolete) — Splinter Review
Fixes Opers Forward Shortcuts.
Attachment #187504 - Attachment is obsolete: true
Attachment #187507 - Flags: review?(steffen.wilberg)

Comment 4

14 years ago
(In reply to comment #3)
> Created an attachment (id=187507) [edit]
> Updates Opera Shortcuts
> 
> Fixes Opers Forward Shortcuts.

Why did you switch the order of decrease and increase.  I can see the logic
because the shortcuts are 0 and 9, but it was sorted alphabetically.

Comment 5

14 years ago
*** Bug 298835 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Attachment #187504 - Flags: review?(steffen.wilberg)

Comment 6

14 years ago
Comment on attachment 187507 [details] [diff] [review]
Updates Opera Shortcuts

Please provide enough context so I can see what your changes are about. Use
e.g. cvs diff -u8, where 8 is the numer of lines of context. Use an even larger
numer if necessary.

<br /> is a hack for old browsers like Netscape 4. Please use <br/> instead.

Don't change Text Size Decrease/Increase, it's ordered alphabetically.
Attachment #187507 - Flags: review?(steffen.wilberg) → review-
(Assignee)

Comment 7

14 years ago
I've been incredibly slackerly recently regarding this bug, and I should have
posted weeks ago that I was working on getting updates from the Opera forums. 
Anyway, here's the info I got there:

http://my.opera.com/forums/showthread.php?postid=958169#post958169

> Stop: Not only Esc, but also ctrl+.
> Move to next/previous frame: 3 and shift+3 respectively.
> Text size increase / decrease (actually total page zoom in Opera): numeric +
> and - as well as the numbers you list.
> Find as you type - link: , (comma) or Shift + (numeric) /
> Find as you type - text: . (period)or (numeric) /
> Find again / previous: ctrl+(shift)+G as well as (shift+)F3.
> Close window: ctrl+shift+w instead of ctrl+w (that one just closes a
> page/tab, never a window).
> New tab: ctrl+n instead of ctrl+alt+n.
> Bookmarks (in panel) has become ctrl+2 by default, instead of ctrl+1. The
> others are correct.
> Downloads/transfers (in panel) has become ctrl+7 instead of ctrl+5.
> CTRL+alt+T is also correct.
> Select location bar: this is H instead of CTRL+H. (CTRL+H hides Opera into
> the system tray, H puts focus in the address field just like F8, but also
> shows the internal history list dropdown.)

Anyway, please use the above information while creating a patch.  (I haven't
looked at the patches posted here, so I don't know how much of the above you've
addressed.)

In cases where you have the option of adding another shortcut in addition to
what's listed for Opera, *do not do so*.  We should refer to the main shortcut
(the one that's most prominent in the Opera UI) only, because the Opera
shortcuts are displayed only for reference and don't need to be as in-depth as
an Opera site might list them.

Finally, once we have a patch that passes Steffen's initial review, I want to
take what we have and post it in that thread and let the Opera people give it a
once-over, so we want to move quickly here so that we can get this in front of
them and approved in time for the l10n freeze, whenever it is.

Comment 8

14 years ago
I've made a bit of a mess of making this patch on my own system. I know this
patch isn't perfect but I hope any small problems can be fixed on check-in.
Attachment #187507 - Attachment is obsolete: true
Attachment #197339 - Flags: review?(jwalden+fxhelp)
(Assignee)

Comment 9

14 years ago
I'm reevaluating whether we actually want to have to go through the hassle of
maintaining shortcut lists for applications we don't actually care about (and
really, how much does it help the user to be able to compare keyboard and mouse
shortcuts?), so the solution may just be to rip out all the non-Firefox keyboard
and mouse shortcuts listed in Firefox Help.  (It might be worthwhile moving them
onto mozilla.org, but if it's decided that's a good idea, fixing that problem
will be beyond the scope of Firefox Help documentation and in the scope of
Firefox product site work.)
(Assignee)

Comment 10

14 years ago
(In reply to comment #8)

Per discussion in bug 310419, we're removing keyboard shortcuts for other
browsers from our documentation.  It's less work for us, and they're not really
helpful in telling people how to use *Firefox*.

I hope you didn't spend too much time making this patch; it's been something
that I've been kicking around for a while, but I haven't yet had the motivation
to actually make a decision and follow through on it.  Sorry for wasting your
time on this...

*** This bug has been marked as a duplicate of 310419 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

14 years ago
Attachment #197339 - Flags: review?(jwalden+fxhelp)
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.